Fedora 37 beta - system dies freezes after login, but only when the second monitor is on. Help!

Hello everyone,
I have a really odd issue on my desktop with Fedora 37 beta.
It is fully up to date, running on the 5.19.11-300 kernel. Gnome 43 running on Wayland. I have the latest akmod-nvidia drivers installed for my 3080.

I get the login screen just fine. After I log in, both screens go into “no signal mode” and go to sleep. The desktop never comes up. I also know it never loads into the desktop because if i hit the “super button”, type restart, hit enter, hit tab, hit enter - the system doesn’t reboot. This would have worked if I was just getting no picture but the system was actually loaded into the desktop.

Here is the weirdest part…if I login with the second screen turned off, everything works every single time. I get the desktop to come up every time.

Why is Fedora 37 freaking out when I have a second monitor turned on? I loads fine into the login screen where I type my password, but after that it hard freezes.

Any ideas? Thank you!

Have you tried the same when logging in with xorg? I had an issue with wayland that was similar but xorg did not cause any similar problems.

I have not (yet). I wanted to stick with Wayland/Gnome going forward. If I go back to using xorg, I might as well switch back to KDE. :smiley:

Also, this does seem to be related to the nVidia driver. I am not getting this behavior when I uninstall it and fall back to nouveau.

Also, if I turn off the second monitor, log in, and then turn it back on - everything works. So weird. It just doesn’t like for it to be on during the login.

1 Like

To narrow down the problem try xorg. If the results are different it confirms the issue is wayland related. If the results are not different then the cause still needs to be identified.

Locating and solving a problem involves testing to identify the conditions under which the problem is seen.

I just tried it. Works fine under xorg/x11.

Ok, now you know the issue is wayland related and you could file a bug with your findings against wayland itself. Note you are on f37 so it would be filed against the beta version. Probably should be done soon so it may be fixed before the final release.

Sorry, I am brand new to Linux (2 months usage).
Where is the correct place to file bugs for Fedora / Wayland / nVidia driver.

I can do it today. Just need to make sure it’s the right place. :+1:

Thank you!

bugzilla.redhat.com, and you can log in using the same credentials as you use on this forum simply by selecting to login using your Fedora Account System credentials.

This seems to be wayland fedora but not nvidia related.

Might be nVidia related, becuase if I uninstall the akmod-nvidia driver (and it falls back to nouveau) then I can log in using Wayland without any issues.

Thank you for all your help! I’ll submit an issue there!

If it is in fact related to nvidia + wayland then a bug report there is not appropriate. Possibly instead report the bug to both wayland developers and via the rpmfusion web site about nvidia. Nvidia and Wayland have been working very hard to ensure wayland works with nvidia, but it would not be appropriate to report that bug to the redhat bugzilla site since fedora does not directly support nvidia drivers…

1 Like

I already reported it there.
And they already corrected me that it is not a Wayland issue, but either mutter or nVidia driver issue.