Installer doesn't launch and I'm losing my mind

Hello, All!
I am brand new to Linus systems and am trying to install Fedora 40 as a means of learning and working through my brand new copy of Linux Bible (10th edition). However, I am encountering issues before getting started and therefore am struggling to troubleshoot the issues.

I’ll describe steps taken below, but here is the general issue. Once I have a Fedora 40 Workstation Live media running and I tell it to install, the mouse turns to a wheel, spins for about 1 minute and then nothing happens.
All other functionality of the live media seems to be fine.

When I open the system monitor, I see as many instances of the installer running, as attempts I’ve made to run it.

I am using the fedora media writer to create a bootable USB stick. One stick is 16 GB and the other is 64 GB, and I get the same results with either one. I am choosing Official Editions of Fedora Workstation:
Version: 40
Hardware Architecture: Intel/AMD 64bit

I have tried it with the following configurations, mostly taken from some other posts I’ve read:
1. Download automatically option, and have tried both the delete download after writing option, selected and unselected.
2. I was able to install a working copy of Fedora on to a VM player Workstation 17 VM on another machine, so I tried using that iso. Same version that seems to get downloaded if I try the media writer
3. I tried using the media write from both the machine that I want to install Fedora on, and another windows 11 machine.
4. I turned off Windows autoplay settings both on the Windows 11 machine I mentioned above, and the target machine.
5. Change my BIOS boot options to UEFI and tried both secure boot on and off
6. started Fedora from the media drive by checking the media, without checking the media, and by selecting troubleshoot and booting it with the minimal video settings option.

No matter which of these methods I try, I get the same symptoms above.
After a few attempts, I did catch this message that flashes for a moment, and then I get the options to open the media:

At one point, not really knowing what I’m doing or what else to try, while booted in the live media, I tried to find the stick, and manually mount it. I got this message:

I am trying to install it on a refurbished Dell Optiplex 9020. it’s currently running Windows 10 Pro.
Here are the specs that I can think of that might be relevant, but PLEASE let me know if anyone needs more info:
Intel HD Graphics 4600
Intel Core i7-4770 CPU @ 3.4GHz
64-bit operating System x64 bas processor
ACPI x64-bsed PC

Please, any advice you have I’m in. I really want to be a part of this community. I want these skills for personal and career reasons.

Thank you all so much in advance!

1 Like

Can you see your drive(s) on the live media? Open the terminal emulator and type lsblk --fs and see if it finds your disk(s) correctly.


Can you load BIOS defaults and try again ? Assuming the latest BIOS version is installed…


Hi @inautumn , welcome to the Fedora Discourse community :fedora: .

You have made several attempts to perform the installation from the live media and have described several issues.

Should you not solve the issue as per the instructions above, there is one thing that cought my eye in your post:

Are you running the installation behind a VPN or firewall? My take is that if you don’t start the installer several times, i.e. click on it just once, then wait patiently for several minutes (could be more than five), the installer would start. If this is true, I reckon it has to do with the issue described in this post.

There are several workarounds described in that linked topic, I am not sure if they are persistent/effective in a live session though. You could try them, and if they are not working, then please give the installer several minutes until it starts, as mentioned above.

This is just a guess though, your issue might still not be related to the one I mentioned.


I think one of the first things the installer will try to do is analyze the disks. I’ve seen reports about Fedora’s Anaconda installer failing when trying to access/analyze some MS Windows recovery partitions. I would suggest that you try running sudo wipefs -a /dev/sdX from a terminal before starting the installer and see if that eliminates the error. (That command will erase all the existing partitions from the disk, so be sure to substitute /dev/sdX with the path to the disk that you want to erase.)


If you are able to use the Live session and the issue is that the installer doesn’t seem to start, I would take a look at the logs /tmp/anaconda.log to get some clues.


Firstly, thank you all for the responses. I’m feeling very welcomed to the community. I updated my bios and now I keep getting a different set of errors. I am studying tonight and then I will update with my progress, and individual efforts related to your responses.

Again, Thank you all endlessly.


Ok I figured it out.
I have a Wi-Fi adapter in that system that it didn’t like.

When I tried launching the installer from the terminal I would get this message:

I implied from the fact that udev manages peripheral devices that it was hardware and that’s the only non factory component I added.

Thanks again everyone. It was your recommendations that sent me on the right path.

I feel welcomed by the community and I’m sure I’ll be back!