Fedora installer crashes after clicking "Install Fedora..."

The problem is the unability to enter installer of Fedora 39 to achieve dual boot installation alongside with Windows 11. Windows in installed on GPT drive.

Target Machine
Model: Lenovo Ideapad 330-15IKB
BIOS manufacturer: InsydeH20
BIOS version: 8TCN61WW

Method 1

Bootable media created by Fedora Media Writer as ISO is downloaded automatically through the application.

Config Specs
Edition: Workspace
Version: 39
Architecture: Intel/AMD 64bit
USB Drive: 31 GB

Try 1

  1. Plug the media into the target machine
  2. Proceed with “Test this media & start Fedora-Workstation-Live 39”

Try 2

  1. Plug the media into the target machine
  2. Proceed with “Start Fedora-Workstation-Live 39”
  3. Click “Install Fedora…” on the Welcome to Fedora app

System opens Install to Hard Drive app but it crashes immediately.

Method 2

Bootable media created by Fedora Media Writer as ISO is downloaded automatically through the application.

Config Specs
Edition: Silverblue
Version: 39
Architecture: Intel/AMD 64bit
USB Drive: 31 GB

Try 1

  1. Plug the media into the target machine
  2. Proceed with “Test this media & start Fedora-Workstation-Live 39”

Method 3

Bootable media created by Rufus as ISO is downloaded from the fedoraproject.org page.

Config Specs
ISO: Fedora-Workspace-Live-x86_64-39-1.5.iso
Partition: GPT
Target: UEFI (not CSM)
USB Drive: 31 GB

Try 1

  1. Plug the media into the target machine
  2. Proceed with “Test this media & start Fedora-Workstation-Live 39”

Result is the same as in Method 1 - Try 1.

Passed Troubleshooting

  1. Restore BIOS default values
  2. Change Partition to MBR (changes Target to BIOS or UEFI as well) in Rufus and try in UEFI / Legacy modes in BIOS
  3. Different USB drive for all the methods above
  4. Boot through ‘Start Fedora-Workstation-Live 39 in basic graphics mode’
  5. Add nomodeset to the grub config and boot
  6. Remove rhgb from the grub config and boot
  7. Remove quiet from the grub config and boot
  8. Try with Fedora 36 and Fedora 31

Bootable media with Zorin-OS-17-Core-64-bit.iso gets to the installer without any problems. What could be the possible cause here that is preventing execution of Install to Hard Drive app?

You should double verify the integrity of the ISO file you’ve downloaded as it failed the checks in the first screenshot:

Thank you for the tip. There was a problem verifying the ISO on the Windows, however I successfully verified it on macOS. After that I found out the problem is that USB driver gets corrupted after it’s plugged into the computer which first boots into Windows. The solution for the first problem is to remember the correct key to access the boot menu and boot only the USB driver after is freshly flashed.

However, I’m still stuck at the second problem which is the crash of the installer. I have tried the same USB drive on a different computer and the problem wasn’t present. We can assume the problem is probably related to the configuration of the target machine. What is there to check next?

Some have seen this problem with specific systems. The apparent work-around for those systems seems to be – install F38 or F37 and then do the online upgrade to F39.

The iso for F37 or F38 can be downloaded from here

1 Like

Yes, I have spotted this solution for a similar problem: Install media don't boot in UEFI mode on certain motherboards

I have downloaded Fedora 36 from here, verified and flashed on USB drive. The problem still persists.

In the meantime I have tried these steps as well:

  • Boot through ‘Start Fedora-Workstation-Live 39 in basic graphics mode’
  • Add nomodeset to the grub config and boot
  • Remove rhgb from the grub config and boot
  • Remove quiet from the grub config and boot

Three options of grub edit were tried with Fedora 36 as well.

I have also found two different answers to the secure boot topic. One recommends have it disabled as it could be potentialy causing troubles while other recommend to enable it that it’s already stable with Fedora. What is the current status?

Fedora has been able to use secure boot for several years. During installation it usually makes no difference, but that also might depend upon the hardware.

One thing I might guess is that in cases where you have certain GPUs that may cause an issue.

Please provide details on exactly what you see when the installer ‘crashes’. Potentially the details may provide more guidance on how to fix this error.

1 Like

The laptop has two GPUs AMD Radeon 530 and Intel UHD Graphics 620. I’m not sure how to find out which one could cause trouble and which one is it actually trying to use during the installation.

Here is a video of the whole process from the boot to the crash: Watch video | Streamable

Thank you for the assistance!

The video has very little useful content, but my impression is that the Live Fedora environment has a problem with your hardware. Your previous images show:

[FAILED] Failed to start checkiosmd5dev-sdb.service failed because the control process exited with error code.

The second attempt shows a the anaconda program crashing while trying to analyze the storage configuration with UnicodeDecodeError: 'utf-8' codec can't decode byte 0xf2 .... This could indicate a hardware issue or a recent innovation in storage configuration data that linux doesn’t yet handle.

You might be able to find a couple frames near the end with some hints, but you should try using the Live Linux environment to collect information. Please start a terminal and shows us the output from ls /dev and posting the output here as text using the </> button (you should be able to login to this site from the Live Fedora environment, or you can redirect output to a file and save to another drive (the Live Fedora environment exists in RAM, so any changes you make are lost).

I suggest running inxi -Fzxx in a terminal (you may have to install a package using dnf). You can also scan error messages in a terminal using dmesg or (assuming it is available in the Live environment, journalctl).

1 Like

I think the first error was caused by booting into the Windows with USB drive plugged in. I have reproduced the exact same error on a different machine by exact same method. It’s now solved as I have written in the first reply.

Now about the commands you have asked for that can help in investigation.

ls
liveuser@localhost-live:~$ ls /dev
autofs           loop2         snd     tty36   ttyS11   userfaultfd
block            loop-control  stderr  tty37   ttyS12   v4l
bsg              lp0           stdin   tty38   ttyS13   vcs
btrfs-control    lp1           stdout  tty39   ttyS14   vcs1
bus              lp2           tpm0    tty4    ttyS15   vcs2
char             lp3           tpmrm0  tty40   ttyS16   vcs3
console          mapper        tty     tty41   ttyS17   vcs4
core             mcelog        tty0    tty42   ttyS18   vcs5
cpu              media0        tty1    tty43   ttyS19   vcs6
cpu_dma_latency  mei0          tty10   tty44   ttyS2    vcsa
cuse             mem           tty11   tty45   ttyS20   vcsa1
disk             mqueue        tty12   tty46   ttyS21   vcsa2
dm-0             net           tty13   tty47   ttyS22   vcsa3
dm-1             null          tty14   tty48   ttyS23   vcsa4
dma_heap         nvram         tty15   tty49   ttyS24   vcsa5
dri              port          tty16   tty5    ttyS25   vcsa6
drm_dp_aux0      ppp           tty17   tty50   ttyS26   vcsu
drm_dp_aux1      ptmx          tty18   tty51   ttyS27   vcsu1
fb0              pts           tty19   tty52   ttyS28   vcsu2
fd               random        tty2    tty53   ttyS29   vcsu3
full             rfkill        tty20   tty54   ttyS3    vcsu4
fuse             rtc           tty21   tty55   ttyS30   vcsu5
hidraw0          rtc0          tty22   tty56   ttyS31   vcsu6
hidraw1          sda           tty23   tty57   ttyS4    vfio
hidraw2          sda1          tty24   tty58   ttyS5    vga_arbiter
hpet             sda2          tty25   tty59   ttyS6    vhci
hugepages        sda3          tty26   tty6    ttyS7    vhost-net
hwrng            sda4          tty27   tty60   ttyS8    vhost-vsock
initctl          sda5          tty28   tty61   ttyS9    video0
input            sdb           tty29   tty62   udmabuf  video1
kfd              sdb1          tty3    tty63   uhid     watchdog
kmsg             sdb2          tty30   tty7    uinput   watchdog0
kvm              sdb3          tty31   tty8    urandom  zero
live-base        sg0           tty32   tty9    usb      zram0
log              sg1           tty33   ttyS0   usbmon0
loop0            shm           tty34   ttyS1   usbmon1
loop1            snapshot      tty35   ttyS10  usbmon2
inxi
liveuser@localhost-live:~$ inxi -Fzxx
System:
  Kernel: 6.5.6-300.fc39.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.40-13.fc39
  Desktop: GNOME v: 45.0 tk: GTK v: 3.24.38 wm: gnome-shell dm: GDM
    Distro: Fedora Linux 39 (Workstation Edition)
Machine:
  Type: Laptop System: LENOVO product: 81DE v: Lenovo ideapad 330-15IKB
    serial: <superuser required> Chassis: type: 10 v: Lenovo ideapad 330-15IKB
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN
    serial: <superuser required>
    part-nu: LENOVO_MT_81DE_BU_idea_FM_ideapad 330-15IKB UEFI: LENOVO
    v: 8TCN61WW date: 05/19/2021
Battery:
  ID-1: BAT0 charge: 24.1 Wh (98.4%) condition: 24.5/30.0 Wh (81.5%)
    volts: 8.5 min: 7.5 model: SMP L16M2PB1 serial: <filter>
    status: not charging
CPU:
  Info: quad core model: Intel Core i5-8250U bits: 64 type: MT MCP
    arch: Coffee Lake rev: A cache: L1: 256 KiB L2: 1024 KiB L3: 6 MiB
  Speed (MHz): avg: 645 high: 800 min/max: 400/3400 cores: 1: 400 2: 800
    3: 800 4: 400 5: 762 6: 800 7: 400 8: 800 bogomips: 28800
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel
    arch: Gen-9.5 ports: active: eDP-1 empty: DP-1,HDMI-A-1,HDMI-A-2
    bus-ID: 00:02.0 chip-ID: 8086:5917
  Device-2: AMD Topaz XT [Radeon R7 M260/M265 / M340/M360 M440/M445 530/535
    620/625 Mobile] vendor: Lenovo driver: amdgpu v: kernel arch: GCN-3 pcie:
    speed: 2.5 GT/s lanes: 1 bus-ID: 01:00.0 chip-ID: 1002:6900 temp: 38.0 C
  Device-3: Chicony EasyCamera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 bus-ID: 1-8:5 chip-ID: 04f2:b628
  Display: wayland server: X.org v: 1.20.14 with: Xwayland v: 23.2.1
    compositor: gnome-shell driver: gpu: i915 display-ID: 0
  Monitor-1: eDP-1 model: ChiMei InnoLux 0x15d5 res: 1920x1080 dpi: 142
    diag: 394mm (15.5")
  API: OpenGL v: 4.6 vendor: intel mesa v: 23.2.1 glx-v: 1.4 es-v: 3.2
    direct-render: yes renderer: Mesa Intel UHD Graphics 620 (KBL GT2)
    device-ID: 8086:5917 display-ID: :0.0
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:9d71
  API: ALSA v: k6.5.6-300.fc39.x86_64 status: kernel-api
  Server-1: JACK v: 1.9.22 status: off
  Server-2: PipeWire v: 0.3.80 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: speed: 2.5 GT/s lanes: 1
    port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:8168
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
    vendor: Lenovo driver: ath10k_pci v: kernel pcie: speed: 2.5 GT/s lanes: 1
    bus-ID: 03:00.0 chip-ID: 168c:0042
  IF: wlp3s0 state: down mac: <filter>
Bluetooth:
  Device-1: Qualcomm Atheros driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 bus-ID: 1-7:4 chip-ID: 0cf3:e500
  Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: <filter> bt-v: 4.2 lmp-v: 8
Drives:
  Local Storage: total: 491.26 GiB used: 6.12 GiB (1.2%)
  ID-1: /dev/sda vendor: Patriot model: P200 512GB size: 476.94 GiB
    speed: 6.0 Gb/s serial: <filter> temp: 40 C
  ID-2: /dev/sdb vendor: SanDisk model: USB 3.2Gen1 size: 14.32 GiB
    type: USB rev: 2.1 spd: 480 Mb/s lanes: 1 serial: <filter>
Partition:
  ID-1: / size: 7.36 GiB used: 6.12 GiB (83.2%) fs: ext4 dev: /dev/dm-0
    mapped: live-rw
Swap:
  ID-1: swap-1 type: zram size: 7.65 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 42.0 C pch: 41.5 C mobo: N/A gpu: amdgpu
    temp: 38.0 C
  Fan Speeds (rpm): N/A
Info:
  Memory: total: 8 GiB available: 7.65 GiB used: 2.89 GiB (37.7%)
  Processes: 321 Power: uptime: 15m wakeups: 0 Init: systemd v: 254
    target: graphical (5) default: graphical
  Packages: Compilers: N/A Shell: Bash v: 5.2.15 running-in: gnome-terminal
    inxi: 3.3.33

Is it clear which component is causing the problem?

I guess errors in dmesg are displayed by red. In that case these are the ones that occurred:

Summary

[ 0.130171] x86/cpu: SGX disabled by BIOS.

[ 13.082666] kfd kfd: amdgpu: TOPAZ not supported in kfd

Maybe those printed in bold could be helpful as well:

Summary

[ 0.200508] MDS CPU bug present and SMT on, data leak possible. See https://www.kernel.org/doc/html/latest/admin-guide/hw-vuln/mds.html for more details.

[ 0.200508] MMIO Stale Data CPU bug present and SMT on, data leak possible. See https://www.kernel.org/doc/html/latest/admin-guide/hw-vuln/processor_mmio_stale_data.html for more details.

[ 8.210396] usb: port power management may be unreliable

[ 8.210699] i8042: PNP: PS/2 appears to have AUX port disabled, if this is incorrect please boot with i8042.nopnp

[ 8.218858] device-mapper: core: CONFIG_IMA_DISABLE_HTABLE is disabled. Duplicate IMA measurements will not be recorded in the IMA log.

[ 10.078289] r8169 0000:02:00.0: can't disable ASPM; OS doesn't have ASPM control

[ 10.799395] GPT:Primary header thinks Alt. header is not at the end of the disk.

[ 10.799397] GPT:4159671 != 30031871

[ 10.799399] GPT:Alternate GPT header not at the end of the disk.

[ 10.799399] GPT:4159671 != 30031871

[ 10.799401] GPT: Use GNU Parted to correct GPT errors.

[ 13.073115] ATPX version 1, functions 0x00000033

[ 13.073193] ATPX Hybrid Graphics

[ 13.115670] amdgpu: can't get the mac of 5

[ 20.730704] amdgpu: can't get the mac of 5

[ 21.168033] kauditd_printk_skb: 28 callbacks suppressed

[ 21.573599] Bluetooth: hci0: HCI Enhanced Setup Synchronous Connection command is advertised, but not supported.

[ 22.401454] dbus-broker-lau[1239]: memfd_create() called without MFD_EXEC or MFD_NOEXEC_SEAL set

[ 36.179039] amdgpu: can't get the mac of 5

[ 46.769532] amdgpu: can't get the mac of 5

[ 899.149105] amdgpu: can't get the mac of 5

Looks like there is a problem with SSD and GPU? Can you confirm the cause?

I see kernel: x86/cpu: SGX disabled by BIOS. on a Dell desktop, so I think you can ignore it.

Your model has many entries in the https://linux-hardware.org/?view=computers&type=Notebook&vendor=Lenovo&model=IdeaPad+330-15IKB+81DE so should be well supported, which points to either outdated firmware or a hardware issue.

Since your AMD GPU is:

AMD Topaz XT [Radeon R7 M260/M265 / M340/M360 M440/M445 530/535

the kfd kfd: amdgpu: TOPAZ not supported in kfd message may indicate that you are missing a firmware update. You should be able to run the installer using only Intel UHD Graphics 620, but it is wise to make sure you have all the vendor firmware updates so you don’t waste time on a problem that has already been solved.

1 Like

Thanks for the analysis. As I assume by firmware you mean BIOS, it is updated to the newest version. How can I tell the USB drive to boot the live using the Intel GPU?

Booting the Installation (from F36). This section is missing from more recent documentation – hope it still appplies.

1 Like

I couldn’t find any info related to setting a GPU. Searched also here but without luck.

Are they any other options?

There is a similar bug report here: Cannot Install Fedora 27 Workstation ISO on HP Pavilion

In that report, someone said that they were able to work around the problem by deleting the MS Windows recovery partition.

It looks like this is a bug that has been around for a while:

https://bugzilla.redhat.com/show_bug.cgi?id=1578077

https://bugzilla.redhat.com/show_bug.cgi?id=1626414

2 Likes

Try editing the kernel command line (the F36 document has instructions) to replace rhgb quiet wiith modprobe.blacklist=amdgpu.

Your BIOS may have an option to disable the AMD GPU. People who use laptops away from power sources (long flights, or reading the manuals for agricultural machines that break down miles from any source of power) often need to keep the GPU from using power, so it is a common BIOS option.

2 Likes

This was exactly the same problem. However, only deleting the recovery partition did not help to resolve the issue on my machine.

What worked for me was to format the whole disk and install Windows again. After that I tried to install Fedora as usual and installation was successful.

Looks like these bugs won’t be fixed in the future as they are marked as “CLOSED EOL”. I hope this thread will help others facing the similar issue. Thank you for your time everyone.

2 Likes

Yeah, apparently something about the way MS Windows creates its partitions can, for some random few, prevent Fedora Linux from installing.

It’s probably better to install Fedora Linux first if you want a dual boot system anyway since MS Windows also makes the EFI System Partition too small to accommodate other installations on the same disk.

Another option might be to install a secondary hard disk or SSD in your PC and use one disk for MS Windows and a separate disk for Fedora Linux. Most BIOSs will let you select which disk to boot from by pressing F12 when powering on or rebooting your system.

2 Likes

The reasoning is valid but it seems mandatory to install windows first since MS tends to overwrite grub and only windows will boot when it is the last installed.

Better to enlarge the efi partition with gparted before doing the install of fedora after installing windows.

2 Likes