Fedora live is stuck after basic.target is reached

Hey guys,

After a treacherous few days of choosing, I have decided to install Fedora 40 as my daily driver instead of Windows (I know it took me long enough). However, during the boot sequence for Fedora 40 KDE, Workstation, and Fedora 39 Workstation, the Fedora live won’t boot. In fact, it freezes after basic.target is reached, and I don’t know what could be causing this.

Things I tried:

  • Took out the Windows SSD (it will be a subsystem)
    
  • Removed the graphics card
    
  • Set BIOS to Legacy + UEFI (also tried to boot USB as Legacy and UEFI)
    
  • Turned off XMP
    

Build:

  • MSI Z97 Gaming 7 (newest firmware)
    
  • Intel i5-4570
    
  • 16GB DDR3
    
  • 1TB WD Black SN850X
    
  • 250Gb WD Black SN770 (Windows ssd)
    
  • MSI GTX 1070 G8
    

I also tried to create the thumb drive with Rufus and Fedora Media Writer.

Added f40

Have you tried the troubleshooting option in the very first boot screen where it gives you thee 3 options?
The system will probably boot and install with basic graphics mode from the troubleshooting option.

UEFI is preferred on almost all systems at this point in time.

Yes, I also tried that. However, the same issue appears.

Since you have tried 2 different versions of Fedora and also 2 different ways to place the ISO file onto the thumb drive, could it be the thumb drive itself?
Do you have a different one to try it out?

Yes, I also tried that.

  1. Thumb drive I used is an old 2.0 with 8GB.
  2. Thumb drive I used is a new 3.1 SanDisk with 16GB.
    However, the same issue persists.

I’m thinking of 1 other possibility, but I’m almost sure it can’t be that:
In my BIOS I have an option to Enable/Disable boot from USB, but I would expect when it is set to Disable that you won’t even come that far in the boot process.

Another thing: is Secure Boot “On”? If so try to switch it off and see what happens then.

The lsmod results from a LinuxHardware.org probe for MSI Z97 Gaming 7 does not show an i915 module that would be used with integrated graphics.

  • Which of the display ports have you tried?
  • What type(s) of monitor and cables do you have?
  • Can you connect a 2nd monitor? One of my systems with integrated graphics and HDMI + USB3+DP ports sometimes switches monitors during boot, so with one monitor I could see something similar to what you show. With one monitor I can use the HDMI port, but if I connect a monitor the USB3+DP the display sometimes switches at boot (I suspect a race condition where one monitor is slow to respond).
2 Likes

Yes, Secure Boot is off. I also tried to find the ‘Enable/Disable boot from USB’ option. However, it seems that my BIOS does not have this.

Well, I have two monitors: one is on HDMI and the second is on DVI. I tried to remove the graphics card and connect only one monitor via the motherboard’s HDMI connection (without the graphics card, I tried to boot only F40 in normal and basic graphics mode). However, the same issue appears.

You have used both the 39 and 40 versions of Fedora and it doesn’t work on your computer. Maybe strange to say this, but as a test, could you download a completely different Linux and try that one? Try for example Ubuntu to see if you can boot into that system.
Should that also not work, then it looks like there is something in your hardware which prevents you from using Linux. Does Ubuntu work then there is something in Fedora which causes it.
Or you could try Fedora Silverblue which does not have a live mode but which goes directly into the installer.
Success.

1 Like

The “MSI Z97 Gaming 7” manual I found online didn’t mention a DVI port. Cables are evil, and doubly so if they have different connectors are each end. Older HDMI cables and adapters may not support the frequencies used by newer monitors.

My experience is that recent linux kernels are less forgiving of non-conforming cables – probably to avoid potential damage to monitors when running them “out of spec”.

Try booting to console text mode. When editing the command line I would remove the rhgb quiet so you get a chance to see error messages.

Your “BIOS” may have a choice of “RAID” or “AHCI”. Make sure it is on “AHCI”.

2 Likes

I tried as you suggested, and you are right. I attempted to boot Ubuntu and Manjaro, and both got stuck just like Fedora, so it seems that the problem is with my hardware.

Hi, when I read this I started looking at your hardware and found an Intel CPU from 2013 which was discontinued in 2017. Somehow I was hoping it would be 32-bit, just so we had found the problem. But it is a 64-bit CPU so that can’t(?) be the problem.

I am out of ideas now, you have done so much already to make it work and still no success.
This is the first time I see this happening in my 16 years using Linux distro’s. I really have no idea what this might be.
I will keep following this thread and should I come up with an idea I will let you know. In the mean time I hope some others here in the forum might have ideas which you could try.

Success.

1 Like