Firefox takes several minutes to open

After upgrading to F40 Workstation on VMs with mac host (both M1 and Intel based macs, virtualization with VMWare Fusion), Firefox takes ages (around 4 minutes) to open.

The same happens when running firefox --safe-mode from terminal.

Is this a known issue? I haven’t found such references here, nor as a bug report.

Added vmware and removed intel

Added macbook

YES! Same here. Just upgraded to F40 this morning or last night via Discover - and after I reboot and open/run/start firefox, it says another version is already running, and I click several times before it starts.

I don’t think clicking several times makes any difference. I have filed this issue in Bugzilla.

1 Like

Same problem for me.
Tried with flatpak version and on another laptop but same slow startup.

With a “strace firefox” the slowdown appear around “/run/systemd/resolve/io.systemd.Resolve”.
After disabling my nextdns configuration which was using /etc/systemd/resolved.conf problem was solved.

Interesting. Are you running Fedora inside a virtual machine?

Since you mentioned a firewall setup, I went and changed my VM’s Network Adapter settings from NAT to Bridged, which solved the issue in my case too.

No, my two Fedora 40 install are on 2 differents hardware, no VMs.
I tried the workaround mentionned here : Firefox slow to start due to waiting for systemd-resolved
but NetworkManager didn’t created the required file and network was not working (propabbly only DNS).

2 Likes

I wonder if there isn’t a simple SUDO fix?

Perhaps sudo dnf install epiphany :slight_smile: . At least until the issue gets fixed in Firefox.

Some additional info, in case someone might want to look deeper into it: I have noticed the same behaviour with Anaconda Installer, when booting from a live iso. Changing the Network Adapter settings fixes it.

Those who are still affected by the issue should consider using workarounds, as this looks like a corner case which may take years to isolate and fix properly:
DNF and Firefox take extreemly long to start when VPN active on f40? - #4 by vgaetera

1 Like

Thanks. It’s all good in my setup, as I can change the settings in VMWare.

I just wanted to give an update on the issue, but based on your links I can see now the defect is well known and with broad implications.

1 Like

thank you!
i’ve been searching for the issue
i didn’t even think of the vNIC of vmware fusion
i have librewolf as well-- same issue
but ms edge is fine
in which isaw when i spun openindiana, changed NAT to Bridge

1 Like

A quick & dirty way to remove the problem:

  • Disable automatic DNS configuration.
  • Manually configure Google’s public DNS to 8.8.8.8 & 8.8.4.4.
  • Restart your system.

See if Firefox works.