Installed Fedora 32 on 2019 Macbook Pro, but Wi-Fi connectivity remains elusive

Long-time Mint/Ubuntu user, first-time Fedora user here, loving it so far. I know Fedora 33 Beta is out but would like to stick with v32 for the time being. Life is good except for some pesky issues (broken wireless, keyboard/touchpad/touchbar become unresponsive when machine wakes up from sleep thus forcing me to force hard shutdown with power button). This thread is focused solely on the wireless woes.

I’ve spent a painful amount of time (many days) researching and experimenting various strategies based on comments by others. I am currently stuck in a rabbit hole and need help to find the light at the end of the tunnel! x-/

cpu: Intel i7-8569U
OS: Fedora 32 (Workstation Edition) x86_64 (running this on Dual-boot alongside MacOS, machine initially came with Mojave and later upgraded to Catalina).
Host: MacBookPro15,2 1.0
Kernel: 5.7.8-200.mbp.fc32.x86_64
Shell: bash 5.0.17
DE: GNOME 3.36.7
onboard Ethernet: RTL8153 gigabit ethernet, confirmed working, and allows me to run dnf updates.
onboard Bluetooth 5.0: confirmed working.
onboard Wireless: using one of the below links, I think it is the maui variant of the Broadcom BCM4364.

Assortment of links that I can remember trying to follow, there’s probably some other pages I’m forgetting:

I rebooted in between various steps to implement changes. In the end, no Wi-Fi devices showed up under Settings > Wi-Fi (it was hidden). I could find it only by searching for Wi-Fi, only to read “No Wi-Fi adapter found”.

Eventually got frustrated and attached an external USB wireless card (AWUS036ACH) with Realtek RTL8812AU chipset. This device is confirmed to be functional on other computers running Windows and MacOS.

Initially, still nothing seemed to register in Fedora Wi-Fi settings. Then, I followed these instructions to grab the latest drivers.

Current status (see screenshots). Using the USB wireless card (not the onboard Broadcom) I am finally able to see my wireless network.

However it fails to prompt me for the password, and therefore fails to authenticate and connect.

Here are some hardware status readouts.
$ inxi -N

  Device-1: Broadcom and subsidiaries BCM4364 802.11ac Wireless Network 
  driver: N/A 
  Device-2: Realtek RTL8812AU 802.11a/b/g/n/ac 2T2R DB WLAN Adapter 
  type: USB driver: rtl88XXau 
  Device-3: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 

$ lspci -nnvk
(pasting just the relevant output for networking device)

01:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM4364 802.11ac Wireless Network Adapter [14e4:4464] (rev 03)
	Subsystem: Apple Inc. Device [106b:07bf]
	Flags: fast devsel, IRQ 255
	Memory at 91400000 (64-bit, non-prefetchable) [disabled] [size=32K]
	Memory at 91000000 (64-bit, non-prefetchable) [disabled] [size=4M]
	Capabilities: <access denied>
	Kernel modules: brcmfmac, wl

$ lsusb
(pasting just the relevant output for networking device)

Bus 006 Device 003: ID 0bda:8153 Realtek Semiconductor Corp. RTL8153 Gigabit Ethernet Adapter
Bus 001 Device 008: ID 0bda:8812 Realtek Semiconductor Corp. RTL8812AU 802.11a/b/g/n/ac 2T2R DB WLAN Adapter

$ ls -AF /usr/lib/modules/$(uname -r)/kernel/drivers/net/wireless/

ath/       intersil/  quantenna/  rndis_wlan.ko.xz  ti/
broadcom/  marvell/   ralink/     rsi/              virt_wifi.ko.xz
intel/     mediatek/  realtek/    st/               zydas/

$ dmesg | grep Bluetooth

[    6.273916] Bluetooth: Core ver 2.22
[    6.273933] Bluetooth: HCI device and connection manager initialized
[    6.273936] Bluetooth: HCI socket layer initialized
[    6.273938] Bluetooth: L2CAP socket layer initialized
[    6.273944] Bluetooth: SCO socket layer initialized
[    6.398304] Bluetooth: HCI UART driver ver 2.3
[    6.398306] Bluetooth: HCI UART protocol H4 registered
[    6.398306] Bluetooth: HCI UART protocol BCSP registered
[    6.398315] Bluetooth: HCI UART protocol LL registered
[    6.398315] Bluetooth: HCI UART protocol ATH3K registered
[    6.398326] Bluetooth: HCI UART protocol Three-wire (H5) registered
[    6.398349] Bluetooth: HCI UART protocol Intel registered
[    6.407873] Bluetooth: HCI UART protocol Broadcom registered
[    6.407884] Bluetooth: HCI UART protocol QCA registered
[    6.407884] Bluetooth: HCI UART protocol AG6XX registered
[    6.407890] Bluetooth: HCI UART protocol Marvell registered
[    6.943553] Bluetooth: hci0: BCM: failed to write update baudrate (-16)
[    6.943555] Bluetooth: hci0: Failed to set baudrate
[    7.104498] Bluetooth: hci0: BCM: chip id 123
[    7.105429] Bluetooth: hci0: BCM: features 0x0f
[    7.107212] Bluetooth: hci0: BCM4364B0 Maui Olympic GEN (MFG)
[    7.107217] Bluetooth: hci0: BCM (001.000.087) build 0313
[    7.107628] bluetooth hci0: Direct firmware load for brcm/BCM.hcd failed with error -2
[    7.107631] Bluetooth: hci0: BCM: Patch brcm/BCM.hcd not found
[    7.436250] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    7.436251] Bluetooth: BNEP filters: protocol multicast
[    7.436254] Bluetooth: BNEP socket layer initialized
[   17.563781] Bluetooth: RFCOMM TTY layer initialized
[   17.563787] Bluetooth: RFCOMM socket layer initialized
[   17.563827] Bluetooth: RFCOMM ver 1.11


Anybody out there? :wave:

Hi, @lawnmower. There are probably not so many Fedora on Mac users to be familiar with the issue you are having.

My thought (without experience to back it up) would be to try nm-cli to try to authenticate your Wi-Fi connection.

1 Like

sudo dnf install$(rpm -E %fedora).noarch.rpm$(rpm -E %fedora).noarch.rpm

sudo dnf update

sudo dnf groupinstall “Fedora Workstation”

sudo dnf install broadcom-wl


try it.

1 Like

hi @eternal. tried it. both of those repo’s appear to already be installed.
ran into an error when running that dnf groupinstall command. do you mean dnf group install with a space?

at first, dnf seems to think Fedora and Workstation were two separate group names, when I used syntax with double-quotation marks "Fedora Workstation".
but when I used single apostrophes sudo dnf group install 'Fedora Workstation' then it seemed to work.

when i attempted to install broadcom-wl, dnf reported a conflict with the previously installed packages broadcom-wl-dkms and akmod-wl.
so i ran:
sudo dnf install --allowerasing broadcom-wl which removed those two packages and replaced them with broadcom-wl.noarch

rebooted…and there’s no apparent change to Wi-Fi (for my internal Broadcom wireless card, which I think is integrated with the Bluetooth unit, and Bluetooth has been working fine since Day 1) – it remains hidden from NetworkManager settings.

However! I plugged my USB wireless card (Realtek chipset) and I’m on wifi, was able to authenticate!!! :partying_face:

I’m super confused, as the package update mentioned above shouldn’t have had any effect on the non-Broadcom wifi card (Realtek).

I suppose if we can still figure out how to get the internal Wifi working that will effectively solve this thread.

any other ideas?

hi @lawnmower

Update to Fedora 33, Might be useful.

I have an older Mac (MacbookPro 2014), and I use to be able to use wifi.

See for exampel:

hi @blueshurricane4 you’re probably right in the big picture, way more folks using Windows-friendly hardware with Fedora compared to converts from Mac who are a minority.

Is Fedora 33 currently still in Beta or considered somewhat stable?

It became the released version yesterday (27 Oct).


1 Like

i see, good to know! i’ll probably wait a 2-3 months before running dnf upgrade.

@ldlyu I ran this instruction mentioned in your link for wpa_supplicant and rebooted.

Same behavior :pensive: for the Broadcom wifi:

After installing this, is there any script or command I should be running?

That’s strange. For me it just works after rebooting the computer. No scripts of commands needed.