MacBook pro user struggles to connect to WiFi on Fedora 35

Howdy y’all. I’m a bit of a newb when it comes to fedora (and Linux) but I wanted to give ita try and experiment! I have a 2012 MacBook Pro, and I’m booting up fedora off of a flash drive right now. I’m trying to get the WiFi to work, and it’s notnworking. More accurately, it’s not an option. I know the wifi card works, as when I boot into MacOs I can stream and email, etc. When I search in the fedoraSsettings for WiFi, it’s telling me “No WiFi Adapter Found.”

How do I get Fedora to find it? Is it a driver issue? How do I download drivers… without WiFi?

Thanks for the help!

1 Like

It is most likely a driver issue. You need to know exactly what wifi card is in use, and that can be found by the command “lspci”.
“dmesg” also can give you some related info.

Post the output of “lspci” and I am sure you will get suggestions for the fix.

You can always put the driver, once identified, on a flash drive and copy it into the running fedora system.

1 Like


Network controller: Broadcom Inc. and subsidiaries BCM4331 802.11a/b/g/n (rev 02)

You’ll need to enable the rpmfusion repositories: and then:

sudo dnf install broadcom-wl from a terminal prompt.

Edit: removed error in command.

1 Like

I used “sudo dnf install broadcom-wl” (without the period at the end) and the packages were downloaded! I’m going to restart the operating system after I’m done typing this, however, as wifi is still not showing up, and hope that that’s the solution.

Update: it still doesn’t think that there is WiFi. :person_shrugging:

You may need to remove or blacklist the module it is installing (or attempting to install) before it will select the newer one during boot. You might also need to force it to install that module.

You can try

sudo modprobe <module name>

to see if it will actually load that module now that it is installed by dnf.

1 Like

Hey there, I have the exact same MacBook Pro. I’ve installed Fedora 35 without any problems. To get the WiFi working, just follow these steps:

  1. Connect an Ethernet adapter or connect an Android or iPhone with Mobile Data and Personal hotspot turned on. This will provide temporary network connection to download the required drivers.
  2. Head over to RPM Fusion Configuration and follow the steps to enable RPM Fusion repos on Fedora 35.
  3. Open a terminal and type sudo dnf update and let it update the system with the latest kernel. This might take a while depending on the speed of mobile data.
  4. After it has completed, reboot the system.
  5. With the phone or Ethernet still connected, log in and open the terminal. Type sudo dnf install broadcom-wl. This will install the drivers for the Broadcom Wi-Fi chipset in MacBooks.
  6. After it has completed installation, reboot your system again.
  7. Disconnect the Ethernet or phone and the Wi-Fi icon will appear on the system tray (top right corner). You can click on this and connect to a Wi-Fi network to access the internet.

This might be a little confusing to anyone trying to switch to linux, so it would be great if this information is included in the fedora docs. Thank you everyone for the amazing work on this distribution! :heart:

Much Love,
Link Smith.


Thanks y’all!

@linksmith : I successfully downloaded all the drivers connected to Ethernet. However, it’s still not finding a network when I’m rebooting into the drive.

@computersavvy can I ask how one finds the older module? How can I find out what driver its using so I can force it to use the proper one?

… I just realized that my WiFi wouldn’t work using a lice boot. :upside_down_face:

Partitioned my ssd, installed fedora, and WiFi works! Thanks y’all!


Yeah, I forgot to mention that even though it is possible to get the wifi working in a live environment, it’s just not worth it. Fedora installs perfectly even without an active internet connection. The guide I’ve given only works On an installed system. I’ll update my previous post to reflect this.

Edit: ok I realised it’s not possible to edit the previous post.

1 Like

Hi everybody

I got my wifi working on fedora 33. Now i upgraded to 35 and reinstalled the rpmfusion free and non free repos with

sudo dnf install$(rpm -E %fedora).noarch.rpm$(rpm -E %fedora).noarch.rpm

and installed the driver

sudo dnf install broadcom-wl

sudo dnf update

But it just doesn’t work.
Do you have any tip how to proceed to get it working?

Try doing sudo dnf update before sudo dnf install broadcom-wl. Then reboot and check if it works. The driver only builds against the latest kernel provided by Fedora, so it is important to update your system first, then reboot to boot into the new kernel, and then install the driver and reboot again.

So the steps are:

  1. sudo dnf update
  2. sudo reboot
  3. sudo dnf install broadcom-wl
  4. sudo reboot

Everything should work now. Please let us know if it’s still not working.

Link Smith

1 Like

Dear Link Smith,
thanks for your quick answer.
I just tried it

  1. sudo dnf update
  2. sudo reboot
  3. sudo dnf install broadcom-wl
    The installation of broadcom-wl tells me the package broadcom-wl- is already installed.

When i have a look at ifconfig there is still no wifi interface.
I am happy for any further tipps.

emphasized text

change that to sudo dnf reinstall broadcom-wl then reboot again.

1 Like

Hello JV,
thank you.
I just tried and did a reboot and it’s still not working.
The reinstall installed the same package wl-

Hello everybody,

is it possible that the wifi-driver will just not work on Fedora 35, so i can only downgrade?
Or what else can i try to get it working.
I would apreciate any help(:

I had the same issue and just managed to solve it.
Please let us know if below steps work for you as well.

Get the broadcom drivers:

sudo dnf install kmod-wl akmods akmod-wl

Check if you have kernel-devel installed. It should be, but if not this will install it for you.

sudo dnf install kernel-devel

Now reboot / restart your system


1 Like