_No Wi-Fi Adapter found_, MacbookPro 11,3, w/ Fedora 36

Good evening I have a new install of Fedora 36 but haven’t been able to use it since I got “No Wi-Fi Adapter found” in MacBook Pro (Retina, 15-inch, Mid 2014) with a Broadcom Inc. BCM4360 802.11ac Wireless Network Adapter.
I have read some articles about it and this is what I have tried with no avail:

  1. I have manually installed the RPM Fusion non-free and free repositories and followed these steps.
    Then I couldn’t sudo dnf install broadcom-wl since, I got an Curl error (6): Couldn't resolve host name for https://...
  2. Then tried the following solutions but it didn’t change anything else.

From here I haven’t been able to do anything else because any install command will give the same answer. Curl error (6). I don’t understand something of this… For many users installing certain elements work as a solution to the Wifi problem, but I don’t understand how they reach any https//: without connection.

You need fedora running on the macbook connected to the internet with wired ethernet.
Fedora setup to build the wl kernel module(broadcom wifi driver) with akmod-wl requires installing gcc compiler and additional packages totaling over 200 MB.
Fetching the individual packages and copying to a flashdrive on another computer to install on the macbook would be a major headache.


This is embarrassing, but this was an straight forward solution, it was about 700 installs and 1GB of upgradables; I would not have been able to do it manually. Thank you for taking your time to help me :smiley:, it’s going to be an interesting journey into the GNU/Linux world :man_with_probing_cane: :man_running:!


Yes it is! I’m running F35/KDE and it’s awesome! :wink: