Input device woes - Mic levels

Hi everyone,

So this is an issue I’ve bee struggling with for sometime. I work form home and do hours of online conference calls. I have been trying to get an effective way to control my mic input levels, bet everything I have tried has not worked.

OS: Fedora release 33 (Thirty Three) x86_64
Kernel: 5.10.17-200.fc33.x86_64

What I’ve done so far:
Deleted the contents of ~/.config/pulse and creating a ~/.config/pulse/daemon.conf with the line:

I’ve edited the following files to disable auto adjustment of the mic:

sudo nano /usr/share/pulseaudio/alsa-mixer/paths/analog-input-dock-mic.conf
sudo nano /usr/share/pulseaudio/alsa-mixer/paths/analog-input-front-mic.conf
sudo nano /usr/share/pulseaudio/alsa-mixer/paths/analog-input-headphone-mic.conf
sudo nano /usr/share/pulseaudio/alsa-mixer/paths/analog-input-headset-mic.conf
sudo nano /usr/share/pulseaudio/alsa-mixer/paths/analog-input-internal-mic-always.conf
sudo nano /usr/share/pulseaudio/alsa-mixer/paths/analog-input-internal-mic.conf
sudo nano /usr/share/pulseaudio/alsa-mixer/paths/analog-input-mic.conf
sudo nano /usr/share/pulseaudio/alsa-mixer/paths/analog-input-rear-mic.conf

And set the following sections to zero
**[Element Internal Mic Boost] **
[Element Dock Mic Boost]
[Element Int Mic Boost]
[Element Mic Boost]

sudo nano /etc/pulse/

And comment out the following modules:

# load-module module-device-restore
# load-module module-stream-restore
# load-module module-card-restore

However my mic input volume still keeps changing. I need to have granular control over this so that I can do my conferences and not have the background noise disturb me. Any other solution welcome.

King regards,


I think this is affecting me, as well… When I’m using my Jabra Elite 75t bugs and I speak, the input microphone “slider” moves steadily to “mute;” does that sound the same as what you’re experiencing?

Mine is doing the opposite, the mic sound steadily moves upwards, so all background noise can be heard.

Ugh… I feel for you because this truly is frustrating. Have you thought of shifting to Pipewire to see if that resolves the issue? I’m leaning to it…

Fedora 34 uses pipewire by default.

If you use Zoom on fedora, in the newest version of the software you can deactivate the automatic mic level … maybe it is this what makes you trouble ? I installed it on Fedora 34 and first time the mic volume made what I wanted.

If you’re feeling particularly adventurous, mfrey/pipewire-nightly Copr

1 Like

I’ve not considered Pipewire, how is your experience with it?

Ok maybe i need to wait for fedora 34, as I need a stable system, its been a huge pain though. I guess my wife and the dog will have to be banished to the back room, thats going to cost me :wink:

Thanks for the Zoom setting suggestion; I hadn’t thought about that being part of the problem. I installed and shifted over to pipewire last night, so we’ll see if those two items coupled solve things, as I have a conference call this afternoon.

1 Like

I just switched to pipewire on Fedora 33, ill let you know how it goes, i have a lot more calls to do.

I’m on Fedora 32, does it work with it too?

:frowning: doesn’t look like it.

1 Like

From my early testing is still looks like the mic auto adjust with pipewire as well. It seems amazing to me that such a simple things is still broken on fedora.

Ok, so Pipewire suffers the exact same issue as Pulseaudio when it comes to input volumes. I’m wondering if anyone knows of any other work around’s or maybe how the input recording volumes could be manually controlled through a script?

Did you already try setting those volumes to a number ie. 40 or 100 vice zero?

Is this with a particular application?

I’m not so sure if it is really fedora who make this adjustments of volume. As mentioned above it can be an application. In my case it was Zoom. But in the settings of zoom i could deactivate it !

What is/are your app/s for the conference calls?

Just web based solutions through the browser, so jitsi server, skype web, nothing that uses an app.

I am exploring if this could be an issue with the crome browser that is adjusting the auto gain.

I think you will find that it is the Conferencing software that is adjusting the mic gain, and most of the popular apps do it whether you want them to or not. I have tried finding a way to disable it on Zoom, Teams, Blue Jeans etc and none of them seem to allow it and each app does it (although I haven’t tried Teams or Zoom in the last 3 months).

1 Like

Zoom 5.5.4 Audio Settings (see Statistics):