Minor Microphone problem

Hello everyone,
my microphone volume dynamically changes from one level to other but I want it to be constant 7ed6596495b47c2e205b2270b162ae616303cb82.png

Can anyone help me?

There are several topics explaining how to disable dynamic volume change. There are also aplications who do the same. For example in Zoom you can deactivate “set volume automatically”.

You might also try F34 live to see if problem is solved.


Hi @ilikelinux I tried but some platform lacks such setting and doesnot offer such
Is compromise the only option for that
such platform includes Google meet and others


good look … the F34 live iso test looks much easier :slightly_smiling_face:

@ilikelinux I am really excited for fedora 34 do you know when will it be lunched?
And will pipewire be a solution for this auto adjust issue?
and I am really confused betn the switch of pipwire and pulseaudio?
do you have any documentation to explain the switch between two?

I am not sure whether PipeWire will address the automated volume settings for a microphone, but the switch to it (and back) is pretty easy. By the way, have you tried Pavucontrol to do some sound tweaking? It might fix your problem even on Pulseaudio, but if you’d like to try PipeWire and you are running Fedora 33 (this would not work on F32), do:

  1. Open your terminal.
  2. Install PipeWire →
    sudo dnf install pipewire --allowerasing → This will install the new audio system and will delete the old one. Note, that you cannot do it without the --allowerasing option as the audio system is protected from being removed easily.
  3. Then you need to install another package to enable the Pulseaudio API in PipeWire →
    sudo dnf install pipewire-pulseaudio.
    Without this, applications will have no connect point and sound will not be heard.
  4. If you plan on using any other sound system, such as Jack, you need to install the appropriate PipeWire module, for example pipewire-jack-audio-connection-kit. You can look for more using
    dnf search pipewire. (This step is not required however).
  5. Do not forget to restart the computer so that old services are correctly stopped and new are started. You do not have to restart, if you know how to do it manually, but restarting is the easiest thing to do.

Then your audio should be using the PipeWire backend. Pavucontrol can still be used to control the audio devices.

Fedora 34 will be launched rather soon, depending on the testing results, but the official date we are trying to achieve is next week around the 28th of April.

We normally say never touch a running system : ). As others already pointed out to mess up while install PipeWire just use the possibility to test it with the live image.

In my case it was, I always hat to fiddle around even with Ubuntu and other Debian based Distros. While using F34 my audio problems where gone.

Any moment:
Fedora Linux 34 Schedule: Key
see bootom lines.

Well, of course might be a risky thing to do stuff like this, but the question was asking about a documentation how to do it, so I provided it. Besides, it has worked for me many times, there and back and was also recommended by the author of PipeWire.

The Live image can maybe show you some of the PipeWire functionality, but it never lets you use it for “real” stuff.

Anyway, Fedora 34 will be out soon with PipeWire as a default.

1 Like

I had this here in mind when I answered:

Second @superadmin was answering to me so I was giving answer what might be good for the user.

Third, I tried your nice commands and killed my F32 installation! Gnome shell was removed and i just could log into Terminal.

Third, I tried your nice commands and killed my F32 installation! Gnome shell was removed and i just could log into Terminal.

Well, I am sorry to hear that, but I thought that we were talking about F33. The pipewire-pulseaudio package is not built for Fedora 32, so there was no way how my commands would have worked on Fedora 32.
And I also do not understand, how you removed the entire Gnome shell? You had checked the list of packages being removed before you pressed Enter on that --allowerasing command, right?

Don´t be sorry and don’t think, act! and just make a note on your replay who says clearly F33 only. F32 is still in use and audio problems are common while having a kernel upgrade from 5.10.x to 5.11.x
A tag is just a tag and can be removed quit easy from several ppl. who have rights to edit titles.

Anyway I learned that it is not possible to remove gnome shell while using mate desktop on the same machine. Even realized lately that when I installed just a app (on a Mate-Compiz spin), the whole gnome-shell came with that app.

As I’m not afraid to use the command line the system was fixt fast again.

Ok, I made a note to say it was meant for F33.
You could have also used the history rollback with DNF to have the packages come back.