Updated F32->F34, microphone extremely quiet

Updated directly from Fedora 32 to 34 a week ago. Since then I have had difficulty with voice chat because my microphone is now emitting at a nearly inaudible level. This is particularly noticeable in Discord, and while the problem might be completely within their app they’ve never been helpful with Linux problems. I read in the update notes that Pipewire is now used for audio and I suspect this change could be involved. Systemctl shows that pipewire is running instead of pulseaudio (although I can still manage audio via pavucontrol; I’m not entirely sure how this all works). I turned up the microphone level through pavucontrol to 100% but that did not significantly affect audibility. Saw another post here about checking journalctl but it does not report any errors related to audio as far as I can find. Would like any help in determining what the problem is and I can run any requested commands for more information; I’m not sure what to provide currently.

Did u already try to disable Automatic Volume and Level for Audio Out and In within the app(s)?

I did try that, and usually discord just crashes if I let it handle audio levels automatically.

It might be worth checking the microphone levels and boost for the ALSA layer using alsamixer (hit the ‘s’ key to choose the correct card first).

This may or may not help you: PipeWire - ArchWiki

I’m experiencing the same problem on Fedora 35 with pipewire 0.3.40. My microphone is a Blue Snowball iCE.
GNOME Sound Settings screenshot:
AlsaMixer screenshot:

This issue is not specific to Discord; when I recorded the same audio on both Fedora 35 and on a Mac, the audio recorded on Fedora was much quieter.

How did you get to Fedora 35, by upgrade or by new installation?

Did you go thru this steps and check if Pipewire works correctly?

How did you get to Fedora 35, by upgrade or by new installation?

I upgraded from Fedora 34, which I had installed about a week before the release of Fedora 35. I don’t remember if I had this issue on Fedora 34 because I used it for such a short period of time.

Did you go thru this steps and check if Pipewire works correctly?

I’m not sure what you mean by checking if Pipewire works correctly.

Anyway, to identify the version of Fedora in which this showed up, I tried running versions 33, 34, & 35 of Fedora Workstation as virtual machines on GNOME Boxes. The Fedora installation that I’ve been using was the host OS. I was not able to recreate the quiet-microphone issue even on the Fedora 35 VM. Here were the steps I took for each VM:

  1. Installed Fedora workstation to the virtual drive & restarted the virtual machine.
  2. Upgraded packages & restarted the virtual machine.
  3. Installed spice-webdavd & GNOME Sound Recorder, then restarted the virtual machine.
  4. Shared my Blue Snowball & home folder with the virtual machine.
  5. Selected Blue Snowball in the virtual machine & maxed out microphone volume in GNOME Settings.
  6. Played a certain audio sample from my smartphone at a fixed distance from the microphone at a fixed volume, & recorded this through GNOME Sound Recorder.
  7. Exported recording to a .flac file & transferred it to the host OS.
  8. On the host OS, compared the volume of the recording to the other recordings.

I recorded the same audio on my non-virtual Fedora 35 installation both before & after doing all the virtual machine tests. These recordings were much quieter than any of the audio recorded through the virtual machines.

After learning more about how to use alsamixer, I found that the gain was lower in the host OS than in the VMs, despite me not knowingly changing that setting. To increase the gain, I did the following:

  1. ran alsamixer command
  2. pressed F6 to access the “Select sound card” menu
  3. Selected “Blue Snowball”
  4. pressed F4 to access the “Capture” volume slider
  5. Used arrow keys to increase gain