I can't install Fedora 38

,

No problem installing Fedora 37 and earlier.

But I encounter a bug that freezes the installation process at the very beginning (screen photo cd).

1 Like

Some users have worked around failures in the F37 installer by installing F36, F36 updates, and then upgrading to F37.

It’s only new installation with usb root device.

Maybe you could install F37, update it to the latest, then do a dnf system-upgrade to F38. This would bypass booting from the live F38 ISO.

It seems certain systems are unable to boot to the F38 live media but can bypass that following the path above. You did, after all, state that you had no problems installing F37.

Yes, thank you, you’re absolutely right, that’s what I’m going to do, upgrade the Fedora 37 to 38 but I’m worried about the following versions…

I spent hours looking for a possible cause with the Bios but it’s very unlikely. I have no problem with Fedora 37 and earlier, nor with Linux Mint as well.

Welcome as a new poster to the ask.fedora section @jpmonin

Just to give you a feedback, that it is not affecting all systems in general. I could install F38 Xfce on a old hp laptop without big issues. So you might give us more info’s about your system with inxi -Fzx or similar.

Also here , what boot medium did you make/use DE etc.
In my case i used the Fedora Media Writer and selected the Xfce to download and write to the usb.

This could be because incompatibility with your hardware and the newer Kernel we use on versions 38 and above.

Setup :
Motherboard : Giigabyte GA-X58A-UD5
DDRAM 3 : 6 x 8 Go
Intel i7 CPU 960 3.2 Ghz
NVIDIA Quadro NVS 450

In my case too, i used the Fedora Media Writer and selected the WorkStation to download and write to the usb.

Anyway seams to be a GPU related issue. Always reading this problem there are some NVIDIA cards included. Here an example:

Might be some kind of text based installer would solve this problem. I’m not sure if this is still available. At least for all the tasks before first login, where NVIDIA drivers are available again.

In my personal opinion such an alternative should come from the NVIDIA community or at least sponsored by them.

Thank you @Ilikekinux, I will try an installation without going through the Nvidia card.
Oups … I don’t have no video output and no other video card. I try update Fedora 37 to 38 but the solution is not permanent …

I just tried the new Fedora 37 → 38 update but, amazing!!!
The update from Fedora 37 to 38 bug!
New Kernel Fedora 38 is incompatible with NVIDIA NVS 450 cards…

I am disappointed to be forced to leave Fedora hoping that these card compatibility issues will be resolved soon.

Unfortunately, neither hope nor disappointment will help your issue be seen or fixed.

Possibly related:

I have not searched kernel bugzilla or mailing lists.

2 Likes

You are not forced to leave. Everyone is welcome here. Alternative you could also change hardware and look for a device who has a integrated gpu for such cases as yours. Some have two GPU a onboard and an additional built in.

Same as you have Apple hardware, not in every case you have compatibility with other OS’es as Windows and Linux. Choosing correct Hardware makes part of the selection of a System you want to use.

Life can be hard, and sometimes quite expensive too :smile:

1 Like

Is your card is PCIe 1.0? For PC’s that only provide PCIe 1.x:
Tom’s Hardware suggests:

If you have an even older PC, or anything that only supports the PCIe 1.x standard, it’s probably better to look at a full PC replacement rather than just upgrading your graphics card.

There are lots of used name-brand enterprise-level PC’s being sold at bargain prices because large enterprises a) want Windows 11, and b) are trimming their workforces. For most applications, integrated graphics will perform as well or better than most PCIe 1.x card with fewer driver issues.

1 Like

Tank very much @gnwiii and @ilikelinux :+1: You are all right !

My wife is an Apple fan, so me & my son got her older MacAir models. Mine (10 yrs old) runs Fedora (few days ago up-ed to F38), and he did’nt want anything but Windows. His model is 5-6 years old. “Boot Camp” was useles, so I installed Win 11 (from Microsoft site) on bare metal. It was hard (could have been easier if I first checked hardware components with Fedora). I had to tweak installation, bypass TPM, then chase the right drivers, and finally use help from chocolatey (for Macair touchpad which was recognized as generic mouse). But, in the end he’s got his windows on a Mac. Point is that you need patience and persistence. :slight_smile:

1 Like
1 Like

I am also unable to install Fedora 38 Workstation from the live USB image. It boots successfully from USB into the GUI but when I click on Install to Hard Drive it does nothing at all.

I had previously successfully installed Fedora 37 on this machine type (Lenovo Thinkpad P1 Gen 4) without issue and successfully upgraded it to F38. A later F38 upgrade then broke Gnome due to Nouvea drivers no longer being compatible with the Nvidia graphics processor. However, installing the relevant Nvidia drivers fixed that problem.

The thing is, I am now again trying to install F38 Workstation on the same Lenovo Thinkpad P1 gen 4 (after wiping the disk) and it will not install at all. No doubt the nvidia driver is the the issue, as [jpmonin] mentioned above. Since I cannot find any where to download F37, I will need to download f36 and upgrade twice after installing nvidia drivers, just to get F38 running in a laptop.

Unless the Fedora team plans to resolve this incompatibility issue so that we can have a simple install process which supports the nvidia graphics cards which are still in wide use on ultra modern laptops, I will sadly be ditching Fedora after many many years of happy use. Right now I run Fedora Workstation on a my desktop computer and Fedora server on my cloud server as well as on a couple of Raspberry Pi machines, and a laptop. I’m really reluctant to jettison Fedora but I cannot accept this dirty workaround as a long term solution. I’m thinking maybe Centos for the servers and Centos with Gnome for the workstation devices.

Come on Fedora team - we still love Fedora but this messy installation process will only get worse as we move to F39 and onwards. It simply is not a viable long term option.

From the server/everything/etc media (not the workstation which is already live) you can append ‘inst.text’ to the grub/kernel command line and it will force text mode. Although i’ve not tried it on x86 recently, I do a lot of installs that way on arm device which have serial ports as the preferred console device.

1 Like