Blank Screen after Upgrade to 38


I’ve just updated my desktop system to Fedora 38 via the command line, and everything seem to go well until the first boot.

The grub screen displayed and showed the new F38 at the top and started to boot.

However after 5 mins the screen was still blank.

So I had to power-off and restart. I tried again and the same thing.

Restarted and went back to the previous boot of F37 and here I am now.

I’m a little lost about what to do.

Here are some details of my system.

Vendor ID: GenuineIntel
Model name: 11th Gen Intel(R) Core™ i9-11900K @ 3.50GHz
CPU family: 6

NVRM version: NVIDIA UNIX x86_64 Kernel Module 530.41.03 Thu Mar 16 19:48:20 UTC 2023
GCC version: gcc version 12.2.1 20221121 (Red Hat 12.2.1-4) (GCC)

Some errors In the boot log from journalctl -b -1 that maybe relevant. These were displayed in RED

Apr 19 09:17:16 fedora-desktop /usr/bin/nvidia-powerd[1005]: Allocate client failed 38
Apr 19 09:17:16 fedora-desktop /usr/bin/nvidia-powerd[1005]: Failed to initialize RM Client
Apr 19 09:17:16 fedora-desktop systemd[1]: Failed to start nvidia-powerd.service - nvidia-powerd service.
Apr 19 09:17:19 fedora-desktop kernel: nouveau 0000:01:00.0: sec2: halted
Apr 19 09:17:19 fedora-desktop kernel: nouveau 0000:01:00.0: sec2: TRACEPC SCTL 00007023 TIDX 201f0000
Apr 19 09:17:19 fedora-desktop kernel: nouveau 0000:01:00.0: sec2: TRACEPC: 00006ee3
Apr 19 09:17:26 fedora-desktop kernel: nouveau 0000:01:00.0: disp: error 08000000

Any help would me very much appreciated. I’ve very computer literate but only been using Linux for about 1 year so I’m not expert enough to debug this.

Looks like your graphics adapter is not supported by the opensource nouveau driver. You should install the nvidia driver packaged by rpmfusion.

1 Like

Thanks. I’ve just managed to fix it.

This is what I did, I’ll post here in case it helps anyone.

1) sudo dnf erase *nvidia*
2) Rebooted back to F38
3) This time I got a low res login screen on just 1 of my 3 screen screens
4) sudo dnf install akmod-nvidia
5) Rebooted

This time I was back to nice high res, multi-screen.

All working.

Looks like the NVIDIA did not update properly when I ugraded from F37 to F38 but now I know what to do in future.


Be careful when removing *nvidia*, you will remove nvidia-gpu-firmware which is most likely not intended (and won’t be reinstalled when installing akmod-nvidia). Check your transaction history and reinstall it if necessary.

RPM Fusion has the more accurate way to uninstall the drivers:

# dnf remove xorg-x11-drv-nvidia\*

Thank you Justin. What exactly is the nvidia-gpu-firmware? How can I check if it’s installed? and if not how to install?

Try using dnf install nvidia-gpu-firmware. If already installed it will tell you and if not it will install it.
That package is the firmware for all the available nvidia GPUs and is necessary for proper operation of most if not all.


Thanks, that worked great.

Appreciate your time and help.