After update to 38 nvidia-powerd.service failed

└[$]> systemctl status nvidia-powerd.service                        
× nvidia-powerd.service - nvidia-powerd service
     Loaded: loaded (/usr/lib/systemd/system/nvidia-powerd.service; disabled; preset: enabled)
    Drop-In: /usr/lib/systemd/system/service.d
     Active: failed (Result: exit-code) since Thu 2023-04-27 20:26:09 +04; 18min ago
    Process: 2028 ExecStart=/usr/bin/nvidia-powerd (code=exited, status=1/FAILURE)
   Main PID: 2028 (code=exited, status=1/FAILURE)
        CPU: 6ms

апр 27 20:26:09 shell systemd[1]: Starting nvidia-powerd.service - nvidia-powerd service...
апр 27 20:26:09 shell /usr/bin/nvidia-powerd[2028]: nvidia-powerd version:1.0(build 1)
апр 27 20:26:09 shell /usr/bin/nvidia-powerd[2028]: Allocate client failed 38
апр 27 20:26:09 shell /usr/bin/nvidia-powerd[2028]: Failed to initialize RM Client
апр 27 20:26:09 shell systemd[1]: nvidia-powerd.service: Main process exited, code=exited, status=1/FAILURE
апр 27 20:26:09 shell systemd[1]: nvidia-powerd.service: Failed with result 'exit-code'.
апр 27 20:26:09 shell systemd[1]: Failed to start nvidia-powerd.service - nvidia-powerd service.

fedora 38, RTX 3070 mobile

I would be grateful for help

Was nvidia-powerd working before the upgrade?

Are the nvidia drivers working otherwise?
What happens if you do a reinstall of all nvidia related packages, then reboot?
dnf reinstall '*nvidia*' (wait about 5 minutes after the reinstall completes before rebooting.)

What is the output of nvidia-smi

nope, didn’t work :frowning:

└[$]> nvidia-smi
zsh: nvidia-smi: command not found...
Packages providing this file:

Should I install any of these?

First lets see exactly what is installed.
dnf list installed '*nvidia*'

akmod-nvidia.x86_64                                                             3:530.41.03-1.fc38                                        @rpmfusion-nonfree
kmod-nvidia-6.2.10-200.fc37.x86_64.x86_64                                       3:530.41.03-1.fc37                                        @@commandline     
kmod-nvidia-6.2.11-300.fc38.x86_64.x86_64                                       3:530.41.03-1.fc38                                        @@commandline     
kmod-nvidia-6.2.12-300.fc38.x86_64.x86_64                                       3:530.41.03-1.fc38                                        @@commandline     
nvidia-gpu-firmware.noarch                                                      20230404-149.fc38                                         @updates          
nvidia-settings.x86_64                                                          3:530.41.03-1.fc38                                        @rpmfusion-nonfree
xorg-x11-drv-nvidia.x86_64                                                      3:530.41.03-1.fc38                                        @rpmfusion-nonfree
xorg-x11-drv-nvidia-cuda-libs.x86_64                                            3:530.41.03-1.fc38                                        @rpmfusion-nonfree
xorg-x11-drv-nvidia-kmodsrc.x86_64                                              3:530.41.03-1.fc38                                        @rpmfusion-nonfree
xorg-x11-drv-nvidia-libs.i686                                                   3:530.41.03-1.fc38                                        @rpmfusion-nonfree
xorg-x11-drv-nvidia-libs.x86_64                                                 3:530.41.03-1.fc38                                        @rpmfusion-nonfree

Yes, install xorg-x11-drv-nvidia-cuda to provide the command nvidia-smi

I personally disabled the service, it was causing me some issues. I have not noticed any issues be disabling it.

Note that the nvidia-powerd service was intended for dual GPU laptops like yours only. It seems possible that the service does not recognize that particular GPU as one of the supported ones and thus will not start.

The nvidia-powerd service is not mandatory, and in fact gives a ‘failed’ error on all systems where it does not support the config (all desktops). It is a very minor inconvenience to see that message in the logs, but is useful for those where it functions and who need the lower power draw it can provide for some.

└[$]> nvidia-smi                               
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

Strange. Mine show exactly the same version numbers as yours, though it may be possible that the wrong version of the cuda package was installed.

Please now run the dnf list installed akmod-nvidia xorg-x11-drv-nvidia-cuda command.
If those results show differing version numbers then please show us and run dnf upgrade --refresh to get all back in sync.

akmod-nvidia.x86_64                                                        3:530.41.03-1.fc38                                             @rpmfusion-nonfree
xorg-x11-drv-nvidia-cuda.x86_64                                            3:530.41.03-1.fc38                                             @rpmfusion-nonfree

And i run dnf upgrade --refresh

soo… whats next?

Nothing related to nvidia-powerd. The nvidia-smi command was just to see what the driver itself was telling you but with it reporting a version mismatch it seems strange.

The only way I know to make certain the driver is fully up to date is to remove it and force a rebuild.

If you wish to do that then
dnf remove 'kmod-nvidia-6.2.12-300*'
ls /usr/src/kernels to see the kernels installed then select the full name of the kernel to build the modules for and use the full name of the kernel shown with ls
(for example)
I see

$ ls /usr/src/kernels
6.2.10-200.fc37.x86_64  6.2.11-200.fc37.x86_64  6.2.8-200.fc37.x86_64  6.2.9-200.fc37.x86_64

and to build the modules for kernel 6.2.11-200 I would use
akmods --kernels 6.2.11-200.fc37.x86_64

After doing that, after the command returns to the prompt, then a reboot should load the newly built modules.

I just wanted to add, I too am having the exact same issues as described in this topic since upgrading to 38 today. As of the moment, the recommendations here seems to have fixed the issues.

Yes, nvidia-powerd was working before my upgrade.

The other odd thing that I cannot figure out if it’s related to this or not. I usually login to an X11 session as I have traditionally had issues with Wayland - especially with a multi-monitor setup. However, since upgrading to 38 today, I cannot login to X11. I only see a black display.

Additionally, when I click on the Wayland/X11 selector in the bottom corner of the SDDM screen (using KDE Plasma), it flickers a white screen very strongly.

To add to all of this, I just checked and it’s no longer even recognizing my GPU (Nvidia GeForce GTX 1050 Ti)…

Probably the nvidia modules did not get updated & built properly. It is not possible for nvidia-powerd to function if the nvidia drivers are not loaded or the gpu is not one of the ones used in the optimus config in the laptops. Nvidia-powerd was designed to support lower power mode on the optimus config (dual gpu) laptops.

To check if the nvidia modules are loaded please run lsmod | grep -E 'nvidia|nouveau'
If that returns a list of nouveau modules then it seems that the modules may not have been built or at least did not load properly.

We can check with dnf list installed '*nvidia*' to see what the system has installed.

Thanks @computersavvy. The interesting thing is that I had the Nvidia gpu setup and working great in F37,with the proprietary drivers. Much better than with the nouveau drivers. So, I’m just trying to figure out what happened.

Yes, it is all nouveau that are listed for me. :unamused: The opposite of what I had in F37. So now I need to find the setup I used for those…

nouveau              3399680  0
drm_ttm_helper         16384  1 nouveau
drm_display_helper    200704  2 i915,nouveau
mxm_wmi                16384  1 nouveau
ttm                   102400  3 drm_ttm_helper,i915,nouveau
video                  77824  4 dell_wmi,dell_laptop,i915,nouveau
wmi                    45056  9 dell_wmi_sysman,video,intel_wmi_thunderbolt,dell_wmi,wmi_bmof,dell_smbios,dell_wmi_descriptor,mxm_wmi,nouveau


Installed Packages
akmod-nvidia.x86_64                                              3:530.41.03-1.fc38                        @rpmfusion-nonfree
kmod-nvidia-6.2.11-200.fc37.x86_64.x86_64                        3:530.41.03-1.fc37                        @@commandline     
kmod-nvidia-6.2.12-200.fc37.x86_64.x86_64                        3:530.41.03-1.fc37                        @@commandline     
kmod-nvidia-6.2.12-300.fc38.x86_64.x86_64                        3:530.41.03-1.fc38                        @@commandline     
nvidia-gpu-firmware.noarch                                       20230404-149.fc38                         @updates          
nvidia-persistenced.x86_64                                       3:530.41.03-1.fc38                        @rpmfusion-nonfree
nvidia-settings.x86_64                                           3:530.41.03-1.fc38                        @rpmfusion-nonfree
xorg-x11-drv-nvidia.x86_64                                       3:530.41.03-1.fc38                        @rpmfusion-nonfree
xorg-x11-drv-nvidia-cuda.x86_64                                  3:530.41.03-1.fc38                        @rpmfusion-nonfree
xorg-x11-drv-nvidia-cuda-libs.i686                               3:530.41.03-1.fc38                        @rpmfusion-nonfree
xorg-x11-drv-nvidia-cuda-libs.x86_64                             3:530.41.03-1.fc38                        @rpmfusion-nonfree
xorg-x11-drv-nvidia-kmodsrc.x86_64                               3:530.41.03-1.fc38                        @rpmfusion-nonfree
xorg-x11-drv-nvidia-libs.i686                                    3:530.41.03-1.fc38                        @rpmfusion-nonfree
xorg-x11-drv-nvidia-libs.x86_64                                  3:530.41.03-1.fc38                        @rpmfusion-nonfree
xorg-x11-drv-nvidia-power.x86_64                                 3:530.41.03-1.fc38                        @rpmfusion-nonfree

What is the output of mokutil --sb-state
The installed packages look perfectly normal.

Exactly what I thought. All looks similar to my previous install.

I can tell you without even running that output that I have secure boot disabled. I never use SB on my installs. I’m Linux only user and find SB causes more problems than anything else.

Did you by chance do a firmware update on the PC? If so then it is likely that secure boot was automatically enabled and may need to be turned off again. That command give the current status.

Yes, I’m aware of the command. Hence my comment.

Yes, I did have a recent firmware update on my machine and yes, SB is still disabled. Good thought.

Thanks for the suggestion to check, I forgot that with firmware updates it can be retriggered back to “on”. In this case, it didn’t happen - thankfully.