I can't install any os except Fedora

I can make usb boot drive only with Fedora Media Writer. There is a button in Writer to write another .iso file but it doesn’t work. When i’m writing Fedora distros through Writer i can boot from usb and install it (checked with Workstation, LXDE, Cinnamon, XFCE). But if i’m writing other .iso file (tried Ubuntu, Manjaro, Mint, Windows 10) i can’t see it in boot manager (but i see it in ‘boot from file’ menu, but it doesn’t work too). I have insydeH2O UEFI. Also tried UltraIso and Rufus on Windows and Unetbootin, Etcher, WoeUSB, MultibootUsb, dd command and default Disks app on Fedora. Help pls.

Hello @shinyzero, welcome to the forums. I have just tried Fedora Media Writer to create a bootable USB for Ubuntu 18.04.3 LTS amd64 that booted no problem into the install. My machine is a BIOS though that should make no difference. Perhaps the iso’s are corrupt in some fashion, maybe try to download one and verify it with the available checksum. As your system is UEFI, you can use the UEFI builtin boot manager to make sure the USB is being selected to boot from. I have never had any issues making a bootable USB with Fedora Media Writer except when I tried to make one for Win 10 Pro, which didn’t work.