USB Flash Drive Won't Show Up on Windows 10

Hello everyone,
I got a new laptop which doesn’t even function correctly, and I’ve tried to install Mint and then Fedora onto it.
Of course both didn’t work, but that’s not the issue I need help with.
The USB flash drive I used to install both of those distro’s (via USB Imager on Windows 10 on another laptop) won’t show up after installing Fedora on it. I didn’t have that issue with Mint. It only boots up Fedora when the Windows 10 laptop starts up after restarting.
Please help me.

Please provide some more information on what you did so we can try to help. What “USB Imager” program did you use? Which disk image did you use for imaging the USB drive?

This sounds like correct behaviour…Can you explain what you are expecting to occur?

It does not clear what was wrong if your drive is not showing in the windows after making bootable drive with linux
That is ok can be fixed
In fedora or gnome base distros open disk app select drive delete all partition and repartition with fat.
In windows open disk management and do it from there.
If any issue about fedora that you are facing you can ask that could be solvable.

Here is the program I used:

I just downloaded the Fedora Workstation ISO from the website (Fedora 35: x86_64 DVD ISO).
The problem isn’t with Fedora booting up, what I tried to say is that restarting doesn’t help with the flash drive not showing up.

Do you mean formatting the disk?

The item you post says A very minimal GUI app that can write compressed disk images to USB drives.

A fedora iso is not a compressed disk image but an iso9660 image.
Have you by chance tried either etcher or rufus for writing to the USB device? The fedora image needs to be written as is since it is not compressed but exactly as would be seen if you looked at a DVD with that file system image on it.

And, no, if you use rufus or etcher you do not need to do anything such as partitioning or formatting the usb device. Writing the image does its own partitioning for you.

Thanks for telling me that, but do you know how to solve the flash drive problem?

Please provide details on what is happening.
I understand that you are putting the fedora ISO onto the USB using a bzt/usbimager from gitlab. (I assume this is done within windows but you do not say)
I instead recommended you put the image (from within windows) onto the usb using either rufus or etcher.

You seem to indicate that you cannot read the usb once it has been written to, and that seems likely if the ISO is modified as it is written.

Since you really have told us no details except a generic “does not work” we need the actual details to assist.

  1. What ISO are you using? Workstation, KDE, server, core, everything, or other? The filename will tell us.
  2. Have you done the verification by checksum of the downloaded iso?
  3. What machine are you using to write the USB? Windows, Linux, other? and what OS name and version?
  4. Have you even tried what was suggested to this point? If so what were the results?
  5. What do you mean when you say you cannot see the flash drive? Windows cannot see it? Linux cannot see it? You cannot boot it? What?
1 Like

Some apps create a specific size partition and this don’t support windows so you needbto delete all partitions and recreate them again if you have linux install or mac os it is not an issue but Windows don’t support most.
Open in windows disk management and select your usb reformat your drive and delete partitions if any and create one with fat.

Edit: Repair usb
Solve in window you can use diskpart with cmd if you want in linux gnome or kde have disk or partition manager use this terminal fdisk or parted or mkfs.
If you want to install linux i recommend use Fedora Media Writer
You can use rufus or
And select your os iso and flash everything should be okey.

Hey, you can look at the posts above, I used Windows 10 to write the Fedora Workstation ISO to the flash drive, and I can’t see the flash drive on File Explorer on Windows 10, sorry if I wasn’t clear.

Windows 10 not seeing the USB device is not an unexpected result. I have not even tried to see the actual device from windows, though since it is a hybrid ISO (can boot either MBR or UEFI mode) it may not meet the strict windows standard for being seen with the file explorer.

However, it still does not answer if the system is able to boot from that device. Have you tried that?

1 Like

It was able to, but now I can’t use the flash drive on Windows.

That is 100% normal. The flash drive is now a read only copy of the ISO written to it.

It can easily be restored to normal use with any of the partitioning tools in linux. Some of those are fdisk, gdisk, parted, gparted, and many others. The first 3 are installed by default with a fedora install and are command line tools. Gparted is a gui and can be installed after fedora is installed and operational. Gparted also allows you to format the device as it does the partitioning so it is quite useful.

Regardless of what tool is used to remove the ISO image and restore normal partitioning it should be formatted to vfat so it can be used for both windows and linux.

1 Like

What about the GNOME Disks app? I’m in the middle of formatting the flash drives through it. Can I also wipe the OS using it?

Are you sure that the image writing software didn’t unmount the USB drive after it was finished writing it? That is somewhat common behaviour for that kind of app. You can try just unplugging and plugging in the USB again. As @computersavvy said, the drive should now be formatted in read-only ISO9660, which Windows 10 should be able to read. If you are able to use the USB drive to boot into Fedora, then it sounds like it was created successfully.

So if you were able to use the USB to boot into Fedora…then why do you need the USB drive to be readable by Windows? Did you already use the USB to install Fedora and just want to reformat the USB drive to use it for other purposes now?

Maybe use the Fedora Media Writer application (download). It has a simple button to restore your USB drive to make it empty and usable for other uses:

I want to use it for other purposes now, and I’ll try the Fedora Media Writer and post if I encounter another issue, thanks.

Thank you very much,
Using the Restore option in the Fedora Media Writer didn’t work, but using GParted worked.
I didn’t have an option labelled vfat, so I used fat32, I hope that’s okay.
Now if I wanted to remove the OS, just like my laptop was when it came, how can I do it?

This is a different topic and should be started on a new thread.
We need different info to properly discuss removal of an os.

1 Like

Okay, thank you.
But is fat32 okay?

It is fine. One of the biggest faults of fat (any version) is the file system size and file size supported. I think vfat is the latest and supports larger files, but fat32 is also readily used.