Fedora Media Writer made my USB stick unusable

I used Fedora Media Writer and successfully installed Fedora 32 Workstation on my PC. Now when I try to format my USB drive that I used with Fedora Media Writer it is not possible to find it in Windows “File Expolorer” only in “Disk Management”. I tried to format it in “Disk management” where I can see a MBR partition and another partition. It did not work to format the MBR because the options are greyed out and the other partition is possible to delete but not to create a new NTFS partition. Also, Windows 10 does not find the USB drive when I plug it in the PC, its only findable in the “Disk management” place.

Could you help me to fix my USB drive and maybe fix your Fedora Media Writer program?

Boot into your Fedora32 install, and use Disks (gnome-disks) to delete the existing partition and create a new one.


Greetings @fedorauser2,

I have been there and haven’t used Fedora Media Writer ever since.

I fixed my USB-drive using a tool called Rufus.
Here is the link for the same: https://rufus.ie/

Now, after you install the same (You will need Windows to install the same),

  • Plug in your USB stick, start the program(Rufus).
  • Select the same from Device.
  • From Boot Selection, Select Non-Bootable.

You may read this too: FAQ · pbatard/rufus Wiki · GitHub

[Moderators of this forum, I am not sure whether I am allowed to mention a third-party tool. Therefore, Apologies if I negated any rule(s) and you may remove my comment but only after @fedorauser2 has read the same.]




I am sure a search (within Ask Fedora) using “rufus” in your query will give you several hits. Its a free world.

Hi and thanks for the reply. This Rufus program worked to fix my USB drive.

Now its up to the Fedora developers to fix their Fedora Media Writer so it is more windows-friendly (so you can format it after use in Windows 10 for example).

Oh, the fact that Rufus helped you with your USB stick does not indict Fedora Media Writer (FMW) in any way. In fact, it serves as evidence that FMW did not damage the stick. If your stick was marked “bootable” by FMW, the tool did its job properly by setting that flag ( gparted, parted, or testdisk in Fedora could revert that for you too).

Without setting the boot flags, your stick will not boot any Operating System (not only Fedora). I hope you can forgive FMW now.

Here is the thing: Explorer in Windows 10 will not reveal a boot-able drive formatted as a UEFI boot device. That is a design decision by the developers of Windows. It doesn’t mean the USB stick is bad. It means that Windows is hiding it from you – Windows protects system files/partitions.


I believe earlier versions of FMW could be used to restore the original partitioning on a USB stick. I have not tried it recently so don’t know if that is still the case.

I have had very good luck as mentioned above with simply using fdisk, gparted, and parted, as well as the fedora disks utility to restore the original partitioning on USB drives.
It is a given that when using dd or FMW that the USB is repartitioned to the size of the iso written to it and is marked bootable. To restore it will require having the partitioning restored by some tool designed for that purpose…

Thank you @twohot for the info about windows and the fact that Explorer will not reveal boot-able UEFI devices. I seldom use windows so had not encountered this issue.

1 Like

FWIW, I have found that you can use FDISK or GDISK to create a new MBR or GPT partition table and Windows will then see it and ask if you would like to format it.

1 Like

Thanks so much! Though my brand new flash drive was dead.

ISSUE: I got this issue When I tried to boot the USB by fedora media writer.

First fix the USB to get recognized by windows. But you can still find the USB in disk management. right click on “my PC” → “manage” → “Disk Management”. Here you’ll find the USB that inserted.

  1. Fixing the usb (issue: 1. you used fedora media writer or 2. you may inserted the USB in Linux)
    Solution To "Virtual Disk Service error: There is not enough usable space for this operation." - YouTube
    by these videos you can definitely fix the usb
  2. Now assume you fixed the USB. Now it’s recognizable.
    Don’t use fedora media writer now, I repeat DON’T.
    Use RUFUS. download here Release Rufus 3.21 · pbatard/rufus · GitHub (official website)
    Now boot the USB by RUFUS software selected the ISO image or DD image. NOTE: RUFUS downloads extra two additional files to boot the ISO image.

All the Best !! Hope you find these notes helpful.

F32 comes with a quite old Media Writer … did you try the new one?

I seem to have had the same issue except my USB only shows up on device manager. Neither Rufus nor file explorer seem to be able to detect the USB drive


Please start a new thread for your issue. This thread was dead in August 2020 with fedora 32.

A couple necro-posts since but not relevant to a current operating system release version.

It remains the same issue.

@joltaic go to Gnome’s disk manager and delete all partitions that are shown on the usb drive. then create a new one that covers the entire usb drive (fat32). After that everything is fine again.

Sorry, I forgot about this post. I don’t recall what I did aside from rebooting and messing with the device manager a bit, but I managed to fix it. Fedora installed without a hitch afterwards.

This is expected behavior because Linux formats USB sticks differently from Microsoft Windows.

No, you can’t do that.

The only solution is the following. At the time of writing this very belated reply --because I just came across it-- Microsoft Windows has two editions: Windows 10 and the latest Windows 11.

I will use Windows 10 as it seems that not many users have upgraded their operating systems to Windows 11.

  1. Ensure that the “problematic” USB stick is plugged into a USB port.

  2. Launch a command prompt with admin privileges. Do not use Windows Powershell with admin/non-admin privileges.

  3. When you see C:\Users\[name of user] >

  4. Type diskpart

  5. You will see DISKPART>

  6. Type list disk

  7. The disk which holds your Windows operating system is always listed as Disk 0

  8. If the plugged-in USB stick is the only USB removable storage device, it will be listed as Disk 1

  9. Type select disk 1

  10. You will see the statement Disk 1 is now the selected disk

  11. Type list disk

  12. If your selection is correct, you will notice an asterisk next to Disk 1

  13. DISKPART> clean

  14. DISKPART> create partition primary

    or DISKPART> create par pri

  15. DISKPART> format fs=ntfs quick

  16. DISKPART> assign letter=X (where X is an unused drive letter)

  17. Exit the command prompt.

For more information on what you can do with this powerful built-in Windows utility, please surf to Everything About DiskPart Commands in Windows 10

You need to format your USB stick with a filesystem first if you plan to use it in a Linux or *BSD distro. However, if you plan to write an ISO file to said USB stick using Rufus in a Microsoft Windows environment, you do not need to format it with a filesystem. Rufus will take care of creating the appropriate filesystem for you.

1 Like

Fedora media writer still has an option to restore the disk to defaults.

1 Like

I wouldn’t trust what it promises.

Trust me, using Microsoft Window’s utility called diskpart is the ONLY solution to the issue posted by the OP, @fedorauser2. Anyway diskpart is a free utility built into Microsoft Windows.

1 Like

It does, but I have not had 100% good luck trying that.
If running linux then gdisk or gparted can easily be used to create a new partition table and gparted can format the file system. If using windows then the method shown by Ariana seems the easiest and safest.

If I were formatting the USB for ntfs or vfat I would certainly use windows to do that. If formatting it for any of the linux style file systems then I would use linux since windows cannot format those file systems.