Having issues with playing videos on firefox browser

I have a serious issue on my fedora 36 workstation os. Videos often stops and become stuck at the loading screen on Firefox. However when I try to play a video file on system, the video starts playing like it should and instantly.

Note these also happen in regular use and it even sometimes freezes the entire browser.

Here is the video proof:Fedora-issue-2022 09 23 15 38 20 - YouTube

'Cause I think this is a codec problem, I naturally tried to remove and reinstall it. I remember using this command:

“$ sudo dnf install gstreamer1-plugins-{bad-*,good-*,base} gstreamer1-plugin-openh264 gstreamer1-libav --exclude=gstreamer1-plugins-bad-free-devel”

I changed “install” to “remove” but it did not work because following package “gnome-shell” is protected. I don’t know what to do now.

It seems to me that you are describing a Firefox issue, in that other Fedora applications don’t give you this same problem. If that is correct, you might need a Firefox version change. What version are you running?

No, I didn’t had any similar issue with other applications.
Here is my firefox version: Mozilla Firefox 104.0.1

Edit: Actually I tried Waterfox browser and had the same issue.

Does anything in this thread help?

try this if you have rpm fusion repos enabled:
sudo dnf group upgrade multimedia
this will instal all multimedia codecs

and maybe this
sudo dnf swap ffmpeg-free ffmpeg --allowerasing


Looks like the actual issue is kernel. I booted the “5.19.7-200.fc36.x86_64” version and it worked. Everything works fine now.

Maybe a kernel upgrade would help.
5.19.11 is out now.