Fedora 36 (Vbox guest) - Firefox cannot play YouTube videos?

Hello guys.

I have installed F36 Mate in VirtualBox. It’s clean install, using Everything ISO with Mate package group selection. Everything is up-to-date, Fusion repos enabled (as per official instructions).

The issue is - Firefox cannot play any YouTube or any other tube video.

Graphics driver is set to VMSVGA, 3D enabled (same thing when it is disabled). Basically, it just opens the thumbnail, loading circle is spinning and stays like that. Same thing for every single video, Ad… controls work (but obviously without any effect).

When Ff is run from Terminal, here is the output when some video is played:

ATTENTION: default value of option mesa_glthread overridden by environment.
[2022-05-12T10:36:02Z ERROR mp4parse] Found 2 nul bytes in "\u{0}\u{0}"
[2022-05-12T10:36:02Z ERROR mp4parse] Found 2 nul bytes in "\u{0}\u{0}"
[2022-05-12T10:36:02Z ERROR mp4parse] Found 2 nul bytes in "\u{0}\u{0}"
[2022-05-12T10:36:02Z ERROR mp4parse] Found 2 nul bytes in "\u{0}\u{0}"
ATTENTION: default value of option mesa_glthread overridden by environment.
[GFX1-]: Couldn't sanitize RENDERER device: SVGA3D; build: RELEASE;  LLVM;

Any help is appreciated.

1 Like

Are these HTML5 videos that are expected to work out of the box? If not, you may need to install the necessary codecs (I haven’t fresh installed in a while, though, but this is all I can think of to begin with):

1 Like

Thank you for your reply. That is the first thing I tried, but the issue remains as with clean/default install.

These videos are HTML5 and on Fedora 34 I did not have to do anything to play them.

1 Like

Could you give us an example URL? I’m on F36 now (on 3 different machines), and I can play YouTube videos on all of them without any issues. So it shouldn’t be a general OS level bug.

Just one example, but the same issue is with each single video: https://www.youtube.com/watch?v=RhtiDYLbfF4

I just tried Chromium (freeworld one from RPMFusion repo and it is the same issue). Based on the console error, do you think that maybe is somehow related to rendering and graphics stack? Once again, I am using VirtualBox’s VMSVGA driver (the one that is used for Linux guests) and issue persists with both - 3D enabled and disabled.


I tested the default Fedora Workstation (Gnome on Wayland) on my home desktop, but instead of VirtualBox, I’m using qemu+kvm+virgl - there are no issues. Is it possible that this issue is Xorg related or it is definitely something connected with VirtualBox?

I’ve seen this happen with hardware acceleration enabled in the latest Firefox, due to a bug in its sandboxing. You could try disabling hardware acceleration by reversing the config option listed here and/or disabling the sandbox using the environment variable from there.

1 Like

I got the same issue as well as I’m working on multimedia / Video platform development. Fedora 36 update killed my development. Apparently this is a known issue and as usual i found this problem once I started testing (

MediaException: UNKNOWN : com.sun.media.jfxmedia.MediaException: Could not create player!


See https://itsfoss.com/things-to-do-after-installing-fedora/ .

Look topic #5: “While you can install and use the shiny new desktop experience with Fedora 36, you cannot play videos/media on it — yet.”

This is not the same thing. Fedora does not ship any proprietary software, which includes multi-media codecs because we’re a FOSS only distribution. So one has to install them separately from RPM Fusion or purchase them from fluendo:

The issue being discussed here is different—the user already has the multi-media codecs installed.

I managed to solve it - the issue was that audio device (in VirtualBox settings) was set to Intel HD Audio. I changed it to ICH AC97 and now it works normally.