Firefox can't play video on facebook

Hai All,
I have installed fedora 36 with GNOME 42 Beta 3 in baremetal from this link

Everything is smooth, no error found so far. Great linux distro I love it. I’ve solved this problem when I installed first fedora 34 long time ago, but I don’t remember what step to solve, I just remember to install ffmpeg-libs then I install ffmpeg-libs from rpmfusion free in this fedora 36 but this step doesn’t work. Facebook still can’t play video from firefox. I use firefox default Fedora 36 firefox 96.
How I can solved this problem? I can play normally in other webiste like youtube.

Thank You in Advance

1 Like

Did you only install ffmpeg? You usually need a few other packages too, as noted here:


Yes, I tried to install ffmpeg-free too but it doesn’t work to. Oke I’ll try to install additional paket requirement.

Make sure the Cisco h264 extension is enabled in Firefox. You should see extensions under Add-ons.

1 Like

Oke siap. Thank you very much :heart_eyes: :pray:, It’ works, I just installed this from those link

sudo dnf install gstreamer1-plugins-{bad-\*,good-\*,base} gstreamer1-plugin-openh264 gstreamer1-libav --exclude=gstreamer1-plugins-bad-free-devel

I still can’t get Firefox to play any videos except for YouTube. for example does not work at all.

Since the OP issue has already been solved, please ask about this in a new topic.

I have an issues with my computer I just installed Fedora 35 been having issues please can you help me out

Please make a new topic for this and be as specific as possible about your issue in that topic.

I did about 5 hours ago

I know this has already been answered, but I was able to fix the OP’s issue by installing GStreamer Multimedia Codecs - H.264 (gstreamer1-plugin-openh264) from the default repos.

When you say something like this it leaves others wondering which repo(s) you consider default.

In this case are the default repos the fedora repos, the rpmfusion repos, the cisco repos, or something else?

I see that package as coming from the fedora-cisco-openh264 repo but others may not know that. It helps instead if you specify exactly which repo you are speaking of.

Good point. I came here looking for an answer after doing a fresh install of Fedora 36, so I meant the repos enabled out-of-the-box.

And now that I’ve been using it for a few days, I noticed that the frame rates were horrible compared to what I was seeing on Ubuntu 20.04. Can confirm the proposed solution fixes that. Thanks!