Configuring Plugins for Video Streaming in Firefox

In the beginning I had to configure a plugin to get any video from sources like Youtube playing. I’ve done that and it works for about 2/3rds of the videos. But some still don’t work, and I don’t get more infos or warnings or error messages for it. I likely didn’t do more than install the plugin recommended by firefox after the initial installation.

This one works: Jackie Chan - How to Do Action Comedy - YouTube
This one doesn’t work: Illustrator on the iPad - Editing Pencil Tool Paths - YouTube
Vimeo also doesn’t work completely. Amazon Prime Video works completely.

Could someone give me a hint on what I could try to figure this one out?

Do you have this enabled in Firefox settings?

1 Like

It’s activated, yep.

I don’t need any special plugins to watch that video.

I wonder if it is the opposite, have you installed a plugin/setting that is blocking them?

Are you using arkenfox or some other custom user.js?

I am not sure what a “customer user.js” is.

I am doing some modifications to the loading pages though, since I’m using uBlock origin to block ads. Could this block the whole video from playing? I haven’t seen that happen in other systems, though (not Fedora, but including RHEL desktop, Windows, OSX, Ubuntu). So it would surprise me if that is it.

It is certainly possible to configure it in a way that would block the video but it wouldn’t do that by default. I am also using ublock origin.

I would try disabling your add-ons and seeing if the video plays. If it does, enable them one at a time. If it doesn’t, you know it is something else.

Didn’t work. And besides ublock Origin I just had something called “Widevine Content Description […]” which I have no clue what it does. I think that is what autoinstalled the first time.

When I deactivate ublock I get the ad playing but not the actual video. Dang. So that probably wasn’t it.

Also for me it works.
Maybe, did you install the Multi media group?
dnf groupinstall "Multimedia"

Not sure if it is called the same on your system.
So you’ll need to look for it, maybe by
dnf group list --hidden

1 Like

You don’t want to disable that. That is what lets widevine DRM content play.

Okay. I have reactivated Widevine as suggested by @dalto and I’ve checked that “Multimedia” group is installed (same name) which I could verify with dnf group list --hidden as suggested by @huben.

Same result.

Strange, what you also could try is a different browser, like google chrome.
For this one you would have to enable its repo in advance.

Great idea. I tried Chromium and there the videos work.

So the next step might be figuring out what’s different between these browsers under the hood when they play videos.

The Youtube Support team had some futher things to check.

As a first step I tried logout → login. No success yet. Replay ID after: xcOQrjBHReXhMSyg

1 Like

Updating to current Firefox solved the problem completely, it seems. :star_struck:

1 Like

This is still an issue with Fedora 36. Content sites offer videos in various formats as a fallback, so it’s hard to tell what video format is/isn’t working on a particular page. You can open the Firefox developer tools and look in its Console tab for warnings like

The video on this page can’t be played. Your system may not have 
the required video codecs for:
 video/mp4; codecs="avc1.4D401E", video/mp4;

I find this video page helpful because it has a sample of each video format without fallback. In my case, WebM video works in Firefox, but MPEG, which I think is .mp4 “H264” video, doesn’t. YouTube offers videos in WebM, but Twitter and Facebook seem to prefer mp4. What’s confusing is Firefox has an H264 video plug-in from Cisco that you can install and activate (here’s Fedora’s guide); but it seems to only enable WebRTC video calls, not video playback.

So, you need to install non-free video codecs. Fedora’s guide Installing plugins for playing movies and music seems to be the right instructions. What’s confusing is that guide suggests installing gstreamer plug-ins, but Firefox can also/instead use the multimedia libraries from FFmpeg to play video, and I think this is the default in the Fedora Firefox package (in about:config, media.ffmpeg.enabled defaults to true).

So I think you need to enable the RPM Fusion packages and then install ffmpeg-libs (in a terminal, sudo dnf install ffmpeg-libs), then restart Firefox. That worked for me, and I didn’t install gstreamer plugins, lame, or the Multimedia group as the Fedora docs suggest. Your mileage may vary. (Some guides on the web tell you to install the FFmpeg video player, which works because that installs the ffmpeg-libs as well; but I already have installed VLC to play media.)

If this works for others, please @erikbask somehow unvote your solution and vote this one.

1 Like