Openh264 and Firefox for video playback

Hello All, I completed a fresh install of Fedora 38 Workstation and opened Firefox.
Firefox would not play some videos. I checked plugins and openh264 was not active.

I then followed this helpful guide: OpenH264 :: Fedora Docs

All is well. openh264 is installed and active in Firefox.

Is there a policy prohibiting this function in Firefox with a fresh install of F38?
I checked the box for third party software with my install.
Just curious about the process to setup Firefox, Thanks :slight_smile:

For displaying videos, Firefox is using the ffmpeg package. I would suggest to install ffmpeg from rpmfusion-free-updates, which will allow you to run youtube videos.

OpenH264 is disabled on my Firefox, and I don’t seem to miss it.

Is WebRTC working for you without it? Both teams and webex didn’t work for me until I enabled OpenH264.

I don’t use WebRTC, so I can’t say.

Just for people coming here in 2024, here are the current suggestions for codec packages for Fedora Firefox:

For AMD on Silverblue, see this:

1 Like

I forgot about Intel’s media driver with F40 and just figured without RPM Fusion’s stuff I’d be unaccelerated. Firefox said it was ok, and after checking, libva-intel-media-driver was already installed. Cool stuff!

On that page it notes:

Accelerated video decoding works well on most Intel GPUs as free drivers are available. There are two[1] drivers for Intel cards, libva-intel-driver (provides and intel-media-driver (, a.k.a. “iHD”, for recent[2] chipsets). Currently, Firefox works with either libva-intel-driver or intel-media-driver.

And on F40 Workstation/GNOME right now:

  • intel-media-driver doesn’t exist as a package in default repos
  • libva-intel-media-driver provides the iHD driver for me (Coffee Lake/UHD 630)

If I remember right from F39, the intel-media-driver that was in F40 pre-release repos was patent-encumbered (couldn’t accelerate interesting stuff). I didn’t try anything yet on F40’s libva-intel-media-driver driver.

Also Firefox on Wayland from seemingly any DE (GNOME and KDE) won’t render at your refresh rate if it happens to be above 60Hz. Changing layout.frame_rate solves that nice and easy! Not a problem on Xorg, but probably not a bad idea to check Target Frame Rate in about:support

Has RPM Fusion and Fedora ever stopped that inconsistent update dance where installing mesa-va-drivers-freeworld on AMD would sometimes reboot to a black screen because of a Fedora update overriding the freeworld stuff?

That whole ordeal broke my trust of RPM Fusion’s quality and stopped me from even entertaining any of their repos on my systems. Interestingly most of my media still plays fine :stuck_out_tongue:

1 Like

Yes, now partial mesa update will be blocked.

PR#21: Ensure that most subpackages have the same version as mesa-filesystem - rpms/mesa -

1 Like

Likely unrelated to video playback, but I was reading that HW accel page and noticed:

X11 backend can tun in two modes - EGL and XGL. You should be on EGL unless you’re running on unsupported config (old NVIDIA drivers, NVIDIA drivers on XWayland or so).

I didn’t know what EGL actually was all this time and clicked the linked blog post about it:

GLX is old, well debugged and tied closely to X11 which means seamless experience and wide support by gfx drivers (like proprietary NVIDIA ones). It’s used by most X11 applications and ‘just works’.

I’m on Xorg and it sounds like I’d want to be using GLX (Intel UHD 630). I don’t know of any known issues, but about 5 minutes with gfx.x11-egl.force-disabled true is looking fine on Firefox 125.0.2 and F40 GNOME on X.

I have more research to do for sure, but I get the impression that GLX is more direct than EGL, or it’s something like libinput vs evdev.