Codecs missing, failing to play h.264

hello, I failed to play an mp4 (video) file in the Gnome’s Video app and Firefox.

Screenshot from 2024-02-07 15-34-36
^Gnome Videos

Screenshot from 2024-02-07 15-35-39
^Firefox

it claimed that the necessary codecs are missing but I have installed all the RPM repos and drivers. it also appears to be installed in Software:

for whatever it’s worth, I’ve never had an issue playing YouTube (which as far as I know is also formatted to h.264).

any ideas what’s the issue?
thanks for your tips! :slight_smile:

Can you show your repo list?

sudo dnf repolist

It will list the repos you have installed. I have these repos on my system:



fedora                                                                                          Fedora 39 - x86_64
fedora-cisco-openh264                                                                           Fedora 39 openh264 (From Cisco) - x86_64
rpmfusion-free                                                                                  RPM Fusion for Fedora 39 - Free
rpmfusion-free-updates                                                                          RPM Fusion for Fedora 39 - Free - Updates
rpmfusion-nonfree                                                                               RPM Fusion for Fedora 39 - Nonfree
rpmfusion-nonfree-updates                                                                       RPM Fusion for Fedora 39 - Nonfree - Updates
updates                                                                                         Fedora 39 - x86_64 - Updates

With Firefox, at least on my part. I do not install the GStreamer. I do however install the openh264 and mozilla-openh264. I believe installing the mozilla-openh264 will download openh264, but I download and install both for safety.

sudo dnf install openh264 mozilla-openh264

Now, on Firefox, you have to go to Extensions → Plugins

Then click on the 3 dots, at the openh264 plugin and mark Always Activate and Standard update.

On GNOME, I do not use Totem or Rhythmbox, I download VLC which already downloads all sorts of codecs, so I watch any video on my computer. But I always have RPM Fusion enabled before any of these steps above. Hopefully this helps.

Edit: I also relogin or restart my system after installing these codecs, it may be unnecessary but on the Firefox end, in my case, it helped, and I have no more issues with it. Udemy has one of the most obscure DRM videos, and I use it to test any video misconfiguration, and is working fine,

brilliant thank you!
I remembered that I did install the Firefox codecs extension but it turned out it was disabled by default.

$ sudo dnf repolist
repo id                                        repo name
copr:copr.fedorainfracloud.org:phracek:PyCharm Copr repo for PyCharm owned by phracek
fedora                                         Fedora 39 - x86_64
fedora-cisco-openh264                          Fedora 39 openh264 (From Cisco) - x86_64
google-chrome                                  google-chrome
rpmfusion-free                                 RPM Fusion for Fedora 39 - Free
rpmfusion-free-updates                         RPM Fusion for Fedora 39 - Free - Updates
rpmfusion-nonfree                              RPM Fusion for Fedora 39 - Nonfree
rpmfusion-nonfree-nvidia-driver                RPM Fusion for Fedora 39 - Nonfree - NVIDIA Driver
rpmfusion-nonfree-steam                        RPM Fusion for Fedora 39 - Nonfree - Steam
rpmfusion-nonfree-updates                      RPM Fusion for Fedora 39 - Nonfree - Updates
updates                                        Fedora 39 - x86_64 - Updates

~$ sudo dnf install openh264 mozilla-openh264
Last metadata expiration check: 0:31:20 ago on Wed 07 Feb 2024 18:51:39 CET.
Package openh264-2.3.1-2.fc39.x86_64 is already installed.
Package mozilla-openh264-2.3.1-2.fc39.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!

thank you for your help!

There may be other codecs missing that may need installed.
Try sudo dnf install libavcodec-freeworld --allowerasing to install the missing codecs

2 Likes

2 posts were split to a new topic: Unable to connect to mirrors

worked like a charm, thanks!