Can't get widevine media to play in any browser

I just installed Fedora yesterday, and I can’t get any widevine media (crave, amazon etc) to play. The day before, I was playing this media fine on Ubuntu.

Because it doesn’t work in any browser I’ve tried, I believe it is based on an underlying problem, and not in the browsers themselves (though it’s still possible the browsers are at fault).

I made sure ffmpeg and a bunch of codecs were installed, but still no luck.

Any ideas to get this working?

sudo dnf install chromium-freeworld

Enabling the RPM Fusion repositories :: Fedora Docs

Thanks for your quick response! I really appreciate that. :slight_smile:

I should have checked your reply sooner too. I did some more troubleshooting on this issue, and I found this in dmesg:

[31635.699766] MainThread[52965]: segfault at 0 ip 00007f7d3904abda sp 00007ffcc137a5f0 error 6 in[7f7d37fa3000+43bf000]
[31635.699789] Code: 00 00 00 00 00 00 00 0f 0b 4c 8d 05 80 b4 3f 04 4c 89 00 c7 04 25 00 00 00 00 00 00 00 00 0f 0b 48 8d 3d 99 b4 3f 04 48 89 38 <c7> 04 25 00 00 00 00 00 00 00 00 0f 0b 48 8d 35 ba b4 3f 04 48 89

I started looking in to that further, but then I just tried installing the standard Firefox browser, instead of the Fedora special edition, and the standard one works fine.

So, I guess this is a bug? I certainly wouldn’t be okay with one of my apps not working and causing crashes by default. Does Fedora or Mozilla (or someone else) handle this “Firefox for Fedora” browser?

Sorry, I’m not sure about Firefox, but you can try Chromium Freeworld as mentioned above.

Thanks for the info! I’ll try that if I have more problems.

Hopefully someone else knows about Firefox though. I think that what ships with the distro should work correctly. :slight_smile:

Have you checked this setting in Firefox?


Netflix works for me after installing ffmpeg from RPMFusion. How did you

made sure ffmpeg and a bunch of codecs were installed


1 Like

That is enabled by default, but I did check it to be sure!

I also see you’re not running the Fedora specific build of Firefox, which is the one with the problem. This is exactly why I’m not a fan of distro-specific builds.

I was taught that every abstraction layer (or fork, or whatever) is another place for bugs to live, and it keeps proving to be true.

I don’t think Netflix uses wildvine, but I’m not sure because I don’t have a subscription.

I made sure they were installed by installing them. :slight_smile:

($) ~: dnf list ffmpeg
Fedora 34 - x86_64 - Updates                                                                                                                                                                                   18 kB/s |  11 kB     00:00    
Fedora 34 - x86_64 - Updates                                                                                                                                                                                  1.5 MB/s | 2.3 MB     00:01    
Fedora Modular 34 - x86_64 - Updates                                                                                                                                                                           48 kB/s |  10 kB     00:00    
Fedora Modular 34 - x86_64 - Updates                                                                                                                                                                          193 kB/s | 177 kB     00:00    
RPM Fusion for Fedora 34 - Nonfree - Updates                                                                                                                                                                   98 kB/s |  10 kB     00:00    
Installed Packages
ffmpeg.x86_64                                                                                                    4.4-2.fc34                                                                                                    @rpmfusion-free

For the record, widevine content works fine for me on Fedora Firefox after checking that box.(For me, it was not checked by default.)

That is because I took that screenshot on a machine that wasn’t running fedora at that moment. I multi-boot different distros on that workstation.

Does fedora have a fork of firefox? Are you sure it isn’t just being built by Fedora? Almost every package on every Linux distro is being built by the package maintainers for that distro.

That being said, if you want a version that is built by Mozilla, grab the Firefox flatpak from flathub.

Thanks for the additional info! I’m glad its working out well for you.

I mentioned this in a previous post, but I don’t know who forked or builds what. I installed Firefox from Mozilla directly, and it works properly.

The wildvine plugin now seems to be working in Firefox for Fedora, though I’m not exactly sure why.

I suspect it may be due to me installing the standard build from Mozilla. Surely that installed some dependencies; I see some .so files with the binaries.