GNOME Software is only showing Snap applications

Since I upgraded to Fedora 30 (though the problem may have originated prior) whenever I launch GNOME software, it only shows installed applications and Snap applications, thus rendering it almost useless.

I have tried refreshing DNF, Appstream, and PackageKit. I have also tried cleaning the DNF cache and deleting GNOME Software’s cache. I even reinstalled Software. The issue persists.

Here’s the log when starting GNOME Software if it helps:

14:30:29:0137 Gs  enabled plugins: desktop-categories, fwupd, os-release, packagekit, packagekit-local, packagekit-offline, packagekit-proxy, packagekit-refresh, packagekit-upgrade, packagekit-url-to-app, shell-extensions, appstream, fedora-pkgdb-collections, snap, desktop-menu-path, epiphany, flatpak, hardcoded-blacklist, hardcoded-featured, hardcoded-popular, modalias, packagekit-refine, rewrite-resource, odrs, packagekit-history, provenance, repos, systemd-updates, generic-updates, packagekit-refine-repos, provenance-license, icons, key-colors, key-colors-metadata
14:30:29:0137 Gs  disabled plugins: dummy
14:30:29:0301 Gs  not handling error failed for action get-updates-historical: failed to build result for 1c77a29dfc8470842d4bde4f48fcde6c63a8664b
14:30:34:0070 Gs  Only 0 apps for recent list, hiding
14:30:34:0913 Gs  hiding category audio-video featured applications: found only 0 to show, need at least 9

I tried switching to dnfdragora and it gave me this message, a similar one appeared in Software:

dnfdaemon client error occurred:
g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name is not activatable (2)

Hello @northivanastan, welcome to the community!

So, does the “all” tab not show in gnome-software at all? This is what mine looks like on startup for gnome-software-3.32.1-3.fc30.x86_64


Not sure about the dnfdragora error, but it does not need to be related to the gnome-software issue. Does installing software off DNF normally work?

The “all” tab is visible on what I believe to be the same version. It looks like this:

All visible apps here are Snap applications. At one point I tried uninstalling gnome-software-snap, and it resulted in “All” being nearly empty, with only the categories visible.

The problem is more visible when I go into a category: image link

All visible apps are installed apps with no icons.

Installing software with dnf install works, so does pkcon install.

Update: DNFDragora seems to have fixed itself. GNOME software is the same, though it’s showing even fewer apps than before.

Can you please check what packages you have installed?

rpm -qa \*soft\* \*app\*

Gnome-software requires appstream metadata to work. Fedora (and RPMFusion) both provide this.

Output of that command:


I appear to have both Fedora and RPMFusion’s AppStream data.

Nothing weird there either. Can we try reinstalling these packages in case they weren’t properly done in the upgrade?

sudo dnf reinstall gnome-software gnome-software-snap appstream-data

Can you also install dconf-editor and check if there are any gnome-software related settings that look off?

Another thing to check is if the different software sources are all enabled? These can be checked in the preferences: the “burger” menu on the right hand side top corner of gnome-software.

I didn’t see anything that looked off in dconf-editor, but here are all the settings:

All of Fedora and RPMFusion’s software sources are enabled, except for testing ones, I believe.

Reinstalling the software didn’t seem to do anything, other than increase the loading time.

I’m out of ideas now—how about creating a new user and seeing how gnome-software does there?

A new account I created has the same issue, so it’s definitely a system issue. I guess for now DNFDragora works, and I’m planning on getting a new laptop soon anyway…

Continuing the discussion from GNOME Software is only showing Snap applications:

Yes, I’m having the same issue. In my case it’s even worse because I haven’t installed snapd so it doesn’t show any application. It happened after installing Mendeley, I reinstalled Fedora 30 and the same issue happened again after installing Mendeley. I reinstalled Fedora again and I didn’t install Mendeley this time, I tried to enable rpmfusion repositories and the problem showed againCaptura%20de%20tela%20de%202019-05-06%2017-47-09

hmm, this might actually be a bug then

I don’t have Mendeley installed, but I do have RPMFusion enabled. Some further triage questions if anyone wants to pursue this:

  • does it happen on KDE Discover, a very similar app? If yes, problem is with AppStream or PackageKit
  • does it happen on other OSes that use GNOME Software? (probably not, I can only seem to find reports of this on Fedora, at least ones that can’t easily be fixed). If yes, problem is probably upstream, if no, problem is probably with a Fedora package.

The problem doesn’t happen on KDE Discover, I’ve installed it and it worked just fine

Looks like bug 1704971, maybe?


yeah that seems to be it

I would uninstall gnome-software-flatpak but I can’t since it’s included in the gnome-software package

  • Fedora 29 workstation, rpm-fusion enabled, nouveau driver, Gnome v3.30.2

Hello pals, sometimes gnome-software behaves that way, e.g. After run the command $ sudo dnf update along with rebooting the computer.
The best known solution is log-out and log-in . But sometimes I need do it 2 times.
But, what if are you working with a tons of oppened applications? you will be forced to close all windows first. I tried ‘r’ in the ALT+F2 prompt, but didn’t solve the problem.
Is there another way to solve that?
Which recommendations do you suggest to avoid that?
What do you think could be generaitng the problem?


after starting gnome-software there is no proposed apps (only categories, but in that categories there lacks some categories inside them), I can’t find a lot of apps, that were previously “searchable” and installed apps don’t have icons. I give you three screenshots

  1. first menu after starting gnome-software
  2. my apps list
  3. what can I choose in forst category (“Dźwięk i obraz”)


When starting Software from CLI (I put “gnome-software” in commandline) there is no output (just window appears).
Why that happened?

Hello @garbulix—welcome to the community.

This is sometimes caused by an incorrect metadata load. Can you please try:

pkill -f gnome-software  # kills the current instance of gnome-software

and then re-running it?

1 Like