Gnome ABRT is failing to upload bug reports because the API key is invalid

I’m trying to upload a bug report to Bugzilla on Fedora 36 but I’m getting the below error message because the API key is invalid, I generated a new API at the Bugzilla website but I’m still getting the error message:

What gives?

Then did you configure ABRT with the new API key, yes?

Yes, of course.

Seems to work for me here. Can you please double check the API key please? When did you generate this, by the way? I think they expire every 12 months now:

I did it yesterday after I reinstall the OS on the weekend, the first one you see in the below screenshot already expired so I created a new one, however, I just noticed that the new key is still in an " never used" state though it’s already entered in ABRT:

Gnome ABRT has two tabs in configuration, one is called “Workflows” and it has 10 settings where the key is put automatically after I enter it for the first time, the other tab is called “Events” and it has one setting where the key is put automatically as well, I just checked each one and I see the new key in there but it seems ABRT is failing to read it or use it:

OK, that looks all OK. What string are you putting in? It’s not the “API Key ID” bit that you see on the page. The key is 40 characters here for me. From what I know, it’s only shown when we generate it the first time.

I remember that I put the API Key ID the first time, it was 4 numbers, like a pin, it worked back then but it suddenly stopped working, hence my post.

I don’t recall that I ever explicitly created a key for bugzilla, but I see a file ~/.ssh/bugzilla_api_key

If you have that file it may contain your key and code.

Ah? No—the ID is not the key and should not have worked. It needs to be the 40 character thing. If you don’t have one, you’ll have to generate a new one.

Where is that file located?

I’m going to generate a new one but if I don’t see any 40 character thing then it is the 4 digit number the one that needs to be input.


I know that it is a hidden folder but I don’t see it.

Now that I remember, I had the key saved on my computer :man_facepalming:

Since that one already expired, I was able to generate a new one and use it:

Thank you for helping me out!.

1 Like