Can't report a bug (complains my Bugzilla API key is invalid?)

I’m trying to report an issue (gnome-shell crash on F37), but abrt doesn’t like my API key: “fatal: RPC failed at server. The API key you specified is invalid. Please check that you typed it correctly.” - I’ve created a new API key (4 digits? that’s odd) and I’m unsure WHERE I can put my username, but it fails. I must be missing something.

1 Like

Hi @mykaul , welcome to the community!

I don’t think the API key is only 4 digits. That’s the API “key id”. My API key is 40 characters long. it should tell you the complete key when you generate one.

I checked my abrt settings and one does not need to provide a username, only the API key.

I’m pretty sure you are right and embarrassed to say I don’t know how to fetch the whole key! The bugzilla UI (and its documentation) aren’t very helpful :frowning:

1 Like

No worries. I just created a new test key, and it pops up a red box with the key. Once you close that you cannot retrieve the key:

Do you not see this when you create a new key here?

I did no get that box - at all! Tried now, and it worked (could be related to the adblocker or something? It was always off on … Strange. Anyway, looks good now!

Thank you!

1 Like