Fedora 40 Beta live doesn't start unless boot with "Basic Graphic Mode"

I am able to enter the live environment (Gnome) when testing in Gnome Boxes but on real system (my Lenovo laptop) I am not able to reach Gnome home screen.

Full Context:
I made a bootable USB with Fedora Media Writer and when I boot from it, it is stuck at Fedora logo when I select first option from boot menu (Fedora 40 Live). When I select 2nd option (Check Media), it is stuck at “starting GDM”. (sysyemctl start gdm.service). When I select the 3rd option (Troubleshooting → Basic Graphic Mode), I am actually able to boot into Gnome desktop live.
I even installed the Beta from the Basic Graphic Mode but I realized there is no animation hence it is same as Basic Graphic Mode live. After looking for solutions on the internet and finding nothing concrete, I am back to Fedora 39 Gnome and probably I will wait for the fix before trying installing Fedora 40 Beta again. I guess the kernel in the beta is having issues with my GPU?
Here is my system hardware specs->

System:
Kernel: 6.7.10-200.fc39.x86_64 arch: x86_64 bits: 64
Desktop: GNOME v: 45.5 Distro: Fedora Linux 39 (Workstation Edition)
Machine:
Type: Laptop System: LENOVO product: 82XV v: LOQ 15IRH8
serial:
Mobo: LENOVO model: LNVNB161216 v: SDK0T76485 WIN
serial: UEFI: LENOVO v: LZCN34WW date: 12/19/2023
Battery:
ID-1: BAT1 charge: 47.6 Wh (79.3%) condition: 60.0/60.0 Wh (100.0%)
CPU:
Info: 8-core (4-mt/4-st) model: 12th Gen Intel Core i5-12450H bits: 64
type: MST AMCP cache: L2: 7 MiB
Speed (MHz): avg: 411 min/max: 400/4400:3300 cores: 1: 400 2: 506 3: 400
4: 400 5: 400 6: 400 7: 400 8: 400 9: 435 10: 400 11: 400 12: 400
Graphics:
Device-1: Intel Alder Lake-P GT1 [UHD Graphics] driver: i915 v: kernel
Device-2: NVIDIA GA107 [GeForce RTX 2050] driver: nouveau v: kernel
Device-3: Bison Integrated Camera driver: uvcvideo type: USB
Display: wayland server: X.Org v: 23.2.4 with: Xwayland v: 23.2.4
compositor: gnome-shell driver: dri: iris gpu: i915
resolution: 1920x1080~144Hz
API: OpenGL v: 4.6 vendor: intel mesa v: 23.3.6 renderer: Mesa Intel
Graphics (ADL GT2)
API: EGL Message: EGL data requires eglinfo. Check --recommends.
Audio:
Device-1: Intel Alder Lake PCH-P High Definition Audio driver: snd_hda_intel
Device-2: NVIDIA driver: snd_hda_intel
API: ALSA v: k6.7.10-200.fc39.x86_64 status: kernel-api
Server-1: PipeWire v: 1.0.4 status: active
Network:
Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
driver: r8169
IF: enp7s0 state: down mac:
Device-2: Realtek RTL8852BE PCIe 802.11ax Wireless Network
driver: rtw89_8852be
IF: wlp8s0 state: up mac:
Bluetooth:
Device-1: Realtek Bluetooth Radio driver: btusb type: USB
Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: bt-v: 5.3
Drives:
Local Storage: total: 476.94 GiB used: 14.22 GiB (3.0%)
ID-1: /dev/nvme0n1 vendor: Samsung model: MZAL4512HBLU-00BL2
size: 476.94 GiB
Partition:
ID-1: / size: 74.2 GiB used: 9.62 GiB (13.0%) fs: btrfs dev: /dev/nvme0n1p7
ID-2: /boot size: 973.4 MiB used: 288.2 MiB (29.6%) fs: ext4
dev: /dev/nvme0n1p5
ID-3: /boot/efi size: 598.8 MiB used: 19 MiB (3.2%) fs: vfat
dev: /dev/nvme0n1p6
ID-4: /home size: 100 GiB used: 4.29 GiB (4.3%) fs: btrfs
dev: /dev/nvme0n1p8
Swap:
ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
Sensors:
Src: /sys System Temperatures: cpu: 40.0 C mobo: N/A
Fan Speeds (rpm): N/A
Info:
Memory: total: 16 GiB note: est. available: 15.34 GiB used: 4.17 GiB (27.2%)
Processes: 650 Uptime: 1h 26m Shell: Bash inxi: 3.3.33

Removed audio, bluetooth, f39, intel, lenovo, pipewire

If you did a fresh install of F40 Beta, you get the nouveau driver. If you didn’t wipe the F40 install, try installing the close source Nvidia driver from rpmfusion.

I can’t boot into live environment to start the installer itself.
I did install using “Simple Graphic Mode” as I was able to boot into the live environment using that option only but the UI was flat obviously. So I came back to F39 and submitting the issue here.

Boot to the installed system. This may require that you use the grub menu and edit the kernel command line entry there to boot to basic graphics mode.
Pressing and holding the shift key after the bios splash screen appears and until fedora starts to boot should display the grub menu.
You then should be able to press e to edit the grub commands and make certain that there is an opition in the line that begins with linux that reads nomodeset. Now when you continue to boot it should properly boot into basic graphics mode.

Once there and during the initial setup enable the 3rd party repos.

Finally, after completing the initial first boot setup you can open a terminal and install the nvidia drivers with sudo dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda.

Wait 5 minutes or more after that completes then reboot and the problem with graphics should be solved.

This also may require that you disable secure boot to enable loading the drivers.

You said above that the installer will boot when using the troubleshooting option and boot to basic graphics mode. Did you not complete the install that way?

Hi, Thanks for the reply. So if I am not wrong, your solution is to boot in “Basic Graphic Mode”, install the Beta and enable 3rd party repos to install some Nvidia drivers and reboot after 5 minutes and make sure secure boot is disabled?

So the problem is Nvidia Graphics Card that I can’t boot with normal graphics? And this (problem) is only for the Beta? Because I installed Fedora 39 Workstation/Sway/KDE without any issue without booting with “Basic Graphic Mode”

And there will be no such issue in Fedora 40 stable release?

Yes I completed the installation with basic graphic mode but obviously there were no animations. I did sudo dnf update also after enabling 3rd party repos but still no animations so I came back to Fedora 39 Workstation. I did not install the drivers you mentioned that time though. I should have made this post from that installed 40 Beta only and waited for the replies but as it is my main work device for office so rather switched back to F39.

I am having the same issue, slightly different Lenovo hardware, Nvidia GPU.

While I see suggested workarounds, to me, this a show stopper bug that needs to be fixed in the installer before release. The majority of laptops have a Nvidia GPU (if they have a discrete GPU).

As an added observation, I do not see a Safe Graphics option on the March 26th installer. EDIT: Found Safe Graphics option under Troubleshooting.

Update:
I tried April 5 build of the beta and this issue has been resolved there.

Here is the link if anyone want to test -
Fedora 40 Beta April 5 Build

It has been resolved I guess. Check my last reply for details and link to April 5 Build of the beta, you can also try it.

What really needs to happen is people need to stop using beta releases for anything other than testing for the final release. Rawhide and Beta releases are for testing, period. If you don’t want to have to figure out work arounds or bugs, don’t use anything but the release. If you’re comfortable with solving the potential issues, then by all means use them and help fix the bugs before release.

1 Like

How oddly passive-aggressive of you. Who said I was using Fedora 40 as a daily driver? In fact, I specifically state it needs to be fixed before release. This specific problem needed a workaround because you can’t do any testing if you can’t get it installed!

See. I can use italic too.

Not passive aggressive in the least. The question originally posted is in ask fedora so I thought it was a help request. If this is truly for testing then the discussion should be in project discussion qa testing IMO not ask since ask.fp.o is for ad hoc community support.

Bravo on your use of markdown.

On the beta page, I’m not seeing an April 5th installer, just the same march 26th. Where’d ya find this?

I believe F40 was put into final freeze on Apr 2 and will receive only security related or blocker updates between now and final release in the next few weeks.

If you install that release from Mar 26 then to a dnf upgrade you will see some updates to the latest.