Fedora 38 showing cursor on blank screen on Surface Pro 5 after upgrade, and now upgraded from 36 to 38 and messed up the grub menu

I am new to Linux. I tried to install fedora 37 and 38 using bootable USB drive. While installing I got a non blinking cursor with a blank screen. I could not proceed any further. Hence, I tried installing fedora 36 and succeeded. Now I upgraded to fedora 38. Now I am having grub menu with multiple options as shown below. When I select rescue mode fedora 36, I am able to enter into fedora 38.

I searched and found fixes for NVIDIA graphics cards, but my surface pro 5 laptop comes with Intel® Iris® Plus Graphics 640 (Kaby Lake GT3e) (KBL GT3). I do not know what to do and how to fix this. After fixing this I have to also install the surface kernel to get my touch screen working. Can someone please let me know how to fix this problem. I highly appreciate the help. The below is what I can find on my settings->info screen. I am sorry that I have provided very limited information. Please let me know what log and how to extract the log which might be helpful to further analyse this problem.


Hello, try to look at my previous post if works for you.

I tried running the command sudo grubby --update-kernel=ALL --args="tpm_tis.interrupts=0" on my terminal and restarted - nothing changed after this. Should I uninstall any kernel and reinstall? If yes, which one should I remove ? The below is what I could manage to get based on my limited knowledge. Sorry.

I’ll go to remove the latest one, the 6.4.7.
But you’ll find it again at first update.
Can you boot the 6.2 kernel?

I am only able to boot using the last 2 ones which is that list item that contains the rescue and the other one which says Linux (5.17**) 36. Both says 36 but when i enter into the operating system it shows 38 and not 36. The update has been successful. I think i am going to using some tool and remove all the entries except “Linux (5.17**) 36”. Any other suggestions ?

I do not know if I have solved the problem or hide it. I just issued the r

pm -qa kernel* |sort -V

command and then removed everything using the

sudo dnf remove

command. I hope there will be no problem in the future.

I am still running on Fedora 38 despite removing all latest 6.* kernels.

Hello @kuttan ,
When you are booted into the working setup, please type uname -a and post it here.
What you can do is this to apply a system upgrade to Fedora F36 …
First sudo dnf upgrade and if you are getting errors about conflicting packages add --allow-erasing to the end of that command to fix that.
After this completes you can upgrade your system. If you want to wait on Gnome Software to find the new release, it may take some time and with two releases difference it may not do it period. If you don’t , you can use dnf’s plugin system-upgrade. Which you can read about … here … https://docs.fedoraproject.org/en-US/fedora/latest/system-upgrade/

hello @kuttan ,have you solved the problem?if not,hope my experience will give you some help.
two weeks ago,I switched from windows to fedora,I got the same problem like you.I can’t install fedora37and38 with bootable usb drive,but fedora36 works well,so i installed fedora36 and update,new problem appears,it can’t boot since kernel 6.2.* and later. i searched the forum and got nothing to solve the problem.I had to run fedora36 on my surface pro5.
a few days ago,I decide to install linux-surface kernel to use touch function,and i found this page:https://githubfast.com/linux-surface/surface-uefi-firmware. then I had a try in that way.I downgraded UEFI from 239.645.768.0 to 238.167.768.0. now I can install fedora38 using bootable usb drive,and everything runs well.
here is my uefi info:

sorry for my bad english cause it is not my native language.hope you can understand what i am saying😂


Using Fedora with Microsoft Edge on Microsoft Surface Go. Surface devices are closed source modified devices with modified closed source EFI bios like Apple. Red Hat has a special interest group targeting Microsoft Surface devices so just wait, things will calm down and software with tweaks will fall down from the sky. The cameras are closed source and do not work, every thing else is fine with full access Microsoft services.
Companies are finding ways to pull corporate users to their frameworks, Google Workspace to Apple or Microsoft devices, Red Hat from Windows to JBoss EAP with RHEL, … a good and thoughtful way. Be careful about dual booting with Windows as focused on security that explain problems with Grub. If you erase recovery partition, default action on Fedora installer, no easy way to get back to Windows or any thing else.

The link you shared says forbidden. I knew there is some problem with UEFI version. Thank you so much for confirming it. I did not know that you can downgrade it. That is why I stopped using fedora. I installed Debian now. I am liking the stability Debian offers. I am not very much excited about brand new features. I like GNOME with what it can offer on top of Debian. I highly appreciate the effort you all have put to help me out resolve this. Thank you so much. :slight_smile:

I can open it normally,or maybe you can try the link without “fast” if you want.BTW I am glad to hear that you have found a distro and like it,have a nice experience.


how to do UEFI from 239.645.768.0 to 238.167.768.0.,

where to download it

Thank you


if your laptop is surface pro 5,you can download from https://www.microsoft.com/en-us/download/details.aspx?id=55484.
SurfacePro_Win10_18362_21.101.11488.0 worked for me

Link is 403 Forbidden

https://githubfast.com/linux-surface/surface-uefi-firmware 2

just visit github.com,and search linux-surface,then surface-uefi-firmware

你好,看了你的截图,为啥我的uefi版本好和你的格式不一样,我的23.开头的,我的是surface pro 8国行