Blank screen with cursor after update

Hello all,

I am in need of help.

I am using Fedora 34 on a machine with the below hardware:

M.B.: Gigabyte GA-770TA-UD3
CPU: Phenom II X2 555
GPU: Radeon RX 580
Memory: 4 + 2 + 4 + 2 = 12 GB
HDD: 2 drives RAID 0, 1.2TB

I kept receiving the update notification and did the update. After the reboot, the system booted up until the Fedora logo disappeared, and I assume just before the login screen, it goes black with a cursor blinking on top left corner.

I found something “nomodeset=0” entered it before the boot screen by pressing the “E”. I am really not good at linux and stuck with this issue. Any help is appreciated cause I have been trying to find something to fix for the past 4 days. Need the data on the drive, otherwise I know reformatting can be a solution. Thank you for your time and help in advance.

Have a good weekend.

I forgot to mention, after nomodeset command, it shows a weird screen like the whole screen jumbled up with colors, or an artifact, but turns into the black screen with cursor again.

From time to time the screen flashes like it tries something but fails and go back to black cursor screen. The machine never freezes though, when I press the sleep button on the keyboard it goes to sleep, or Ctrl + Alt + delete restart the machine and it shows the list of everything turned off, disabled one by one and restarts.

First thing that pops into mind. Your memory config is highly unusual. It is always recommended to have the same size memory modules installed.

While it may not be the cause, please remove the one potential issue and remove both 2GB modules so you are left with 2 4GB DIMMs. Then verify they are in the proper slots per the mobo manual. This image is directly from the manual for that motherboard.


Your description of the memory config implies that you have the banks crossed with one 4GB and one 2GB in each bank.

The latest firmware (bios) for that board is F4B released 2010/08/02.

Have you tried to access a console by pressing ctrl+alt+f2 when it is halted with the black screen.? (you could also use f3,f4,f5, or f6).
If you can get the console screen and log in then this would appear to be an issue with graphics and not anything else.

You do realize I hope, that fedora 34 will go EOL in about a month after fedora 36 is released on may 10. You definitely should do an upgrade to at least fedora 35, and the issue may be a moot point if you upgrade to the later release.

It can be tested by burning the fedora 35 iso to a usb stick and booting live from that device to see how it works for you before actually upgrading. If everything works with the live boot then I suggest you actually upgrade the installed system.

1 Like

Dear Jeff,

First of all, thank you for sparing your precious time to answer, very kind of you.

Secondly, I know it looks weird and I had extra sticks and just installed them but you are right, I’ll remove them.

The console part, never tried because I didn’t know. I kept reading people trying different commands, now I know at least where they used :grin:.

Been a user of Windows and Mac, I thought there’s a system rescue/restore option but couldn’t find such a thing.

As you mentioned, prepared a live USB stick (Fedora 34) wanted to access the disk so I could back it up but the disk is encrypted and didn’t even mount. Then I tried Parted Magic, also failed. Now I’m gonna remove the extra sticks, make it 8, try the console, and share the result.

If I manage to save my data from the disk, I’ll reformat and do a fresh install of 36.

Again, sincerely thank you for your time, appreciated.

Hurray, it did launch the console, and I managed to login to my account, and now my username is there and I’m searching how to switch to GUI.

Ctrl+alt-F1 brings me back to black cursor screen, F3, 4, 5 etc asks me to login again which I did hoping to switch to the GUI but did not.

I tried to use 3, 4, and 5 at the grub menu, edited the line and added those numbers one by one did not work.

Tried “sudo dnf history undo last” in order to rollback to the previous working state didn’t work.

No matter what it ends up at the blinking cursor screen.

I had a Radeon 5830 laying around, I installed and tried again, no luck, still black screen with cursor.


1 Like

Hi Jeff, thank you again for your reply but it throw out an error, something is missing:

I pasted an error message but it is recognized as spam, waiting for the admin check it, basically it starts for a second and throws and error message.

And I found this on another forum, should I try?

I changed my password, reinstalled xserver-xorg by typing:  sudo apt-get install --reinstall xorg

Found another solution since startx command didn’t work:

chown -R mikey:users /home/mikey

It scrolled a lot and all the lines have “Operation is not permitted” message at the end.

Started to lose hope :frowning:

On a different forum found the below commands and it showed a login screen, same background I use, but it said login failed even though I entered the correct password. The login screen was also weird as it was for a tablet or a touch screen device:

sudo systemctl set-default

sudo systemctl enable sddm --force

The mouse pointer is still on the screen showing.

Don’t ever do that. Fedora does not use the “users” group as other distros do and changing group ownership of your home directory may have disastrous consequences.

Changing your password is certainly OK. Reinstalling all the xorg pieces certainly won’t hurt sudo dnf reinstall *xorg*

Did you copy & paste this from the screen or did you type it in? /etc/X11/xorg.comf.d as a directory does not exist by default.
You can easily highlight text on the screen with the mouse then a right click to select copy so the formatting is retained.

Have you looked at /home/mikey/.local/share/xorg/Xorg.B.log to see what it may tell you? In what you posted a see a reference to /lib64/libwayl but it does not point to an actual library file so cannot possibly check what the error is there. If you were to copy & paste the text the full reference would not be cut off. I have 16 different /lib64/libwayland-* files on my system.

Remember that since you are using an OLD version of fedora with updated software there may have been problems introduced by the updates.

Dear Jeff, sincerely appreciated your help, but nothing is working :(.

I am done with linux and Fedora especially. I go back to Mac OS, what’s gone is gone, thanks to linux months of work I lost and that was not even my fault, I just updated it cause it kept crying.

Again thank you so much Jeff, you are a great helper. Have a great one ahead.