Fedora KDE Blackscreen with only Cursor instead of login screen

Hey, i have 2 Systems:

Dell XPS 9720
Nvidia RTX 3060

PC with Ryzen 5900 and Nvidia RTX 2070

On both systems the Fedora KDE installer boots directly into a blackscreen with the cursor only visible and even movable, so i use the ‘safe graphics’ mode to install the OS.

The System will work normally after installation with the open source drivers, but as soon as i install the Nvidia drivers from RPM Fusion the blackscreen with cursor is back. I cannot find a solution to this problem so i would be thankful for any tip in the right direction.

The issue is not present in the Fedora Gnome version and Kubuntu does also work (Nvidia driver installed from driver-manager) so it has to be a problem of the KDE Spin.

I first experienced this issue in Fedora 36 (did not try versions before) and it is still there in Fedora 37.

Similar issues as mine are reported but they are mostly just about the installer.

My guess is that it is the same issue I ran into (and found a good work around for) in this thread:

The work around was to put something in /etc/sddm/Xsetup to delay enough that sddm-greeter was no longer starting before X was ready. (I used an xrandr command. I think xrandr stalls rather than failing if it starts a moment before X is ready).

If it isn’t that, for further diagnosis, did you try ctrl-alt-F3?
If that works, do you know the basics of looking around using non-GUI tools to find out what went wrong?

To make sure you haven’t mislead us, you do mean black screen before the gui login, right? If you get past the gui login, then have the symptoms you describe, that implies wayland isn’t compatible with your nvidia driver (a common problem). If you have some good reason to use that nvidia driver then you need to not use wayland.

Hey, thanks for your reply, but this workaround does not work in both of my cases, i just used plain ‘xrandr’ command without any arguments (just logs available resolutions) and the same blackscreen happened.

Yea i know how to use linux without gui, but i have not enough knowledge to find / solve such problems. If i run startx x11 starts and works as expected.

And yes i mean that the blackscreen with the cursor is happening before login.

I’m far from an expert myself. Something I should have tried much earlier in my own diagnosing process (before I understood that sddm-greeter was segfaulting, and long before I posted a question about it):
dmesg | grep -i error

The explanation for your problem is likely somewhere in the output of dmesg, but there is a LOT of output, and I have no idea how you find real failures among all that. But the word “error” doesn’t show up too many times, and the problem might be one of those.

I used ps -ef | grep… to find out what parts of X and/or sddm were running after the failure to display the login screen. With that and a lot of effort, I figured out my failure was in sddm-greeter before I found that the more direct way.

I also check the time/date of the file /var/log/Xorg.0.log to verify that is was created during the failure that I’m investigating, then I try to find some insight in its contents. It is another giant log filled with mostly incomprehensible stuff. But sometimes its view of the problem puts you on track to the solution (for my recent sddm and nvidia/Wayland problems that log was just a frustrating waste of time. But for diagnosing similar problems longer ago, it has helped).

If the mouse cursor was working, then x11 was already running (I still think sddm had failed but x11 was working). I just tested and apparently you can start another instance anyway.

What does “works as expected” mean? Does that mean the login screen comes up and works the way it should have automatically on startup? That would imply something was needed and not ready yet, when the automatic attempt to start sddm happened (similar to, if not the same as the problem I had).

Hey, i checked the dmesg log for errors on my pc but there are no errors
On my laptop i get a complete blackscreen on ctrl-alt-F3 (did not happen before last update).

I also found out it is not consistent on the PC, every 4th boot or so i will get a complete blackscreen instead of blackscreen with working cursor.

With “x11 works as expected” i mean that when i run startx from an logged in terminal i will be directly logged into the working x session, if i logout i am back in the terminal.

Sadly i have not enough time to mess with this as it is different on both of my machines i would need to do the stuff twice.

As this is clearly a bug which is shipped by Fedora KDE which happens quite often on different systems (lot of results when i search for stuff like this) i will open a bug.

Thanks a lot