Black screen and cursor after trying to log out of an account on KDE x11

Hello, friends. There is a problem that I could not solve in two days. I recently installed Fedora 40 KDE plasma and akmod-nvidia-470xx drivers (due to the fact that the GT740 graphics card does not support newer drivers), and then changed wayland to x11 in order to use the graphics card “normally”. After that, there was a problem of not being able to exit/reboot/shutdown from the graphical interface (that is, using the graphical buttons), all applications are closed and in the end only a black screen and cursor remain. However, I found out from the tests that if you do not “log out”, but “change the user”, log in to another user, then the buttons work as usual, and it no longer matters which of the users to use to reboot / shutdown. I also noticed that using qdbus org.kde.ksmserver /KSMServer closeSession causes the same “black screen” effect. I tried various methods of configuring the configuration and the forum, but eventually ran out of strength… If you have any ideas what might be and what additional information should be provided, I will be very grateful.

Have you configured sddm(?) to use x11 as well?

Thanks for the reply… Yes, I tried to reconfigure the /etc/sddm.conf file. I changed the default server from wayland to x11. I also tried the “tips” from here: Display manager - ArchWiki (I know we don’t have arch…)

It’s a known bug and I believe they are working on it. If you are getting a black screen with visible mouse cursor when trying to shutdown, reboot or logout of x11 it is due to the package: plasma-workspace-x11-6.0.5.1-1.fc40. The solution is to downgrade to plasma-workspace-x11-6.0.3-1.fc40.x86_64.rpm.

Thanks!,
Dave

1 Like

Yes, it is, and you are right.

Thank`s, Varion!