[SOLVED] No boot with 6.4.7 kernel, everything is fine with 6.2.9. I'm stuck!

This is the output of: grep UUID *.conf

acbd614e6b164ffbb6b23f58e21d9a6e-6.2.9-300.fc38.x86_64.conf:options root=UUID=185b6dfa-957d-4930-b72e-75ebbc2a8623 ro rootflags=subvol=@ rd.luks.uuid=luks-19c84a4d-4853-4cc5-9e68-b5fe701cef7b rhgb quiet 
acbd614e6b164ffbb6b23f58e21d9a6e-6.4.7-200.fc38.x86_64.conf:options root=UUID=185b6dfa-957d-4930-b72e-75ebbc2a8623 ro rootflags=subvol=@ rd.luks.uuid=luks-19c84a4d-4853-4cc5-9e68-b5fe701cef7b rhgb quiet

and this is the result of lsblk --fs

zram0                                                                                                                                     [SWAP]
├─nvme0n1p1                                   vfat        FAT32                       ABA2-380E                             581,4M     3% /boot/efi
├─nvme0n1p2                                   ext4        1.0                         a24ff4af-2e46-4d9e-b220-3832b77aa06f    661M    25% /boot
└─nvme0n1p3                                   crypto_LUKS 2                           19c84a4d-4853-4cc5-9e68-b5fe701cef7b                
  └─luks-19c84a4d-4853-4cc5-9e68-b5fe701cef7b btrfs             fedora_localhost-live 185b6dfa-957d-4930-b72e-75ebbc2a8623  930,3G     2% /home

I’ve redownloaded Fedora ISO, changed the pen drive, formatted the laptop, and reinstalled Fedora.
Same issue.

New kernel version brought new driver and/or new config which is in the conflict of your HW. What are your major HW components - CPU, GPU, storage, MB, lan, WIFI ?

P.S.: https://bugzilla.redhat.com/show_bug.cgi?id=2212012

Was having the same problem. After removing rd.driver.pre=vfio-pci it worked again.

Get into boot menu, select entry with updated kernel version, hit ‘e’ in order to enter edit mode. At the end of end of kernel param line remove the ‘rd.driver.pre=vfio-pci’. Then boot it. If it boots, make change to kernel line permanent by removing the parameter from the GRUB_CMDLINE_LINUX= line in the /etc/default/grub config or using grubby. Then update grub to make change persistent. This workaround has to be reversed once the issue is fixed in kernel.

I have a laptop with brand-new hardware.
So, if, like the noob I am,
I remove the 6.4.7 kernel and avoid updating it, and can I stay with the 6.2.9 kernel?

No, because the kernel will update if I want to install the Nvidia driver.
It’s a mess.

And the old laptop is laughing at the new one.

Apologies, but you have to be more specific than that.

Is there a command or something to put all info together?

There is no magic command. Your problem seams a “popular one”. That thread contains some suggestions , please try what is most relevant in your case. As you did not share your HW details, there is nothing else I can help you with, apologies.

The problem is I’m upset because I waited a long time and … I’m stuck.
I’ve generated a file with ALL the specifications for my laptop.
I searched on Google, and I got something, I think.
My laptop specifications

Apparently your post on pastebin was not made public. I cannot read it.
If you were to log in with the 6.2.9 kernel then run inxi -Fzxx and post that output here we could see the hardware and configs, including drivers, so we might have some idea of what is happening.

If you have an nvidia GPU then this might be related to an earlier noted problem where the password entry to unlock the disk was not displayed – It could, however, be entered blindly and still unlock the disk and continue.

That problem seemed to be related to NOT having the nvidia drivers installed (nouveau drivers in use), and once the nvidia drivers were installed the problem disappeared.

Just for further info,
Installing akmod-nvidia can be done, and yes it does install the latest kernel and the drivers for that kernel.
Once installed the user could boot to the 6.2.9 kernel then use the command
akmods --kernels $(uname -r) --force to build the modules for the running 6.2.9 kernel. Once done, a reboot to the same kernel should load the drivers as long as secure boot is disabled.

Hello @computersavvy ,
I’ve checked it in anonymous mode in my browser, and the link to pastebin is working.

I’ve not installed the Nvidia driver at all.

  Kernel: 6.2.9-300.fc38.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.39-9.fc38 Desktop: GNOME v: 44.3 tk: GTK v: 3.24.38 wm: gnome-shell
    dm: GDM Distro: Fedora release 38 (Thirty Eight)
  Type: Laptop System: PCSpecialist product: Ionico 16 v: N/A
    serial: <superuser required> Chassis: No Enclosure type: 10
    serial: <superuser required>
  Mobo: CLEVO model: PE6xRNx serial: <superuser required> UEFI: INSYDE
    v: 1.07.05TPCS3 date: 04/13/2023
  ID-1: BAT0 charge: 74.4 Wh (100.0%) condition: 74.4/70.8 Wh (105.0%)
    volts: 17.5 min: 15.4 model: Notebook BAT serial: <filter> status: full
  Info: 14-core (6-mt/8-st) model: 13th Gen Intel Core i9-13900H bits: 64
    type: MST AMCP arch: Raptor Lake rev: 2 cache: L1: 1.2 MiB L2: 11.5 MiB
    L3: 24 MiB
  Speed (MHz): avg: 2341 high: 3000 min/max: 400/5200:5400:4100 cores:
    1: 3000 2: 3000 3: 800 4: 3000 5: 940 6: 3000 7: 830 8: 3000 9: 832 10: 3000
    11: 494 12: 3000 13: 3000 14: 3000 15: 930 16: 3000 17: 3000 18: 3000
    19: 3000 20: 3000 bogomips: 119807
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel Raptor Lake-P [UHD Graphics] vendor: CLEVO/KAPOK
    driver: i915 v: kernel arch: Gen-13 ports: active: eDP-1
    empty: DP-1, DP-2, DP-3, DP-4 bus-ID: 00:02.0 chip-ID: 8086:a720
  Device-2: NVIDIA AD106M [GeForce RTX 4070 Max-Q / Mobile]
    vendor: CLEVO/KAPOK driver: N/A arch: Lovelace pcie: speed: 16 GT/s lanes: 8
    bus-ID: 01:00.0 chip-ID: 10de:2860
  Device-3: Chicony USB2.0 Camera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 bus-ID: 3-8:3 chip-ID: 04f2:b7c3
  Display: wayland server: X.org v: 1.20.14 with: Xwayland v: 22.1.9
    compositor: gnome-shell driver: gpu: i915 display-ID: 0
  Monitor-1: eDP-1 model: BOE Display 0x0af0 res: 2560x1600 dpi: 189
    diag: 406mm (16")
  API: OpenGL v: 4.6 Mesa 23.1.5 renderer: Mesa Intel Graphics (RPL-P)
    direct-render: Yes
  Device-1: Intel vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel
    bus-ID: 00:1f.3 chip-ID: 8086:51ca
  Device-2: NVIDIA driver: snd_hda_intel v: kernel pcie: speed: 16 GT/s
    lanes: 8 bus-ID: 01:00.1 chip-ID: 10de:22bd
  API: ALSA v: k6.2.9-300.fc38.x86_64 status: kernel-api
  Server-1: PipeWire v: 0.3.77 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
  Device-1: Intel driver: iwlwifi v: kernel port: N/A bus-ID: 00:14.3
    chip-ID: 8086:51f1
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Realtek RTL8125 2.5GbE vendor: CLEVO/KAPOK driver: r8169
    v: kernel pcie: speed: 5 GT/s lanes: 1 port: 3000 bus-ID: 2f:00.0
    chip-ID: 10ec:8125
  IF: enp47s0 state: down mac: <filter>
  Device-1: Intel driver: btusb v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s
    lanes: 1 bus-ID: 3-10:5 chip-ID: 8087:0033
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 982.69 GiB used: 22.03 GiB (2.2%)
  ID-1: /dev/nvme0n1 vendor: solidgm model: SSDPFKNU010TZ size: 953.87 GiB
    speed: 63.2 Gb/s lanes: 4 serial: <filter> temp: 30.9 C
  ID-2: /dev/sda vendor: Kingston model: DataTraveler 3.0 size: 28.82 GiB
    type: USB rev: 3.2 spd: 5 Gb/s lanes: 1 serial: <filter>
  ID-1: / size: 952.26 GiB used: 21.83 GiB (2.3%) fs: btrfs dev: /dev/dm-0
    mapped: luks-19c84a4d-4853-4cc5-9e68-b5fe701cef7b
  ID-2: /boot size: 973.4 MiB used: 184.5 MiB (19.0%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 17.4 MiB (2.9%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 952.26 GiB used: 21.83 GiB (2.3%) fs: btrfs
    dev: /dev/dm-0 mapped: luks-19c84a4d-4853-4cc5-9e68-b5fe701cef7b
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 49.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 444 Uptime: 23m Memory: available: 31.05 GiB
  used: 4.89 GiB (15.7%) Init: systemd v: 253 target: graphical (5)
  default: graphical Compilers: N/A Packages: pm: rpm pkgs: N/A
  note: see --rpm pm: flatpak pkgs: 48 Shell: Bash v: 5.2.15
  running-in: gnome-terminal inxi: 3.3.27

It didn’t work for me as well but it was OK after page refresh.

Here you have a comment from another thread:

In your case the nvidia 4070 gpu has no driver loaded at all.

That is a very new gpu and likely not yet supported by nouveau. I suspect that if you can get the nvidia drivers loaded the problem may disappear.

Install the drivers by first enabling the 3rd party repos in gnome software, then from the command line first use dnf list installed '*nvidia*' to confirm the nvidia-gpu-firmware package (and no other nvidia packages) is properly installed. If the system shows that package as any version other than the one below then upgrade that package before continuing.

# dnf list installed nvidia-gpu-firmware
Installed Packages
nvidia-gpu-firmware.noarch                                         20230625-151.fc38                   @updates

Then install the drivers with dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda to install the drivers and any necessary supporting packages.
Finally wait at least 5 minutes after that install completes then reboot and see if it will properly boot with the drivers loaded (disable secure boot if not already done during this boot)

I installed Nvidia drivers.
I got this:

akmod-nvidia.x86_64                                                                                                                                       3:535.86.05-1.fc38                                                                                                                  @rpmfusion-nonfree-nvidia-driver
kmod-nvidia-6.4.7-200.fc38.x86_64.x86_64                                                                                                                  3:535.86.05-1.fc38                                                                                                                  @@commandline                   
nvidia-gpu-firmware.noarch                                                                                                                                20230625-151.fc38                                                                                                                   @updates                        
nvidia-persistenced.x86_64                                                                                                                                3:535.86.05-1.fc38                                                                                                                  @rpmfusion-nonfree-nvidia-driver
nvidia-settings.x86_64                                                                                                                                    3:535.86.05-1.fc38                                                                                                                  @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia.x86_64                                                                                                                                3:535.86.05-1.fc38                                                                                                                  @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda.x86_64                                                                                                                           3:535.86.05-1.fc38                                                                                                                  @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.x86_64                                                                                                                      3:535.86.05-1.fc38                                                                                                                  @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-kmodsrc.x86_64                                                                                                                        3:535.86.05-1.fc38                                                                                                                  @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.x86_64                                                                                                                           3:535.86.05-1.fc38                                                                                                                  @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-power.x86_64                                                                                                                          3:535.86.05-1.fc38                                                                                                                  @rpmfusion-nonfree-nvidia-driver

I waited, then rebooted.
Same issue.
But I’m sure that ONCE I booted into 6.4.7 because I messed up at boot with some entry at grub.

These are the items in Grub:

args="ro rootflags=subvol=@ rd.luks.uuid=luks-19c84a4d-4853-4cc5-9e68-b5fe701cef7b rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau"
title="Fedora Linux (6.4.7-200.fc38.x86_64) 38 (Workstation Edition)"
args="ro rootflags=subvol=@ rd.luks.uuid=luks-19c84a4d-4853-4cc5-9e68-b5fe701cef7b rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau"
title="Fedora Linux (6.2.9-300.fc38.x86_64) 38 (Workstation Edition)"
args="ro rootflags=subvol=@ rd.luks.uuid=luks-19c84a4d-4853-4cc5-9e68-b5fe701cef7b rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau"
title="Fedora Linux (0-rescue-acbd614e6b164ffbb6b23f58e21d9a6e) 38 (Workstation Edition)"

It worked.
At least, I’m running on Nvidia, even with the older kernel. Thanks!

I must understand if I’m doing something wrong with the newest kernel.
Now, that I’m with 6.2.9, what can I do to PURGE kernel 6.4.7 and reinstall it?

I just noticed I have NO SOUND!

Lets attack one problem at a time so we know what is happening and do not have interactions that might be hard to resolve.

To remove the 6.4.7 kernel and related packages the command you probably want would be sudo dnf remove kernel*6.4.7* --noautoremove and look at the recommended list of packages before proceeding. That should not remove a large number of packages, and will not remove anything that is required for the installed and booted kernel or other packages. It should be only the kernel packages and the related kernel modules, such as kmod-nvidia-6.4.7…

I gave up.

On my old Asus, I see it is not so slow: Fedora gives it full of speed and commodities I can’t even imagine with Windows.

So, try to picture me with a new toy that can’t works as expected.
This early morning, I gave up.

I bought this new laptop, and I was so happy because, in my mind, I could use it in full.

Now, I’ve installed Windows, and it works well.

I’ve been reading about many people with issues with 6.4.x kernel, even on Raspberry.

But I’m tempted to try again with Fedora. To install the bare minimum and see what happens.

I have a full Macrium backup of the new PC in the eventuality.
Do you think I’m crazy enough to do that again?

In the end, I’m running Fedora on the 6.4.7 kernel.
After looking at this page and thanks to this page,
for now, I used:

sudo grubby --update-kernel=ALL --args="tpm_tis.interrupts=0"

to temporarily fix the boot issue.

I’ll wait better time to remove that parameter from Grub; it works for now.

Thanks, people!