Fedora doesn’t boot anymore

I have my Surface Pro (5th gen) dual booting Windows 10 and Fedora 38 since months and everything used to run smoothly.
For a couple of days I had to work with Windows and when I tried to start Fedora, nothing happened.

Whatever kernel I choose, after grub menu I can only see a minus sign at the top left corner with the system completely frozen. I can only long press the power button to power off the machine.

I’ve checked into windows and I found a “Surface Firmware update on 17 October” but after a quick search I discovered that firmware updates can’t be reverted or downgraded and actually I don’t know if this upgrade could had break the Fedora bootloader or something else.

According to what I found in the web I have already made these attempts:
I tried to change/add some boot params but nothing.
I tried to boot Fedora in rescue mode but nothing.
I tried to leave my Surface on that after-grub-black-screen a whole night but nothing.
I tried to chroot my system trough a Live USB environment but I did not succeed (I’m not very expert).

The PC doesn’t boot with F37 and F38 Live.
I had to write a Fedora 36 Workstation Live USB in order to boot successfully my Surface.

Now I’m able to see the disk’s partitions but I don’t know how to proceed in order to fix the system and get it back to boot normally.

Could you please help me with that?

Thank you all!

Surface firmware update versus linux was reported for a beta release months ago. Looks like someone with a Surface system will have to work out a fix without the aid of Microsoft. There is more information on Matrix.

1 Like