Fedora 38 fails to boot


I wanted to try Fedora 38, so I downloaded the image and used the Fedora image writer to create a bootable flash drive with the image. When the computer boots from the flash drive, it gets stuck after passing the media integrity check. Apparently, there are some troubles somehow with the CPU (AMD Ryzen 9 9500X, I will add a screen shot, when I am at home). I had Fedora 38 live running with my old CPU on the same mainboard (MSI Gaming Edge Wifi) without a problem some months ago. I had to replace my old graphics card (now a Radeon 7900 XT) and my power supply. Is it possible that this combination somehow prevents the live system from booting? Windows is starting without a problem, also the Opensuse tumbleweed installer is starting. Are there any boot or BIOs options I could try?

It just keeps hanging here:

Does it eventually boot if you let it sit for a few minutes?

No, it just hangs there for a some minutes and the system is rebooting. Is there maybe some alternative start up flag or attribute I can set?

I now made a test with an Opensuses installation (tumbleweed) and the result is the same: The installation process is executed without a problem, but as soon as the system should start, the same error situation occurs as on every distribution I tested :
*) „hard lock on cpu xyz“ (not always the same cpu number)
*) cannot find toc-block
*) xHCI host controller assume dead

As I do not have any errors or stability issues with Windows, I do not really want to change any components, despite the fact, that with the old cpu and graphics card there was no problem starting Fedora, so I assume the problem is related to one of those or both components. I will wait on Fedora 39 and give it another try.

This may also be related to a firmware issue. Have you updated the laptop firmware to the latest available?


it’s not a Laptop, it’s a PC. Yes I have flashed my mainboard with the latest firmware available on the MSI website. Fedora 39 beta does generates those errors but does not start either.

Fedora 39 is doing at least a little bit more …

When booting from the install iso it should give 3 initial boot options. One of those should be troubleshooting, under which you could select the basic graphics mode. This sometimes is necessary with newer graphics cards during the installation. Your Radeon 7900 XT qualifies as a newer card (released late 2022). I cannot find info on the Ryzen 9 9500X. Did you by chance mean the 5900X?

Of course 9 5900X :man_facepalming: I did not find any general problems with Linux and this processor, so I suppose it‘s maybe a unfortunate combination with my mainboard. I tried the basic graphics mode too, this is where the screenshots are from.

Is that mobo the B550 or the X570 chipset version?
Though similar they do have different specs.

It’s a MSI Gaming Edge Wifi X570.

Strange. That board would seem it should support that processor if it has up to date firmware. However the board info only shows support for 2nd & 3rd gen Ryzen. With research it seems the 5900X may be a 4th gen processor. Thus updated firmware seems a must, and it should show support for the 4th gen Ryzen.

I must also ask about the RAM. Is it DDR4? and what speed? Different RAM is supported depending upon the processor installed.


I use 4 Corsair DDR4 modules (for the exact specs I would have to check). As I mentioned in the beginning, I have Windows running without any problem, stability issues or what so ever. With the former processor and graphics card on the same mainboard, I had no problem with any live Linux distribution.

This is the module I use: CORSAIR Vengeance LPX DIMM Kit 16GB, DDR4-3600,CL18-22-22-42


I was able to narrow the problem down to the sound card. I recently switched to a Soundblaster AE7, which is for some reason recognized as Intel sound card. Is there an option to disable/override this detection for the live system?

Reddit “official” SoundBlaster Creative AE7 Support is a few years old but indicates a lack of interest from Creative. Linux Hardware can help find a card with good linux support.

Well, as the sound card is just 2 months old, I do not really want to go for another card just to try out an operating system. Is there no way to prevent a detection of it? The other option would be to remove the card, every time I would boot to Linux, which is also not really what I want from a dual boot system.

While that is understandable, simply removing the card and verifying that the system boots and operates properly without it would confirm whether the cause is or is not the sound card.

Once that is confirmed then you would be able to make a decision as to the path forward.

No, if the card is connected then the system configures it when detected, so there is no way to prevent detection. It may be possible to prevent configuring it but devices that do not have an active driver loaded may cause other issues.

For hardware that is installed it either does or does not work which usually points to the fact it does or does not have suitable drivers.

An unsupported device may or may not cause problems.

It is up to you how far you want to test, and then what actions to take in moving forward.

Three years ago:

We can only guess whether this has improved:
Creative does not provide an official (thus does not directly support) Linux driver, however, there are development efforts in the ALSA community to support SoundCore 3D based Creative sound cards. Users may wish to contact ALSA community for the drivers.

Try removing the card and booting as per @computersavvy 's suggestion. That would help to isolate the issue.

1 Like