Fedora 37 Arm Image won't work on RPi 4


I’ve downloaded the “Fedora-Workstation-Live-aarch64-37-1.7.iso” image and checked the image > it’s ok.
I tried to burn it with Balena Etcher. When loading the image i got a “partition missing” error

. I can flash the image but i get the “unable to read partition fat” error message (see below).

I tried with the Fedora Media Writer : it writes the image but when booting on the Pi, i got an “unable to read partition fat” error :

Is the F37 Arm Image broken or do i miss something ?

I have a 16Gb Micro SD working (i can reinstall raspbian on it without any trouble).

Try downloading the raw.xz image and writing it to the sd card using fedora’s arm-image-installer.

I never have a problem using the raw image, but can when I use the iso image.

Hi Jeff, thx for your Help.
I’ve tried f36 in raw.xz and it takes hours to boot…(i’ve tried on two different sd card, as i thought it might be damaged, but no…) I’ve given up. I’ve switched to Ubuntu.

It’s really too bad. I love my fedora on my Notebook, but clearly le RPi is not the priority (and i can understand it)… But i cannot spend hours in building a working Pi… :slight_smile:

Thanks anyway !

Whatever distro works for you is good.
But why F36? Support for RPi4 has been improved starting from Fedora Linux 37

1 Like

Sorry for digging up an oldish post, just saw this under my related topic, and I know the problem.
The Raspberry Pi 4 (and anything else older) is not “SBBR compliant” as they say. In effect, it can’t just boot a UEFI USB image (the AArch64 ISO).
However it can load U-Boot (used by Fedora aarch64 raw img) or pftf UEFI and they can boot it.