No signal after booting fedora workstation,on rasp pi 4

It finishes the booting.Then it displays no signal.
I dont know how to debug or find out what went wrong.

Hello @yewefed0ra
Could you specify which image have you used, and how have you created the SD card?

and then flash with balena desktop app

Exactly which image?
I use Fedora-Workstation-37-1.7.aarch64.raw.xz then write it to the sd card using fedoras arm-image-installer with the command sudo arm-image-installer --image=/path/to/Fedora-Workstation-37-1.7.aarch64.raw.xz --media=/dev/sdf --resizefs --target=rpi4

Note that the media is the location of the sd card being written to, and the target is the board it is to boot. This method has better results for me than using the iso image.

yeah i am using the same raw.xz unpacked then flash with the raw.
maybe I will try fedora arm-image-installer.

tried using fedora media writer still no signal.
I have no idea what went wrong.

My Raspberry Pi 4 Model B Rev 1.1 works well with Fedora-Server-37-1.7.aarch64.raw.xz. Try to remove “rhgb quiet” at booting to see more details.

# uname -r
# dmidecode |grep -i name
	Product Name: Raspberry Pi 4 Model B Rev 1.1
1 Like

The fedora media writer and the arm-image-installer are 2 totally different apps. One is for writing an iso to a usb and the other is for expanding the raw compressed (arm) image onto a device (usually an sd card, but not always) . They are not interchangeable in function.

The arm-image-installer uses the compressed image and does not need it unpacked, but exactly as downloaded.

Huh I see,I will try using arm-image-installer and see if I can get it working.

Does this mean I MUST use arm-image-installer for flashing rasp with fedora?

sorry but I have no idea how to do this.
do I need to enter tty mode when booting the rasp pi?

Not necessarily, but it was designed for that purpose and works with the compressed image exactly as it is downloaded.

For help in usage simply use arm-image-installer with no arguments (or arm-image-installer -h) and it will display the options and help info.

If you cannot see the kernel boot entry after rasp pi’s post, it mostly because you did not write the image correctly. You might want to try rewrite it.
Here is my command writing the image to flash:

#sudo arm-image-installer --image=Fedora-Server-37-1.7.aarch64.raw.xz --target=rpi4 --media=/dev/sda --resizefs --norootpass

I want to add that in my experience, before writing the image to the sd card the user must make certain all partitions on the sd card are NOT mounted. Udev tends to mount them and I have had failures in installing the image on the card when mounted. When I remember to unmount all partitions on the target card before writing it works flawlessly.

1 Like

You mean it can write but when booting/running it will have problems?
I dont know how to unmount them,they are very presistent.

$ sudo umount ‘/run/media/a/fedora_fedora’
umount: /run/media/a/fedora_fedora: target is busy.

I reflashed it but still seems to be no-signal.

Is there any chance that there are display drivers that are supported up to BOOTING ONLY?
so the display works during boot but when entering OS environment the driver is just not compatible?

I am currently using some Chin* OEM touch display.(if this info somehow helps?)

1 Like

The partitions are usually mounted at /run/media/USER/xxxxx where USER is the user name and xxxx is the name/uuid/label of the file system mounted.

That partition will NOT be busy if you plug in the usb device, run the ‘mount’ command to see where it was mounted, then do sudo umount /run/media/USER/xxxx to unmount it. It WILL be busy if you cd to the location or if you use the file manager to look at the content and leave it in that directory.

There may be one or more partitions that are auto-mounted from the device and all need to be unmounted before writing to the device with the arm-image-installer.

the booting works But the display somehow didnt work.
Using another hdmi display linked to projector worked though.

Is there a way for me to know why is it incompatible so I can prevent buying incompatible display for my fedora rasp pi.

If that is the issue then it may be either the hdmi mode used by the display or the display may not be providing the edid data used to configure the output for the Pi.

Most modern displays work, but not all.

I would suspect the display itself, especially since it seems lower quality and is a touch display so the drivers might not all be available.

hmmm in that case Do you know of any list of display that works?
or specifications that works?
I think this should be added to fedora arm pi docs to prevent such sad case from happening again.

Because without a spec I couldnt actually confirm the next display I buy will works and it be just a waste of money and time to debug. Do you happen to know where can I contribute or ping the fedora arm developers to discuss the details?

I don’t have a list of those that work.
I do have an Acer, a Dell, an LG, and a Samsung TV, all of which work when connected to the Pi using HDMI.

i see huge thanks maybe the support is limited to pc display or tv?I will ping the team and see how it goes.