Install Fedora server 30 on Raspberry 3

I installed Fedora 30 Server on Raspberry 3.
after I plug the power cord. Fedora starts to boot after sometimes I see this message

 lan78xx_eth waiting for  PHY auto negotiation to complete 

and boot process stop.
I must press Ctrl+C on a keyboard and after that Fedora server continues it booting.
when fedora boot reaches to something like grub, I must press Enter again to boot process continue again.
I want to connect raspberry to hidden network and I need MAC address of Wlan0, when I type


I see mac address of Wlan0, and I add my mac to my router for mac filter, but after sometimes when I run


again I see different mac address for Wlan0 and I think every time mac address is changed automaticaly.
It is how odd why mac address of wlan0 change!!!
and I want to connect to a hidden network with mac filter on the router.
how I can solve this problem?
I want to use this fedora server as a server for my network. I want fedora boot without keyboard and monitor and fedora boot without problem.
I want to control my system over wifi network by SSH.
what I must do?
I think Fedora server on Raspberry 3 has some bugs.

How did you prepared the SD card?
Are you using aarch64 or armv7 image?

Uh. You are right.
While I don’t see any strange message that force me to press Ctrl+C or enter in order to boot, the MAC address keep changing at each reboot.
If I’m not wrong this issue was present some time ago (Fedora 27 or 28?) and it was solved in some kernel or firmware update (I don’t remember). Now the issue seems here again.

I use this guide to install
but I do no use xzcat because after first try it failed and Fedora can not boot.
I download Fedora30-server.raw.xz in Linux mint and extract it and right to SD.
and after that Fedora boot.
but I have those problems, I said in my first post.

After start fedora booting, I see this message

``` lan78xx_eth waiting for PHY auto negotiation to complete
Fedora booting stop and cannot continue, I must cancel this process by ctrl+c and continue boot and start using Fedora.


Fedora-Server-30-1.2.aarch64.raw.xz or Fedora-Server-armhfp-30-1.2-sda.raw.xz

And what do you mean with “I do no use xzcat”?

and I can not connect to hidden netrwork too.

I use aarch64.raw.xz.
if I use this command to write image to SD
xzcat Fedora-IMAGE-NAME.raw.xz | sudo dd status=progress bs=4M of=/dev/XXX
image of fedora write on SD, but Fedora can not boot.
So I download raw.xz and extract it by GUI app and after that write it on SD by DD command.

Strange. I tried on a Raspberry Pi 3, preparing the SD card by uncompressing the xz file then using dd as you wrote, and I’m not experiencing such boot issue.

I do not know what happen, but this problem happened for me.
What I must do about others problem?

Well, I think that you could report such issues to the Fedora ARM mailing list or #fedora-arm IRC channel on
I already reported the issue related to the MAC address changing at each reboot.

1 Like

Uh! Wow. It seems that MAC address randomization is a feature and not a bug!
And it is not related to the Raspberry Pi, but it is managed by NetworkManager.

So you can put these lines in a file called /etc/NetworkManager/conf.d/00-macrandomize.conf


And the wlan0 MAC address will be the same at each reboot.

One learns something new every day. :slight_smile:

1 Like

As as followup, and for future reference just in case some other user will incur in this issue, the discussion continued on the Fedora ARM mailing list.

The Raspberry booted just fine unplugging keyboard and mouse. (Maybe a PSU issue not providing enough power?)