Aarch64 Fedora 30 on Raspberry Pi 3B+ dracut-initqueue timeout

I’ve been trying, unsuccessfully, to get Fedora-Server-30-1.2.aarch64.raw.xz booted on my Raspberry Pi 3B+ for 2 days now.

I have downloaded the file several times, confirmed the sha256 checksum, and use “sudo arm-image-installer --image=Fedora-Server-30-1.2.aarch64.raw.xz --target=rpi3 --media=/dev/sde --resizefs” to install it to my SD card.

When I go to boot it in my pi I get to a point where it prints out and repeats…

dracut-initqueue[569]: Warning: dracut-initqueue timeout - starting timeout scripts

At this point it hangs and nothing is returned and it doesn’t boot. I have tried to boot with and without a mouse and keyboard attached, I have even removed the camera attached to the CSI interface. Nothing appears to work. If I let it go, and I mean for hours, it prints that it is going to drop me to emergency mode, but never does. (left it over night and it was still at the same point in the morning)

I have then tried to interrupt boot at the grub stage and add systemd.unit=rescue.target to the end of the kernel line to no avail. (by the way that is harder than one would expect because there is no cursor for some reason so you have to move a bit type a letter, delete it, then continue moving toward the end of the line since the end key doesn’t work)

I would really like to get Aarch64 installed and running on this Pi 3B+ since it is one of the rare 64bit distros for the pi with everything functioning correctly (at least according to the wiki page). I have had ArchArm installed on this but wasn’t happy with several missing and non-functional items.

Does anyone have a suggestion on how I can get past this point and get this booted? Or references I can use? I did a cursory search on this forum and couldn’t find anything similar but that doesn’t mean I didn’t miss anything. Any help would be greatly appreciated.


To test if my SD card and procedures work, I downloaded Fedora-Server-29-1.2.aarch64.raw.xz and put it on the same SD card. It booted correctly and I had no issues with it. So it appears there is something up with Fedora 30 on the Raspberry Pi 3b+. Though I have 29 on this now, and I may try to “update in place from 29 to 30” to see if the issue booting then presents itself, I am happy to try to get 30 on this from the start and will provide any logs/info etc for anyone else that may run into this issue.

1 Like

And did you try a different power supply?
I have a RPi 3 (not +) and Fedora works here, so I can’t be of help.
Please try the in place upgrade, and report your issue also to the Fedora ARM team: on the mailing list or on the #fedora-arm IRC channel on irc.freenode.org

Thanks, yeah this is a Adafruit 5.05v, 2.5 amp supply and has worked fine with all other distros.

The Aarch64 Fedora 29 image worked fine. I am now trying a complete upgrade in place 29 - 30 and it appears to be going well. (though I have a while to wait as it’s on 121 of 1403 packages) I’ll report back if it goes belly up after the upgrade.

I did have to manually change my baseurl in my repos though as the metalink was picking some atrociously slow mirrors to the tune of 4k/s. (manually setting them to a mirror close to me brought the average throughput to 25Mb/s)

I would like to put aarch64 Fedora 30 on another SD card however, and see if I cant’t get past that point again as I’m sure others are going to run into the same issue and I’d like to help with that. I’ll mention this on the IRC channel and see if anyone else has had similar issues. Thanks @alciregi for your reply.

The update from f29 to f30 using https://fedoramagazine.org/upgrading-fedora-29-to-fedora-30/ worked perfectly and the F30 box boots as expected. I am not sure if this is an arm-image-installer issue or something else. When I have the time I will try to make the aarch F30 SD card manually and see if that works directly to F30. I did run into this as well, unusual load in top but no identifying process consuming it. It is apparently a known issue and will not be fixed until 5.3 kernel. https://github.com/raspberrypi/linux/issues/2881

1 Like

Well, it must have been an issue with the arm-image-installer. Using the following and creating the SD card manually worked fine, directly to F30 using the aarch64 image.

xzcat Fedora-Server-30-1.2.aarch64.raw.xz | sudo dd status=progress bs=4M of=/dev/sde

Then, prior to removing it from my machine I used “sudo gparted /dev/sde” and resized the root partition. Once removed and put in the Raspberry Pi 3B+ it worked flawlessly.

1 Like

I just need to note here, the arm-image-installer royally hosed my main laptop I used it on by creating a SECOND “fedora” vg on my laptop, not on the SD card listed in the command above. How? I have no idea. It took me hours of low level pv/vg/lv work to get it removed correctly before I attempted a reboot. Honestly though, any reference to that arm-installer should be pulled ASAP until it is fixed… creating duplicate “fedora” vg’s on the host system is a recipe for disaster.