Fedora 36 GNOME 42 Touch screen not working


EDIT: Problem’s not solved, I believe this may be the issue: Wacom Pen and multitouch sensor dead after suspend

Furthermore, touchscreen seems to work on and off, despite the percentage of the wacom pen and multitouch sensor. But I can assure, this problem was not this frequent prior to recent updates.

Initial post
Before you read this, I miraculously and randomly found the solution to this problem. It even happened while I was writing this. It doesn’t make sense to me why it started working, but I can take a few guesses.

To understand my situation, please read below.

I have a Thinkpad Yoga X380. Since Fedora 35 the touchscreen and stylus was working perfectly fine. As of yesterday, installing all the latest updates on Fedora 36, my touchscreen and stylus stopped working. I’m also using Wayland.

I booted from a spare copy of AVLinux, and touchscreen worked fine; it’s 100% not a physical or hardware issue.

Either something screwy happened after installing all the latest Fedora updates, or I changed the settings somehow, but I certainly have no clue what I could have changed for this to happen. Furthermore, when looking at Settings>Power>Devices, I noticed that the Wacom pen and multitouch sensor are at 0%.

Touchscreen neither works on the Fedora log in page and desktop. So, it’s not some user setting that disabled it… I’m thinking this may be a system settings issue.

So, after booting to a USB copy of AVLinux, and seeing how touchscreen worked fine, I booted my regular system of Fedora 36 from my internal SSD, and… it WORKED! Multitouch and wacom pen worked fine on Fedora 36. I checked the settings in Power again, and it now has 100% as opposed to 0%. My guess is that the sensor was either froze, stuck, or couldn’t reset its values, and prevented me from using the touch screen.

Once again, I used this Yoga laptop yesterday, 6.5.22, and it worked fine. Today, it wouldn’t work until I tried that fix. So… maybe something to do with the package update between yesterday and today(?)

I have no clue why this solution worked, but in case there’s any folks out there that have a system where touchscreen fails to register, try booting from a USB distro!


Please try Gnome DE on xOrg

Changing DE to another DE but still running on Wayland will change nothing

Wayland is still in experimental mode and not all compagnies ( and distros ) are willing to work hard for a new graphical server not fully supported by all ( and imposed as did Microsoft for windows 8 ) and that still make a clash with some developper.

Here you can see 2 screen capture programms, 1 Screen recorder, TeamViewer … all companies ( and myself ) say please use xOrg

I’m suprised to see many Wayland users having trouble with and not using x11 instead, x11 is implemented and stil perfectly working since 35 years then before Linux exists ! :grinning:


When I use Gnome DE I always force on xOrg ( WaylandEnable=false in gdm3 )
But to be frank I’m using Cinnamon since Gnome 40 and when possible ( it has all Gnome options as on-line account,… and more options due to Cinnamon )