Touchscreen working only on live USB -- Lenovo Yoga 12

Hello everybody, I hope someone could help me.

I have a Lenovo Yoga 12 convertible laptop with Windows 10 and everything works fine (touchpad, trackpoint, touchscreen and stylus). I decided to install Linux Fedora (v.32 kernel 5.8) parallel to Windows since it looks the best distro for convertibles.

When it started from live USB the touchscreen worked fine, so I installed it onto the hard drive. When the installation was done I rebooted it and found out that it is not working.

The touchscreen device is listed in /proc/bus/input/devices as “SYNAPTICS Synaptics Touch Digitizer V04” with event handler “mouseX”, both on live and on hard-disk. The command cat /dev/input/mice works fine on live (all inputs are read) but on hard-disk the touchscreen input is missing.

Is there something I am missing?


I have the same problem on the same machine. I haven’t found have a solution so far, but I here is a bit of what I tried and found out, if that helps anyone helping us. I’ve only started getting into linux, so probably some of this is obvious and/or silly.

  1. I tried ubuntu 20.04 with Gnome first, and the same thing happened. Live Distro worked, after installation, not anymore. Switching between the default and wayland sessions did not make a difference, as far as I’m aware.
  2. I found a recent bug report on a forum, someone had the same error on an different device. (Surface3, I think, I can add a link once I find it again). They suggested closing and opening the lid as a workaround. This worked for me, most of the time. But it’s not really practicable, so…
  3. Next I installed the xfce DE on ubuntu and the touch screen did work, but with limited functionality. Not too surprising.
  4. Then I tried Fedora because I thought, Gnome is good with touchscreens and maybe with another Distro I’ll be luckier. Not the case.
  5. Then I tried Manjaro with xfce. Not relevant for this question, but basically the screen responded, support was poor though and I did come some way but not a long way in making it work comfortably.
  6. So I went back to Fedora, which is where I am now. Closing the lid seems not to do the trick here, but sometimes after having the yoga suspended and logging back in, the touchscreen is suddenly awake and fully functioning.

Thanks for any tips! (And sorry for not knowing what may be relavant and what not)