TouchScreen is not working properly

Hi. I am using Laptop with touchscreen and it worked just fine after install, however 2 days later it stopped working properly. Now i can only emulate click in touchscreen. I can’t swipe, zoom in or out, everything works as a click. Is there a way to fix that? I realize that i’m not asking this question properly, but i don’t know what kind of information i should provide and how to get it.

To find this out a good start you find here >> #start-here

As mentioned in the other topic, please use search engines and search fields here in the forum, docs and wiki pages.

touch screen problem with laptop name/model fedora linux >> search engine string (replace name/model with your system name/model)

1 Like

Is this Gnome or a different desktop environment?

Hi. Thank you for your time.
I did some research before asking the question, however could not find a solution.
I noticed tough, that people were posting the output of the following command

inxi -Fxxxrz

  Kernel: 5.17.5-300.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-24.fc36 Desktop: GNOME v: 42.0 tk: GTK v: 3.24.31 wm: gnome-shell
    dm: GDM v: 42.0 Distro: Fedora release 36 (Thirty Six)
  Type: Convertible System: HP product: HP ENVY x360 Convertible 15-cp0xxx
    v: N/A serial: <superuser required> Chassis: type: 31
    serial: <superuser required>
  Mobo: HP model: 8497 v: 92.48 serial: <superuser required> UEFI: AMI
    v: F.49 date: 05/24/2021
  ID-1: BAT0 charge: 36.2 Wh (100.0%) condition: 36.2/36.2 Wh (100.0%)
    volts: 13.2 min: 11.6 model: 333-54-35-A LK03052XL type: Li-ion
    serial: <filter> status: charging
  Device-1: hid-0018:04F3:2650.0001-battery model: ELAN0732:00 04F3:2650
    serial: N/A charge: N/A status: N/A
  Info: quad core model: AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx
    bits: 64 type: MT MCP smt: enabled arch: Zen rev: 0 cache: L1: 384 KiB
    L2: 2 MiB L3: 4 MiB
  Speed (MHz): avg: 1407 high: 1597 min/max: 1600/2000 boost: enabled
    cores: 1: 1353 2: 1347 3: 1276 4: 1346 5: 1347 6: 1397 7: 1596 8: 1597
    bogomips: 31938
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Mobile Series]
    vendor: Hewlett-Packard driver: amdgpu v: kernel pcie: speed: 8 GT/s
    lanes: 16 ports: active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 03:00.0
    chip-ID: 1002:15dd class-ID: 0300
  Device-2: Lite-On HP Wide Vision FHD Camera type: USB driver: uvcvideo
    bus-ID: 3-1:2 chip-ID: 04ca:7086 class-ID: 0e02 serial: <filter>
  Display: wayland server: v: 1.20.14 with: Xwayland v: 22.1.1
    compositor: gnome-shell driver: gpu: amdgpu display-ID: 0
  Monitor-1: eDP-1 model: AU Optronics 0x22ed res: 1920x1080 dpi: 142
    size: 344x193mm (13.54x7.6") diag: 394mm (15.5") modes: max: 1920x1080
    min: 640x480
  OpenGL: renderer: AMD Radeon Vega 8 Graphics (raven LLVM 14.0.0 DRM 3.44
    v: 4.6 Mesa 22.0.2 direct render: Yes
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 16
    bus-ID: 03:00.1 chip-ID: 1002:15de class-ID: 0403
  Device-2: AMD Family 17h/19h HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 16
    bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.17.5-300.fc36.x86_64 running: yes
  Sound Server-2: PipeWire v: 0.3.51 running: yes
  Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter
    vendor: Hewlett-Packard driver: rtw_8822be v: N/A pcie: speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 02:00.0 chip-ID: 10ec:b822 class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  Device-2: ASIX AX88179 Gigabit Ethernet type: USB driver: ax88179_178a
    bus-ID: 2-1.1:9 chip-ID: 0b95:1790 class-ID: ff00 serial: <filter>
  IF: enp3s0f3u1u1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: Realtek Bluetooth 4.2 Adapter type: USB driver: btusb v: 0.8
    bus-ID: 3-2:3 chip-ID: 0bda:b00b class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Local Storage: total: 931.51 GiB used: 21.42 GiB (2.3%)
  ID-1: /dev/sda vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB
    speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 1J scheme: GPT
  ID-1: / size: 930.01 GiB used: 21.19 GiB (2.3%) fs: btrfs dev: /dev/sda3
  ID-2: /boot size: 973.4 MiB used: 214.5 MiB (22.0%) fs: ext4
    dev: /dev/sda2
  ID-3: /boot/efi size: 511 MiB used: 20.7 MiB (4.0%) fs: vfat
    dev: /dev/sda1
  ID-4: /home size: 930.01 GiB used: 21.19 GiB (2.3%) fs: btrfs
    dev: /dev/sda3
  ID-1: swap-1 type: zram size: 6.73 GiB used: 13.8 MiB (0.2%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 56.0 C mobo: 40.0 C gpu: amdgpu temp: 59.0 C
  Fan Speeds (RPM): N/A
  Packages: note: see --pkg flatpak: 8
  No active dnf repos in: /etc/dnf/dnf.conf
  Active yum repos in: /etc/yum.repos.d/
    1: ~$releasever-$basearch/
  Active yum repos in: /etc/yum.repos.d/_copr_phracek-PyCharm.repo
    1: phracek-PyCharm ~$releasever-$basearch/
  Active yum repos in: /etc/yum.repos.d/fedora-cisco-openh264.repo
    1: fedora-cisco-openh264 ~$releasever&arch=$basearch
  Active yum repos in: /etc/yum.repos.d/fedora-modular.repo
    1: fedora-modular ~$releasever&arch=$basearch
  Active yum repos in: /etc/yum.repos.d/fedora-updates-modular.repo
    1: updates-modular ~$releasever&arch=$basearch
  No active yum repos in: /etc/yum.repos.d/fedora-updates-testing-modular.repo
  No active yum repos in: /etc/yum.repos.d/fedora-updates-testing.repo
  Active yum repos in: /etc/yum.repos.d/fedora-updates.repo
    1: updates ~$releasever&arch=$basearch
  Active yum repos in: /etc/yum.repos.d/fedora.repo
    1: fedora ~$releasever&arch=$basearch
  Active yum repos in: /etc/yum.repos.d/google-chrome.repo
    1: google-chrome ~
  No active yum repos in: /etc/yum.repos.d/rpmfusion-free-updates-testing.repo
  Active yum repos in: /etc/yum.repos.d/rpmfusion-free-updates.repo
    1: rpmfusion-free-updates ~$releasever&arch=$basearch
  Active yum repos in: /etc/yum.repos.d/rpmfusion-free.repo
    1: rpmfusion-free ~$releasever&arch=$basearch
  Active yum repos in: /etc/yum.repos.d/rpmfusion-nonfree-nvidia-driver.repo
    1: rpmfusion-nonfree-nvidia-driver ~$releasever&arch=$basearch
  Active yum repos in: /etc/yum.repos.d/rpmfusion-nonfree-steam.repo
    1: rpmfusion-nonfree-steam ~$releasever&arch=$basearch
  No active yum repos in: /etc/yum.repos.d/rpmfusion-nonfree-updates-testing.repo
  Active yum repos in: /etc/yum.repos.d/rpmfusion-nonfree-updates.repo
    1: rpmfusion-nonfree-updates ~$releasever&arch=$basearch
  Active yum repos in: /etc/yum.repos.d/rpmfusion-nonfree.repo
    1: rpmfusion-nonfree ~$releasever&arch=$basearch
  Active yum repos in: /etc/yum.repos.d/sublime-text.repo
    1: sublime-text ~
  Active yum repos in: /etc/yum.repos.d/vscode.repo
    1: code ~
  Processes: 392 Uptime: 17h 15m wakeups: 8 Memory: 6.73 GiB
  used: 3.19 GiB (47.4%) Init: systemd v: 250 runlevel: 5
  target: Compilers: gcc: 12.0.1 Shell: Bash v: 5.1.16
  running-in: gnome-terminal inxi: 3.3.14

Hi, thank you for your reply.
I’m running Gnome 42.1/Wayland with Fedora 36

1 Like

I’m thinking this might be hardware specific. My ThinkPad has a touch screen and I can use the Gnome gestures with it. As far as pinch-to-zoom goes, that seems to be dependent on if the application itself supports it. For example, pinch to zoom works perfect for me with Firefox but not Slack, though I can still scroll in Slack with a swipe, where in Hexchat, the same gesture selects text.

I don’t think that it is it, because it used to work normal after installation. Stopped working properly after day or two.

I used Asus vivobook s500ca since Fedora 34 Workstation and now upgraded to fedora 35 with the lastest kernel, waiting upgrade to Fedora Linux 36 stable, touchscreen is working normally and perfectly, 2 finger for pinch to zoom in or zoom out, 3 fingers for swipe workspace, 1 finger to scroll vertical and horizontal, for click and for double klik. Maybe your hardware is broken, check in usb live linux system or if you dual boot check it on windows to make sure is working properly or not?

Hi, i installed Zorin OS to that laptop, touchscreen worked fine out of the box, so i decided to stick with it. However i will keep using Fedora on my main laptop.