[Fedora 35 Silverblue] No flatpak icons

So I’ve gotten myself up and running quite quickly with fedora 35 silverblue and everything is well working so far, but any apps that I install through flathub just have the blue diamond icon.

I googled around for this but wasn’t able to find anything specific? Any ideas?

I’m not against a fresh install to see if I maybe did something wrong but I’m at least attempting to figure out what went wrong here in case it helps someone else.

Things I tried:

  1. Updating
  2. Logging off and logging in
  3. Rebooting a few times

Example: https://i.imgur.com/D3yYjqw.png

Hello @jmilne22 ,
Welcome to the :fedora: discussion area!
First off, No! don’t re-install yet. It is likely just some updates need applying. So on Silverblue, because it is a hybrid atomic OS and package layering system, with most applications coming in Flatpak versions, this can get rather complex for the Gnome Software app. So, you can wait for it to catch up and go the GUI route, or open a terminal and issue a couple of commands to complete the update yourself.
In a terminal, enter rpm-ostree update it will run (providing it isn’t already busy) and when done, if anything needs updating on the system it will inform you and you would do a systemctl reboot to reboot into the updated commit.
Now you can update the flatpaks, in a terminal again, using the command sudo flatpak update and do them if any are found. If you still have no proper icons after all this you can try sudo flatpak repair which will repair your flatpak installation entirely.

@jakfrost So you’ll think I’m crazy but I did the following:

  1. rpm-ostree update and there were no updates
  2. Did a systemctl reboot anyways.
  3. Did a flatpak repair (sudo didn’t work, threw a “dbus-launch” (No such file or directory)
  4. Everything was still the same, but after I installed another flatpak from gnome-software (I picked transmission as a random one). All the icons randomly showed up, at least that’s what I think happened.

Appreciate your help.

1 Like

I have done a few Silverblue installs in the past few years, and hadnt come accross this issue before until a fresh install yesterday. No idea what caused it.

I will note I had installed about 9-ish flatpaks between Fedora’s repo, and Flathub. None of them had an icon except Headlines app (odd indeed).

But… after reading your comment I opened Gnome Software and installed Transmission (and used the default via Fedora’s Flatpak). After installing this app, all the other icons immediately appeared.

No i idea why the flatpak-repair or other things didnt fix this issue, but I assume there was something wrong with a runtime-level config that got sorted with the Transmission install. Weird!

Hi, I’m new to Fedora Silverblue and I’m having the same problem.
It seems the XDG_DATA_DIRS is correctly set, and all the icons are properly laid out inside /var/lib/flatpak/exports/share/icons, but Gnome does not seem to accept the icons (but does properly read the .desktop files).
I honestly have no idea how to debug this

Hmm, weird. I have been using Silverblue for almost a year now, and I didn’t face this issue ever on my computer. But today, I installed a fresh SB35 on a friend’s computer, and no flatpak icons there (gears or exclamation marks instead).
Those icons are shown in Flatseal, but they aren’t visible in Gnome Desktop/Activites nor Gnome Settings/Applications. I did follow all the instructions posted on this topic here (reboot, update, upgrade, reboot, update, repair, reboot) but no help. Apps are working fine, though.
I guess my friend is just unlucky.

Edit: I guess they are lucky, because the issue solved itself(?) randomly. What a weird thing though.

For what it’s worth, this issue just „magically“ fixed itself after a while. No idea why though

So I just wanted to confirm that I had this very issue in F35 SIlverblue and have just encountered again in a fresh Fedora 36 Silverblue install.
As suggested above in this thread, what fixed it seems to be installing one more flatpak from Software.

I’m seeing this issue with a fresh Fedora 36 Silverblue installation. None of the suggested fixes have worked yet.

The only visible difference I’ve noticed on the system without icons is that GNOME Software shows “Fedora Flathub Selection (Flatpak)” for the iconless apps, while my desktop system shows “Flathub (Flatpak)”. I have enabled the full Flathub on both.

One other difference is that the iconless system is a fresh Fedora 36 Silverblue installation, while the desktop is upgraded from Fedora 35 Silverblue.

1 Like

Update: After another Flatpak update, the icons are now showing, even for the apps that didn’t update. Not sure what changed, but I had previously tried “flatpak repair” and other diagnostics to no avail.

I’m not sure, but I may have solved it by running sudo gtk-update-icon-cache -f /var/lib/flatpak/exports/share/icons/hicolor/ and sudo gtk4-update-icon-cache -f /var/lib/flatpak/exports/share/icons/hicolor/.


Confirmed solution for the described issue of a fresh silverblue 37 install.