F37 & KDE 5.27: screen doesn't dim nor turn off

Since updating to KDE 5.27 (Friday 2/17/2023 I believe) my laptop screen doesn’t dim nor turn off when inactive. Same behavior if on mains or battery power. I’ve tried shutting down and restarting, and changing the timeout values in system settings, all with no effect.

Known issue? (Search didn’t return anything similar.)

I’ve yet to try it on my desktop although I fear it may be the same - I remember being mildly alerted when I’d last been away and the screen was still on*. Will check.

Machine: Dell XPS 9520
CPU: i7-12700H
Memory: 32GB
GPU: Intel Iris Xe iGPU & RX 3050Ti (but the system won’t use it)
Screen: 4K panel

Machine recognizes when power is unplugged.

I should boot into Windows 11 (it’s always useful to keep it around for sanity checks!) and ensure it’s not a hardware problem, if I can find the BitLocker recovery key…

Addendum 1: Booted into Windows 11. It behaves as expected (including about 4 reboots for updating system bits - almost as bad as Fedora! (I kid!))

Addendum 2: Just tried this on a desktop machine (new AMD 7950X build) running Fedora 37. Luckily I hadn’t yet updated to KDE 5.27 so I could observe that the screen turned off after the 1 minute interval I set on KDE 5.26.5 and did not turn off after the same interval once I’d updated to and booted into the same system now running KDE 5.27.

Ladies and gentlemen, we got 'm! I would call that a reproducible scenario.

*Might not actually have been the same machine running the same system: I have many machines, all multi-boot, and I’ve been testing different configurations of (graphics) hardware and software recently. Also, I might not have been away long enough.

Having the same issue here on two laptops running Fedora 37 after updating to KDE 5.27. Screen will lock but not dim or turn off anymore.

I filed a bug in bugzilla - 2171349

1 Like

Ah ha! I switched to X11 (from Wayland) and the screen dimming and turning off after the specified timeout is back!

However there are other issues: the Plasma panel isn’t being scaled - I have a 4K laptop screen and it’s impossible to see if it’s not scaled to 200%. Most other things are now scaled correctly except the Plasma panel and the mouse and cursor. I may have to reload icons & pointers.

Tiny little mouse pointer is sooo cute! Not.

This was working correctly on X11 but now that I’ve updated to KDE 5.27.2 the behavior is broken on my laptop on both X11 and Wayland, on battery and plugged in.

Strange development: the behavior is now working as expected on X11. The only change I made between observing that it wasn’t working correctly and now is that I changed graphics platform from X11 to Wayland to test the behavior there, then I later changed back to X11. I changed platforms by way off logging off and on and changing the setting on the SDDM screen.

There was a fix for this that when applied, worked for me. This fix is in kf5-kidletime-5.103.0-2.fc37.

you can file a bug in kde bugzilla https://bugs.kde.org/

already did in bugzilla

you should have also give a link of that report so others can look into i hope.

I updated to the latest bits and this behavior is broken again: it seems that it’s disabled each time I update to new bits, and re-enabled after logging off and on and perhaps switching between Wayland and X11 as I did yesterday. It’s very frustrating.