Excessive transparency of Qt applications in Gnome44

Fedora 38, GNOME44, AMD video. In Qt applications such as Strawberry, I get a transparent menus like here (screenshot). As you can see, it’s too transparent and the menu is almost unreadable.
I can’t find where I control it and make such menus more readable…

1 Like

Dolphin: oc-ssr_20230920_123959|690x388

According to journald, in different apps this is accompanied by messages:

Wayland does not support QWindow::requestActivate()

07:50:08.033 WARN unknown This compositor does not support the Shadow interface

org.kde.kf5.kwindowsystem.kwayland: This compositor does not support the Shadow interface

– this is on wayland, didn’t yet examine it in X11; also, the messages are from Clementine, not Strawberry, but they are similar

Apps that use Qt have problems in a GTK environment and vice versa.
Do you know the differences between gnome and kde? – relevant because of org.kde.kf5.kwindowsystem.kwayland: This compositor does not support the Shadow interface

2 Likes

We need to narrow down the config/components that are involved here.

I’d test out X11 if possible. I’d also create a new user and see if the issue persists—that’ll tell us if it’s a system issue or some sort of user-config issue.

Another piece of detail: are these apps installed via RPMs or Flatpaks?

I’m on F39 here, Gnome with X11, and my QT apps look fine. I use Qutebrowser everyday and have also played with Falkon.

1 Like

X11 is also affected. More over, I’ve got older AMD videocard broken, and switched to newer Nvidia. With Nvidia I see it also! More over, I’ve upgraded to Fedora 39 with Gnome 45, and I see this also!

But I found out that Qt5ct software may do something with this as long as QT_QPA_PLATFORMTHEME=qt5ct variable is set. But it’s hard yet to understand how this Qt5ct works correctly.

X11 with Clementine (Strawberry) shows this: “Window manager warning: Invalid WM_TRANSIENT_FOR window 0x4000031 specified for 0x400019a.”

Apps are mostly installed via RPMs from repos, but Clementine is from RPM file from Github.

It’s related to “Blur” module in “Desktop Effects” section in KDE settings (turning it on/off changes the view)

Strawberry in Fedora 40 Gnome 46. When Strawberry is set to Adwaita style, the menus are not transparent. When I set Strawberry to Breeze style, the transparency appears as pictured above.