[Gnome, Wayland] QT programs: can't hide titlebar or show tray icon


QOwnNotes, Ghostwriter and Qbittorrent, all 3 QT programs I use regularly, won’t hide the titlebar when maximized and tray icons won’t appear. Flatpak or dnf install no difference.

I’ve had this PC running Arch with Gnome, I use Ubuntu (Gnome) on my laptop and I haven’t experienced this problem.

I’ve tried different themes. qgnomeplatform is installed. tried tweaking the .desktop files.

Those are the error messages:

QSocketNotifier: Can only be used with threads started with QThread

qt.qpa.wayland: Wayland does not support QWindow::requestActivate()

Any ideas?


edit: KeepassXC is QT also and has no such issues. No error messages on launch

Tray icons are not part of the Gnome design spec. You can install this extension to get tray icons to show in the top panel:

sudo dnf install gnome-shell-extension-appindicator

Would you clarify what you mean by “won’t hide the title bar”? Gnome apps don’t do that either so I’m not sure if that’s expected.

This seems to be a common issue—it needs fixing in Qt from what I know. I see a number of bugs about this:


1 Like

Hi, thanks for your answer!

I meant it doesn’t work with the necessary extensions installed, sorry about that.

Arch + Gnome 40 Wayland + needed extensions (be it Unite, tray icon reloaded etc… doesn’t matter) → tray icons show and maximized windows have no title bar.
Same for Ubuntu.

But for some reason it’s different in Fedora, even though everything seems to be identical.

This error message only appears in Fedora, so that might be the issue:
QSocketNotifier: Can only be used with threads started with QThread

gnome extensions are now managed by gnome-extensions-app where previously they were managed by gnome-tweaks. I had to install the extensions package when the change was made.

Maybe you need that package installed so things can be reconfigured the way you like.

I’m using the new extensions app already. Thanks though

I overlooked one thing. You mention wayland and I spoke of gnome but I use xorg. I have no experience with wayland since I have an nvidia GPU which only works with xorg.
You need to isolate this behavior to either xorg with gnome or wayland with gnome. Try using xorg and gnome to see if there is a difference. That can be selected from the gear icon in the lower right of the login screen

Yes it’s a Wayland issue (xorg no probs), but only happening in Fedora. Ubuntu/arch Gnome + Wayland are okay.

I was considering switching my laptop to fedora, but if I have to use xorg I don’t get the must have new gnome 40 gestures only availble in wayland


This works for me with wayland:


Thanks Tom

1 Like

Can you perhaps share a screenshot to show what you mean with the title bars? I’m using Qt apps here on Gnome + Wayland, and Gnome + X and in neither case are title bars hidden when they are maximised. Here’s Falkon, a Qt app, for example:

I use this extension

Here Fedora + X, using Falkon title bar is hidden.

Ubuntu + X will hide the title bar, and Ubuntu + Wayland too, but not Fedora + Wayland

I don’t know about Ubuntu—they don’t necessarily use upstream’s Gnome.

What version of Fedora and gnome are you on? The documentation says you need to install other packages.

dnf install xorg-x11-utils

Have you done this? If that does not work, it’s best to file a bug with the extension developer. Fedora and Gnome do not develop the extensions, so they can’t fix them if they’re not working as expected:


I have xorg-x11-utils installed.

Both Ubuntu and Fedora run Gnome 40.4.

Most other extensions with same functionality behave the same way (ubuntu & arch ok, fedora no), so I doubt it’s an issue on their part, but I could ask.

I’m starting to think it’s not worth the effort. I’ll keep running Ubuntu on my latpop for now and use Fedora with X on my desktop, and try again in a few months.

Thank for the help!

@tjdoyle Thanks. yeah I tried this one and it works but I had some issues with it

Did you find any solution? having the same problem