Electron apps don't run

Hi there!

So I upgraded from 38 to 39 and to my surprise no electron app seems to work.
Behavior doesn’t change whether on X or Wayland.
Only output I get from running them from the command line is “zsh: trace trap (core dumped)”.
Also tried flatpak but no luck, same behavior.
Even Chromium doesn’t start, which is a bit of a pickle.
No slack, no discord no nothing.
I’m running and intel CPU with intel iris xe graphics if that’s of any help, although it’s the same laptop that was working fine with 38.

I found this thread pointing to this proposed solution but no luck.

Can anybody help me troubleshoot this?

Electron, yeah …

I read you tried removing stale config/cache. Just to exclude this as a root cause: Can you set up a fresh user (account) and try there?

I see you use zsh as a login shell or at least on the terminal. What is your desktop environment?

I currently have a few electron apps working in F39 (X11/i3, intel gfx) but this wasn’t without hickups. So it is possible, and I don’t always know why :wink:

I did try with a new user, different DE and shell but the result is just the same.

I’m running i3 with zsh as my shell but tried with a new user under Gnome (both X and wayland) with bash as its shell but nothing seems to change the behavior in the least.

I also tried running these apps with the --no-sandbox option since I’ve read around the webs that it might be a fix but still nothing.

Well, here’s an update: I can’t share my screen (doesn’t matter if wayland or X) nor can my coworkers see my camera feed (even tho I do see it and I can see them) when video conferencing. I’m talking about firefox, since that’s the only thing that works (all chrome-based stuff doesn’t run).
This is honestly pretty troublesome.

I’m starting to think there might be some wayland backend stuff conflicting with X. I understand X is going away and I should be migrating over, but I really can’t afford to deal with this atm.

If anybody more knowledgeable can point me to a clean way to remove all wayland stuff from the system that would be great, since the installer didn’t really give me an option and I don’t really know how to find out if that is the root cause or not.

Firefox 122 workaround to fix Google Meet issue