Some XWayland applications don't display anything on Fedora 39 Beta

I just installed a fresh install of Fedora 39 on my Lenovo Yoga Slim 7, and I can’t seem to be able to run some applications through XWayland. They don’t display a window, there is just the icon, as visible in the attached screenshots.
The issue might be related to Electron - I can run Calibre through XWayland just fine (well, it’s blurry with fractional scaling, but that is expected), but not Discord or Spotify. I however can’t run even JetBrains IDEs, which are not Electron based, so it’s affecting other stuff too. Both RPM and Flatpak packages are affected by this. The applications don’t launch even if I edit their .desktop files to include the Wayland arguments.
Is there any solution to this? When I tried this previously on Fedora 38, everything worked just fine. Thank you for your help, I’ll be happy to provide any additional information.

I’ve had this issue sometimes and it is always when Nvidia kernel modules are not loaded. Chromium based apps open, but not show anything on igpu after restart and Nvidia modules are back and loaded all works fine. This I have seen on F38 workstation so not sure is it hardware acceleration issue since drivers not loaded.

I can confirm the same for discord and firefox flatpacks on my laptop (AMD GPU) after updating yesterday with updates testing enabled.

Firefox I was able to work around by using flat seal to set MOZ_ENABLE_WAYLAND=1 or enabling the X11 fallback session.

Edit, may want to clear the gpuCache,

1 Like

This is on an integrated AMD GPU, so it isn’t Nvidia related.

I tried running the commands for clearing the GPU cache but it makes no difference, even after a reboot. :frowning:

On my laptop:
Laptop is an integrated AMD GPU:
Device-1: AMD Rembrandt [Radeon 680M]
chrome flatpak I can start by adding --ozone-platform=wayland
discord appears to be a crash

window.created win3 "Discord"
blackbox: 2023-10-22T16:30:06.759Z 11 webContents.destroyed web2
[1022/] ptrace: Operation not permitted (1)
[WebContents] double crashed (reason: crashed, exitCode: 139)... RIP =(
blackbox: 2023-10-22T16:30:08.644Z 12 ❌ render-process-gone { reason: 'crashed', exitCode: 139 }
blackbox: 2023-10-22T16:30:08.655Z 13 window.close win1

On my desktop, I was able to start after downgrading mutter sudo dnf downgrade mutter
Downgrade mutter-45.0-9.fc39.x86_64 @fedora
Downgraded mutter-45.0-10.fc39.x86_64 @@System
Downgrade mutter-common-45.0-9.fc39.noarch @fedora
Downgraded mutter-common-45.0-10.fc39.noarch @@System

Looks like the mutter update was obsoleted … that’s what I get for running updates-testing :slight_smile:

– now I need figure out what I borked on my laptop.
EDIT: resetting permissions on flatseal resolved my laptop issues.

I downgraded two mutter packages, but it still wants to update to that “obsoleted” even after refreshing repositories… Why? Doesn’t making package “obsoleted” mean that it will be blocked from installation from now on?

I’m pretty sure that what was done only prevents it from going to stable from updates-testing. This is one of the risks of running newer builds or having the updates-testing repository enabled.

If you have updates-testing enabled, you can do
sudo dnf upgrade --refresh --exclude=mutter\*

You’ll want to periodically check to see if mutter gets an upgrade.
sudo dnf list mutter or sudo dnf info mutter


1 Like

Thanks for that :+1: I have also disabled automatic updates.
Do you know how to downgrade all packages from testing to stable including flatpacks? (I want to sync with ‘39’ stable when it will be relased)

sudo dnf distro-sync --refresh

I’m not sure about flatpaks.

I’m not sure this will be worth the trouble unless you have something else broken. The updates testing packages that meet the criteria should be pushed to stable once the final freeze is over.

I know this command, but I also have flatpaks installed from “testing” - They are new to me. Before I was using just RPMs, and world was simpler back then… :stuck_out_tongue_winking_eye: For now I will just stick to my setup, and will watch for better “mutter” package update. If some package is broken where can I find out before I will update again? searching bodhi is not intuitive…

This was caused by a broken mutter update. Please run

sudo dnf distrosync --refresh

to get back to latest versions. The broken mutter has been removed from updates-testing.

Also, at this point, updates-testing repo should be disabled by default, so only use it if you actually want to use it. If you have it enabled (see sudo dnf repolist) and don’t know why, you can disable it with

sudo dnf config-manager --set-disabled updates-testing

Thank you for investigating this, everyone.