Cherry pick gnome-shell from rawhide correctly

I’m running Fedora 30.
For debugging purposes I want to test the current gnome-shell 3.33 and mutter 3.33. So my idea was to cherry pick that from rawhide using
sudo dnf --enablerepo=rawhide --releasever=31 upgrade gnome-shell
which gives the following output

 Package                                Architecture  Version                  Repository      Size
 evolution                              x86_64        3.33.4-1.fc31            rawhide        3.7 M
 evolution-data-server                  x86_64        3.33.4-1.fc31            rawhide        2.2 M
 evolution-data-server-langpacks        noarch        3.33.4-1.fc31            rawhide        1.4 M
 evolution-langpacks                    noarch        3.33.4-1.fc31            rawhide        6.0 M
 folks                                  x86_64        1:0.13.1-1.fc31          rawhide        575 k
 gnome-calendar                         x86_64        3.33.1-3.fc31            rawhide        417 k
 gnome-clocks                           x86_64        3.32.0-2.fc31            rawhide        389 k
 gnome-initial-setup                    x86_64        3.33.4-1.fc31            rawhide        1.3 M
 gnome-settings-daemon                  x86_64        3.33.0-2.fc31            rawhide        1.0 M
 gnome-shell                            x86_64        3.33.3-1.fc31            rawhide        1.4 M
 gsettings-desktop-schemas              x86_64        3.33.0-1.fc31            rawhide        629 k
 libgweather                            x86_64        3.33.0-1.fc31            rawhide        2.8 M
 libical                                x86_64        3.0.5-1.fc31             rawhide        276 k
 libical-glib                           x86_64        3.0.5-1.fc31             rawhide        174 k
 mutter                                 x86_64        3.33.3-1.fc31            rawhide        2.5 M

Transaction Summary

So it looks like gnome-shell and mutter are correctly updated.

But after restarting gdm doesn’t start anymore. The screen stays black. Reverting the upgrade lets gdm start correctly again. The problem doesn’t appear with a clean rawhide installation.

Does anybody have an idea what I might have missed? Any additional packages?

Just out of curiosity, why not just upgrade all of it since you’re using rawhide which is a “bleeding edge” as it gets for Fedora, and you could be missing dependencies? You could try the -b option of dnf (best available versions).

Because otherwise I need a stable system (for my daily work) and only require the gnome-shell updates for extension development.

I’ve been looking at the “has already been finalized” errors that occur when changing the desktop background. This is one of several cases where there the target is destroyed in the onComplete function passed to addTween().

I’m sorry but I don’t get it :slight_smile:
How exactly does that help me?

Using virtualization for testing seems like the right approach in this case.


That’s how I did it in the end.
Anyway, I wanted to find out if I missed something obvious.

1 Like

Hi, @invisibleshadowghost! Out of curiosity, won’t the obvious step be to update gdm as well? Just guessing here.

And of course, you may need to update some lower lever libraries as well, and that can be easy to debug if you’re lucky (looking gdm’s logs, for example, optionally turning on debugging for gdm in it’s configuration) – or quite hard if you’re not :slight_smile:

Good idea. I have tried that as well, but it still doesn’t work.

So yes, it seems like something more lower

Not really.

Yes, this is probably what it is. The different versions of tools that make Gnome are now strongly linked in each version, so mixing and matching tools from different versions may not work. The API/ABI may change, so the version of libraries may change too which means tools that rely on a different version will not work. It’s why you’ll also notice that when a Gnome update occurs, all the tools/libraries are generally pushed as a single big update to ensure that users get all the required pieces at once:

(Click the builds tab)