Can't install gnome-tweak-tool on Silverblue Rawhide


#1

Hello everyone. I installed Silverblue Rawhide to play around with it and learn a bit. But I’m stuck at installing gnome-tweak-tool. When I do rpm-ostree install gnome-tweak-tool I get this:

[me@localhost ~]$ rpm-ostree install gnome-tweak-tool
Checking out tree 4eacb3a… done
Enabled rpm-md repositories: rawhide
rpm-md repo ‘rawhide’ (cached); generated: 2018-11-17T08:53:31Z
Importing metadata [=============] 100%
Resolving dependencies… failed
error: Base packages would be removed: gnome-shell-extension-alternate-tab-3.30.1-1.fc30.noarch

I think there might be a a way to delete conflicting package from base image, but it looks a little barbaric. So is there a more civilized way to get Gnome Tweaks?


#2

IMHO they ought to take the GNOME shell extensions out of the base - all of them. They’re packaged as flatpaks, and you can install them locally via the GNOME extension website.


#3

Wait, what? GNOME Software uses the normal extension installation system, not Flatpak. Unless I missed some major GNOME development…

Also, I think GNOME Tweak’s version conflicts with the shell itself, and the extensions also conflicting is just a side effect. Not quite sure, though.


#4

There are multiple ways to get the extensions - RPMs if they exist, via the website, or as flatpaks. My bias is towards minimal installs and containerized apps, especially on Silverblue. TBH I’d prefer an OpenBox / i3wm Silverblue over a GNOME one. :wink:


#5

I know about RPMs and the website, but I’m really curious about how you installed it via Flatpak?


#6

I thought I saw them in the Flatpak menu - maybe I was seeing double.


#7

try rpm-ostree upgrade --install gnome-tweak-tool and see if that works.


#8

Really, a minimal install would be one using your package manager, not
duplicating system files with a flatpak image.


#9

Alas, it didn’t work. It took almost half an hour, downloaded 700Mb and ended up with the same error.


#10

ok. found the issue which has caused our rawhide composes to not get signed (and thus not get published) for the past few days. If you try this again tomorrow then it should work.


#11

Thank you! Now it’s working. System was successfully updated and Gnome Tweak installed. Now there’s another issue, though. Several GNOME extensions installed through Gnome Applications are not working (Dash to Dock among them). Gnome Tweaks says that there’s an error loading them (no description of error whatsoever). Other extensions (Screenshot tool, AppIndicator) appear to be working fine.
All of these extensions worked fine before Gnome Tweaks installed.


#12

Glad that it’s working now. Can you select the answer that helped you most as the “solution” and open a new thread for the new issues?


#13

Dash to Dock has been finicky for me too - sometime it gives an error and I have to reboot to get it to work. There’s probably some state information that’s getting mangled / not cleared / not set properly.